Az előadás letöltése folymat van. Kérjük, várjon

Az előadás letöltése folymat van. Kérjük, várjon

1 MESTERSÉGES INTELLIGENCIA (ARTIFICIAL INTELLIGENCE) Kivonat Nagy Sára Fekete István Gregorics Tibor munkái alapján.

Hasonló előadás


Az előadások a következő témára: "1 MESTERSÉGES INTELLIGENCIA (ARTIFICIAL INTELLIGENCE) Kivonat Nagy Sára Fekete István Gregorics Tibor munkái alapján."— Előadás másolata:

1 1 MESTERSÉGES INTELLIGENCIA (ARTIFICIAL INTELLIGENCE) Kivonat Nagy Sára Fekete István Gregorics Tibor munkái alapján

2 2 N királynő probléma reprezentáció állapot – egy állás (N x N-es mátrix) állapottér – lehetséges állások 1..N királynővel – mezők megcímkézése (KN, ütésben, szabad)  nem lehetnek ütésben álló KN-k  KN=N esetén célállapot művelet – 1 KN elhelyezése  ütésben álló mezők száma nő korlátozás kielégítés (constraint satisfaction) költség – minden megoldás költsége azonos (N hosszú műveletsorozat) kezdőállapot – üres tábla célállapot – N királynő a táblán

3 3 N királynő probléma reprezentációs gráf – inkrementális megfogalmazás

4 4 Heurisztikák az n-királynő problémára 1. Neminformált:  Diagonális és ptl-ps heurisztika  *  *  *  *  *  *  *  *  *  *  *  *  *  *  **      Diagonális heurisztika:      *  * 22 visszalépés 2 visszalépés0 visszalépés  *  *  **  *  * 3. reprezentáció mellett

5 5 Ariadne fonala  Visszalépéses keresés  visszalépés feltételei:  zsákutca, azaz végpontjából nem vezet tovább út  zsákutca torkolat, azaz végpontjából kivezető utak nem vezettek célba  kör, azaz végpontja megegyezik az út egy megelőző csúcsával  mélységi korlátnál hosszabb  terminálási feltétel:  az aktuális út végén megjelenik egy célcsúcs, vagy ha a startcsúcsból vissza akarunk lépni  sorrendi heurisztika, vágó heurisztika

6 6 CSÚCS, ÚJCSÚCS: reprezentációs gráf csúcsa SZABÁLYOK: lista kezdetben az összes szabály, de az AlkalmazhatóSzabályok operátor hozza létre NIL: Üres lista Első: Lista elő eleme Vége: Lista maradéka Fűz 1 elemet fűz a lista elé Rekurzív eljárás visszalépés1(CSÚCS) 1. HA cél(CSÚCS) akkor visszatér(NIL) 2. Szabályok :=AlkalmazhatóSzabályok(CSÚCS) 3. Talált:=hamis 4. Ciklus amíg nem (üres(Szabályok) vagy Talált) 5. R :=elso(szabályok); szabályok :=vége(szabályok) 6. Újcsúcs :=R(CSÚCS) 7. Szablista :=visszalépés1(Újcsúcs) 8. ha szablista ≠hiba akkor Talált :=igaz 9. Ciklus vége 10. Ha Talált akkor visszatér(fűz(R,Szablista)) 11. különben visszatér(hiba) 12. Eljárás vége Visszalépéses keresés

7 7 Rekurzív eljárás visszalépés1(CSÚCS) 1. HA cél(CSÚCS) akkor visszatér(NIL) 2. Szabályok :=AlkalmazhatóSzabályok(CSÚCS) 3. Talált:=hamis 4. Ciklus amíg nem ( üres( Szabályok ) vagy Talált ) 5. R :=elso(szabályok); szabályok :=vége(szabályok) 6. Újcsúcs :=R(CSÚCS) 7. Szablista :=visszalépés1(Újcsúcs) 8. ha szablista ≠hiba akkor Talált :=igaz 9. Ciklus vége 10. Ha Talált akkor visszatér(fűz(R,Szablista)) 11. különben visszatér(hiba) 12. Eljárás vége Meghívása: visszalépés1(STARTCSÚCS) Visszalépéses keresés

8 8  A visszalépés1 algoritmus terminálása nem garantált  végtelen, vagy  kört tartalmazó gráfon  Javítás:  Mélységi korlát bevezetése  Csak be nem járt csúcsok vizsgálata Visszalépéses keresés 2.

9 9 4 királynő – visszalépéses kereséssel


Letölteni ppt "1 MESTERSÉGES INTELLIGENCIA (ARTIFICIAL INTELLIGENCE) Kivonat Nagy Sára Fekete István Gregorics Tibor munkái alapján."

Hasonló előadás


Google Hirdetések