Az előadás letöltése folymat van. Kérjük, várjon

Az előadás letöltése folymat van. Kérjük, várjon

Megszámlálás Elemi algoritmusok 1. Emlékeztető  Az eldöntés algoritmusa: i:=1 Ciklus amíg i<=N és e[i] nem jó i:=i+1 Ciklus vége Ha i<=N akkor talált.

Hasonló előadás


Az előadások a következő témára: "Megszámlálás Elemi algoritmusok 1. Emlékeztető  Az eldöntés algoritmusa: i:=1 Ciklus amíg i<=N és e[i] nem jó i:=i+1 Ciklus vége Ha i<=N akkor talált."— Előadás másolata:

1 Megszámlálás Elemi algoritmusok 1

2 Emlékeztető  Az eldöntés algoritmusa: i:=1 Ciklus amíg i<=N és e[i] nem jó i:=i+1 Ciklus vége Ha i<=N akkor talált egyébként nem talált 2

3 Példa  Számoljuk meg, egy felhasználó által adott stringben hány ‚a’ betű van! ”papamaci” 3 Mutató i Számláló db0123

4 C# megoldás int i; string szoveg; szoveg = Console.ReadLine(); int db = 0; for (i = 0; i < szoveg.Length; i++) { if (szoveg[i] == ’a’) db++; } Console.WriteLine(db); 4

5 Emlékeztető  Tömb feltöltése véletlenszámokkal int i,elemszam = 5; int[] tomb = new int[elemszam]; Random r = new Random(); for (i = 0; i < elemszam; i++) { tomb[i] = r.Next(100); } //0-100 ig kiválasztott számokkal tölt fel 5

6 Feladat  Határozzuk meg, hogy egy egész számokat tartalmazó tömbben hány páros szám van! 6


Letölteni ppt "Megszámlálás Elemi algoritmusok 1. Emlékeztető  Az eldöntés algoritmusa: i:=1 Ciklus amíg i<=N és e[i] nem jó i:=i+1 Ciklus vége Ha i<=N akkor talált."

Hasonló előadás


Google Hirdetések