Az előadás letöltése folymat van. Kérjük, várjon

Az előadás letöltése folymat van. Kérjük, várjon

Eljaras linearis_kereses(adatok[],n) Szamlalo:=0; Megvan:=hamis; Ciklus amíg (szamlalo0) akkor megvan:=igaz; szamlalo:=szamlalo+1;

Hasonló előadás


Az előadások a következő témára: "Eljaras linearis_kereses(adatok[],n) Szamlalo:=0; Megvan:=hamis; Ciklus amíg (szamlalo0) akkor megvan:=igaz; szamlalo:=szamlalo+1;"— Előadás másolata:

1 Eljaras linearis_kereses(adatok[],n) Szamlalo:=0; Megvan:=hamis; Ciklus amíg (szamlalo0) akkor megvan:=igaz; szamlalo:=szamlalo+1; Ciklus vege; Ki: megvan; Eljaras vege; 0 0 hamis 2 1 igaz -1 2 igaz

2 Eljaras maximumkivalasztas(adatok[],n) Szamlalo:=0; Maximum:=adatok[0]; Ciklus amíg (szamlalomaximum) akkor maximum:=adatok[szamlalo]; hanyadik:=szamlalo; szamlalo:=szamlalo+1; Ciklus vege; Ki: maximum, hanyadik; Eljaras vege;

3 Eljaras minimumkivalasztas(adatok[],n) Szamlalo:=0; Minimum:=adatok[0]; Ciklus amíg (szamlalo

4 Összegzés Adott egy n elemű e sorozat, vagy tömb. Határozzuk meg az elemek összegét! A végeredményt s tartalmazza. s:=0; ciklus i:=1 - től n - ig s:=s + e[i]; ciklus vége Ki(s);

5 Példa összegzésre Határozza meg az [1, 100] intervallumba eső páros számok összegét! Osszeg:=0; Ciklus i:=1 - től ig Ha (i mod 2 = 0) akkor /a mod a maradékképzés operátora, a feltétel /arra a osszeg:=osszeg + i; /matematikai igazságra utal, hogy a páros /számok 2-vel Elágazás vége /maradék nélkül oszthatóak Ciklus vége Ki(osszeg);

6 Megszámlálás Adott egy intervallumon vagy tömbön értelmezett T tulajdonság. Határozzuk meg, hogy hány T tulajdonságú elem van a sorozatban vagy a tömbben. db:=0; Ciklus i: = 1 - től n - ig Ha (e[i] T tulajdonságú) akkor db:=db + 1; Elágazás vége Ciklus vége Ki (db);


Letölteni ppt "Eljaras linearis_kereses(adatok[],n) Szamlalo:=0; Megvan:=hamis; Ciklus amíg (szamlalo0) akkor megvan:=igaz; szamlalo:=szamlalo+1;"

Hasonló előadás


Google Hirdetések