Az előadás letöltése folymat van. Kérjük, várjon

Az előadás letöltése folymat van. Kérjük, várjon

TÁMOP 2.2.3-07/1-2F-2008-0011 Felkészítés szakmai vizsgára, informatika területre 1144-06 modulhoz II/14. évfolyam Az interaktív vizsga jellegzetes feladattípusainak.

Hasonló előadás


Az előadások a következő témára: "TÁMOP 2.2.3-07/1-2F-2008-0011 Felkészítés szakmai vizsgára, informatika területre 1144-06 modulhoz II/14. évfolyam Az interaktív vizsga jellegzetes feladattípusainak."— Előadás másolata:

1 TÁMOP /1-2F Felkészítés szakmai vizsgára, informatika területre modulhoz II/14. évfolyam Az interaktív vizsga jellegzetes feladattípusainak áttekintése Balogh Zoltán 2009

2 A vizsgarész Interaktív vizsgafeladat példafeladatai

3 1. feladat Mely állítások igazak? Jelölje be az összes jó választ! 1.A nyilvános deklarációt mindenki látja, tehát az osztály egy példányának használója és az osztály utódja is. 2.A védett deklarációt láthatja, aki megszólítja az osztály egy objektumát. 3.A privát deklarációt kizárólag az osztály és annak leszármazottjai látják. 4.A védett deklaráció erősebb védelem, mint a privát.

4 2. feladat Mely állítások igazak? Jelölje be az összes helyes választ! 1.A felhasználói felületen egyszerre maximum annyi komponens lehet fókuszban, ahány alkalmazás fut. 2.Egy komponens általában látványban megváltozik, amikor fókuszban van. 3.Ha egy komponens látszik és engedélyezett, akkor mindenképpen fókuszban van. 4.Billentyűesemény csak a fókuszban levő komponensen keletkezhet.

5 3. feladat Adva van egy növekvően tömb, amelyben benne van a keresett elem. Mely állítások igazak? Jelölje be az összes jó választ! 1.A tömb végéig kell keresni. 2.Abbahagyhatjuk a keresést, ha találtunk a keresett elemnél kisebb elemet. 3.Abbahagyhatjuk a keresést, ha találtunk az elemnél nagyobb elemet. 4.Ha az elemek objektumok, akkor azok osztályában kötelezően szerepelnie kell egy olyan metódusnak, amely eldönti, melyik objektum van előbb a rendezettségben.

6 4. feladat Mely állítások igazak? Jelölje be az összes jó választ! 1.Végjelig való feldolgozás esetén a végjel feldolgozása a sorozat elemeként logikai hibát eredményez. 2.A megszámlálás algoritmusában egy sorozat valamilyen adott tulajdonságú elemeit számoljuk meg. 3.A minimumszámítás algoritmusában, ha a sorozat elemeit mindig egy addigi minimumhoz hasonlítjuk, akkor vagy az első számról, vagy egy olyan kicsi számról kell indulnunk, amilyen biztosan nincs a sorozatban. 4.A maximumszámítás algoritmusában, ha a sorozat elemeit mindig egy addigi maximumhoz hasonlítjuk, akkor vagy az első számról, vagy egy olyan kicsi számról kell indulnunk, amilyen biztosan nincs a sorozatban.

7 5. feladat A következő algoritmus egy X[N] és egy Y[M] tömb elemeit egyesíti egy Z[N+M] tömbbe. Hol vannak hibák az algoritmusban? Javítsa ki! 15 pont Ciklus I=1-től N-ig Z[I]:=X[I] Ciklus vége NM:=N Ciklus J=1-től M-ig J:=1 I:=1 5 pont Ciklus amíg I Y[J] I:=I+1 Ciklus vége Ha I N 5 pont akkor NM:=NM+1 5 pont Z[NM]:=Y[J] Ciklus vége

8 6. feladat Készítse el a következő programot az Ön által tanult programozási nyelven! 70 pont Egy „adatok.txt” nevű szöveges állományban egy ax 2 + bx + c = 0 másodfokú egyenlet együtthatóit tároljuk Például az x 2 + 3x -10 = 0 egyenlet együtthatói a = 1, b = 3, c = Hozza létre ezt az állományt szövegszerkesztővel, és vegyen fel benne 3 adatot. A program induláskor olvassa be a fájlban lévő adatokat 15 pont, majd ezek segítségével számítsa ki az egyenlet megoldásait. 40 pont A képernyőre listázza ki az együtthatókat, a megoldások számát és az eredményeket. 15 pont Feltételezzük, hogy a fájl valóban egy másodfokú egyenlet adatait tartalmazza, így ezt nem kell ellenőrizni a programnak.


Letölteni ppt "TÁMOP 2.2.3-07/1-2F-2008-0011 Felkészítés szakmai vizsgára, informatika területre 1144-06 modulhoz II/14. évfolyam Az interaktív vizsga jellegzetes feladattípusainak."

Hasonló előadás


Google Hirdetések