Az előadás letöltése folymat van. Kérjük, várjon

Az előadás letöltése folymat van. Kérjük, várjon

Spregoval tanultam táblázatkezelést Csernoch Mária, Simon Klaudia, Brósch Éva, Kiss Éva Debreceni Egyetem Informatikai Kar.

Hasonló előadás


Az előadások a következő témára: "Spregoval tanultam táblázatkezelést Csernoch Mária, Simon Klaudia, Brósch Éva, Kiss Éva Debreceni Egyetem Informatikai Kar."— Előadás másolata:

1 Spregoval tanultam táblázatkezelést Csernoch Mária, Simon Klaudia, Brósch Éva, Kiss Éva Debreceni Egyetem Informatikai Kar

2 Milyen függvényeket ismernek a hallgatók? Sorolja fel azt a 15 táblázatkezelő függvényt, amelyekről úgy gondolja, hogy ismeretükre feltétlenül szükség van! „15 függvény” – hallgatók 99 darab függvény – tankönyvek 171 függvény

3 Sprego adsheet Le

4 Sprego függvények Sprego 1Sprego 2Sprego 3 SZUM () ÁTLAG () MIN () MAX () BAL () JOBB () HOSSZ () SZÖVEG. KERES () HA ()

5 Sprego függvények Sprego 1Sprego 2Sprego 3 SZUM () INDEX () ÁTLAG () HOL. VAN () MIN () HIBÁS () MAX () BAL () JOBB () HOSSZ () SZÖVEG. KERES () HA ()

6 Sprego függvények Sprego 1Sprego 2Sprego 3 SZUM () INDEX () KICSI () ÁTLAG () HOL. VAN () NAGY () MIN () HIBÁS () SOR () MAX () OSZLOP () BAL () ÉS () JOBB () VAGY () HOSSZ () NEM () SZÖVEG. KERES () HELYETTE () HA () ELTOLÁS () TRANSZPONÁLÁS () KEREKÍTÉS () VÉL () INT ()

7 Függvényeken túl… Összetett függvényekTömbképletek

8 List of states and territories of the United States http://en.wikipedia.org/wiki/List_of_states_and_territories_of_the_United_States

9 State Jellemzők – minden név előtt (balra) szóköz – nevek végén alkalmanként [X] sztring Algoritmus – szóközök eltávolítása  szóközmentes sztring kivágása és kiíratása új sztring hosszának meghatározása – [X] sztring eltávolítása  [X]-mentes sztring kivágása és kiíratása (a szóközmentes sztringből) – államok szétválogatása az alapján, hogy van-e a végén [X] sztring vagy nincs Kódolás

10 Kódolás – State – Szóközök 8 7 9 12 10 6 9 17 13 16 5 8 10 9 { } =HOSSZ(A2:A51)

11 Kódolás – Szóközök 8 7 7 6 9 8 12 11 10 9 6 5 9 8 17 16 13 12 16 15 5 4 8 7 10 9 98 =HOSSZ(A2:A51) 8 7 9 12 10 6 9 17 13 16 5 8 10 9 -1{ }

12 Kódolás – Szóközök 8 7Alabama 7 6Alaska 9 8Delaware 12 11Kentucky[C] 10 9Louisiana 6 5Maine 9 8Maryland 17 16Massachusetts[D] 13 12North Dakota 16 15Rhode Island[F] 5 4Utah 8 7Vermont 10 9Wisconsin 98Wyoming =HOSSZ(A2:A51)-1 JOBB(A2:A51; ) { } 8 7 7 6 9 8 12 11 10 9 6 5 9 8 17 16 13 12 16 15 5 4 8 7 10 9 98

13 Kódolás – [X] 8 7 9 12 10 6 9 17 13 16 5 8 10 8 { } =HOSSZ(A2:A51)

14 Kódolás – [X] 8 4 7 3 9 5 12 8 10 6 6 2 9 5 17 13 9 16 12 5 1 8 4 10 6 8 4 -4{ } =HOSSZ(A2:A51) 8 7 9 12 10 6 9 17 13 16 5 8 10 8

15 Kódolás – [X] 8 4Alab 7 3Ala 9 5Delaw 12 8Kentucky 10 6Louisi 6 2Ma 9 5Maryl 17 13Massachusetts 13 9North Dak 16 12Rhode Island 5 1U 8 4Verm 10 6Wiscon 8 4Wyom =HOSSZ(A2:A51)-4 { } = JOBB(A2:A51;HOSSZ(A2:A51)-1); ) =BAL( ; ) 8 4 7 3 9 5 12 8 10 6 6 2 9 5 17 13 9 16 12 5 1 8 4 10 6 8 4

16 Kódolás – két eset szétválogatása #ÉRTÉK! 10 #ÉRTÉK! 15 #ÉRTÉK! 14 #ÉRTÉK! =SZÖVEG.KERES("[";A2:A51){ }

17 Kódolás – két eset szétválogatása #ÉRTÉK! 10 #ÉRTÉK! 15 #ÉRTÉK! 14 #ÉRTÉK! IGAZ #ÉRTÉK!IGAZ #ÉRTÉK!IGAZ 10HAMIS #ÉRTÉK!IGAZ #ÉRTÉK!IGAZ #ÉRTÉK!IGAZ 15HAMIS #ÉRTÉK!IGAZ 14HAMIS #ÉRTÉK!IGAZ #ÉRTÉK!IGAZ #ÉRTÉK!IGAZ #ÉRTÉK!IGAZ =SZÖVEG.KERES("[";A2:A51) = (SZÖVEG.KERES("[";A2:A51)) { } =HIBÁS( )

18 Kódolás – két eset szétválogatása #ÉRTÉK!IGAZ #ÉRTÉK!IGAZ #ÉRTÉK!IGAZ 10HAMIS #ÉRTÉK!IGAZ #ÉRTÉK!IGAZ #ÉRTÉK!IGAZ 15HAMIS #ÉRTÉK!IGAZ 14HAMIS #ÉRTÉK!IGAZ #ÉRTÉK!IGAZ #ÉRTÉK!IGAZ #ÉRTÉK!IGAZ =HIBÁS(SZÖVEG.KERES("[";A2:A51)) =HA( ;"";""){ } #ÉRTÉK!IGAZ #ÉRTÉK!IGAZ #ÉRTÉK!IGAZ 10HAMIS #ÉRTÉK!IGAZ #ÉRTÉK!IGAZ #ÉRTÉK!IGAZ 15HAMIS #ÉRTÉK!IGAZ 14HAMIS #ÉRTÉK!IGAZ #ÉRTÉK!IGAZ #ÉRTÉK!IGAZ #ÉRTÉK!IGAZ

19 #ÉRTÉK!IGAZ #ÉRTÉK!IGAZ #ÉRTÉK!IGAZ 10HAMIS #ÉRTÉK!IGAZ #ÉRTÉK!IGAZ #ÉRTÉK!IGAZ 15HAMIS #ÉRTÉK!IGAZ 14HAMIS #ÉRTÉK!IGAZ #ÉRTÉK!IGAZ #ÉRTÉK!IGAZ #ÉRTÉK!IGAZ #ÉRTÉK!IGAZAlabama #ÉRTÉK!IGAZAlaska #ÉRTÉK!IGAZDelaware 10HAMIS #ÉRTÉK!IGAZLouisiana #ÉRTÉK!IGAZMaine #ÉRTÉK!IGAZMaryland 15HAMIS #ÉRTÉK!IGAZNorth Dakota 14HAMIS #ÉRTÉK!IGAZUtah #ÉRTÉK!IGAZVermont #ÉRTÉK!IGAZWisconsin #ÉRTÉK!IGAZWyoming Kódolás – két eset szétválogatása #ÉRTÉK!IGAZ #ÉRTÉK!IGAZ #ÉRTÉK!IGAZ 10HAMIS #ÉRTÉK!IGAZ #ÉRTÉK!IGAZ #ÉRTÉK!IGAZ 15HAMIS #ÉRTÉK!IGAZ 14HAMIS #ÉRTÉK!IGAZ #ÉRTÉK!IGAZ #ÉRTÉK!IGAZ #ÉRTÉK!IGAZ =HA(HIBÁS(SZÖVEGKERES("[";A2:A51));””;””) =HA(HIBÁS(SZÖVEG.KERES("[";A2:A51)); ;"") JOBB(A2:A51;HOSSZ(A2:A51)-1) { }

20 Kódolás – két eset szétválogatása #ÉRTÉK!IGAZAlabama #ÉRTÉK!IGAZAlaska #ÉRTÉK!IGAZDelaware 10HAMIS Kentucky #ÉRTÉK!IGAZLouisiana #ÉRTÉK!IGAZMaine #ÉRTÉK!IGAZMaryland 15HAMIS Massachusetts #ÉRTÉK!IGAZNorth Dakota 14HAMIS Rhode Island #ÉRTÉK!IGAZUtah #ÉRTÉK!IGAZVermont #ÉRTÉK!IGAZWisconsin #ÉRTÉK!IGAZWyoming =HA(HIBÁS(SZÖVEG.KERES("[";A2:A51)); JOBB(A2:A51;HOSSZ(A2:A51)-1);””) BAL(JOBB(A2:A51;HOSSZ(A2:A51)-1);HOSSZ(A2:A51)-4)) { } #ÉRTÉK!IGAZAlabama #ÉRTÉK!IGAZAlaska #ÉRTÉK!IGAZDelaware 10HAMIS #ÉRTÉK!IGAZLouisiana #ÉRTÉK!IGAZMaine #ÉRTÉK!IGAZMaryland 15HAMIS #ÉRTÉK!IGAZNorth Dakota 14HAMIS #ÉRTÉK!IGAZUtah #ÉRTÉK!IGAZVermont #ÉRTÉK!IGAZWisconsin #ÉRTÉK!IGAZWyoming =HA(HIBÁS(SZÖVEG.KERES("[";A2:A51)); JOBB(A2:A51;HOSSZ(A2:A51)-1); )

21 Population Jellemzők – vesszők száma 1 vessző: az eredeti egész szám ezred része 2 vessző: sztring Algoritmus – annak eldöntése, hogy szám vagy sztring – vessző eltávolítása Kódolás

22 Kódolás – Population { } =G2:G51*1000 #ÉRTÉK! 735132 925749 #ÉRTÉK! 723393 #ÉRTÉK! 626630 #ÉRTÉK! 582658

23 Kódolás – Population =G2:G51*1000 = G2:G51*1000 =HIBÁS( ) { } #ÉRTÉK!IGAZ 735132HAMIS 925749HAMIS #ÉRTÉK!IGAZ #ÉRTÉK!IGAZ #ÉRTÉK!IGAZ #ÉRTÉK!IGAZ #ÉRTÉK!IGAZ 723393HAMIS #ÉRTÉK!IGAZ #ÉRTÉK!IGAZ 626630HAMIS #ÉRTÉK!IGAZ 582658HAMIS #ÉRTÉK! 735132 925749 #ÉRTÉK! 723393 #ÉRTÉK! 626630 #ÉRTÉK! 582658

24 Kódolás – Population = HIBÁS(G2:G51*1000) =HA(HIBÁS(G2:G51*1000);;G2:G51*1000) #ÉRTÉK!IGAZ0 735132HAMIS735132 925749HAMIS925749 #ÉRTÉK!IGAZ0 #ÉRTÉK!IGAZ0 #ÉRTÉK!IGAZ0 #ÉRTÉK!IGAZ0 #ÉRTÉK!IGAZ0 723393HAMIS723393 #ÉRTÉK!IGAZ0 #ÉRTÉK!IGAZ0 626630HAMIS626630 #ÉRTÉK!IGAZ0 582658HAMIS582658 #ÉRTÉK!IGAZ 735132HAMIS 925749HAMIS #ÉRTÉK!IGAZ #ÉRTÉK!IGAZ #ÉRTÉK!IGAZ #ÉRTÉK!IGAZ #ÉRTÉK!IGAZ 723393HAMIS #ÉRTÉK!IGAZ #ÉRTÉK!IGAZ 626630HAMIS #ÉRTÉK!IGAZ 582658HAMIS

25 Kódolás – Population =HA(HIBÁS(G2:G51*1000);;G2:G51*1000) = HELYETTE(G2:G51;",";"") ) { } #ÉRTÉK!IGAZ04833722 735132HAMIS735132 925749HAMIS925749 #ÉRTÉK!IGAZ04395295 #ÉRTÉK!IGAZ04625470 #ÉRTÉK!IGAZ01328302 #ÉRTÉK!IGAZ05928814 #ÉRTÉK!IGAZ06692824 723393HAMIS723393 #ÉRTÉK!IGAZ01051511 #ÉRTÉK!IGAZ02900872 626630HAMIS626630 #ÉRTÉK!IGAZ05742713 582658HAMIS582658 #ÉRTÉK!IGAZ0 735132HAMIS735132 925749HAMIS925749 #ÉRTÉK!IGAZ0 #ÉRTÉK!IGAZ0 #ÉRTÉK!IGAZ0 #ÉRTÉK!IGAZ0 #ÉRTÉK!IGAZ0 723393HAMIS723393 #ÉRTÉK!IGAZ0 #ÉRTÉK!IGAZ0 626630HAMIS626630 #ÉRTÉK!IGAZ0 582658HAMIS582658

26 Kódolás – Population #ÉRTÉK!IGAZ04833722 735132HAMIS735132 925749HAMIS925749 #ÉRTÉK!IGAZ04395295 #ÉRTÉK!IGAZ04625470 #ÉRTÉK!IGAZ01328302 #ÉRTÉK!IGAZ05928814 #ÉRTÉK!IGAZ06692824 723393HAMIS723393 #ÉRTÉK!IGAZ01051511 #ÉRTÉK!IGAZ02900872 626630HAMIS626630 #ÉRTÉK!IGAZ05742713 582658HAMIS582658 =HA(HIBÁS(G2:G51*1000); HELYETTE(G2:G51;",";""); G2:G51*1000) *1 { } #ÉRTÉK!IGAZ04833722 735132HAMIS735132 925749HAMIS925749 #ÉRTÉK!IGAZ04395295 #ÉRTÉK!IGAZ04625470 #ÉRTÉK!IGAZ01328302 #ÉRTÉK!IGAZ05928814 #ÉRTÉK!IGAZ06692824 723393HAMIS723393 #ÉRTÉK!IGAZ01051511 #ÉRTÉK!IGAZ02900872 626630HAMIS626630 #ÉRTÉK!IGAZ05742713 582658HAMIS582658

27 Spregoval tanultam programozni Segít a logikus gondolkodás fejlesztésében. A függvények egymásba ágyazása az algoritmizálásra nevel. VKERES (), FKERES () függvények helyett sokkal érdekesebb volt az INDEX ( HOL. VAN ()) összetett függvényt használni, mert itt gondolkozni kellett rajta. Jobban átláthatók az univerzális alapfüggvények funkciói. Többféle kontextusban alkalmazhatóak az általános függvények. Ennek a használatához gondolkozni kell. Argumentumok tudatosabb használata. Későbbiekben használható táblázatkezelői tudás.


Letölteni ppt "Spregoval tanultam táblázatkezelést Csernoch Mária, Simon Klaudia, Brósch Éva, Kiss Éva Debreceni Egyetem Informatikai Kar."

Hasonló előadás


Google Hirdetések