Az előadás letöltése folymat van. Kérjük, várjon

Az előadás letöltése folymat van. Kérjük, várjon

Nevezetes algoritmusok. Összegzés tétele Összegzés tétele II. A tétel másik elterjedt neve Sorozatszámítás. Legyen adott az n elemű A sorozat. Összegezzük.

Hasonló előadás


Az előadások a következő témára: "Nevezetes algoritmusok. Összegzés tétele Összegzés tétele II. A tétel másik elterjedt neve Sorozatszámítás. Legyen adott az n elemű A sorozat. Összegezzük."— Előadás másolata:

1 Nevezetes algoritmusok

2 Összegzés tétele

3 Összegzés tétele II. A tétel másik elterjedt neve Sorozatszámítás. Legyen adott az n elemű A sorozat. Összegezzük a sorozat értékeit! A előálló összeget az s változó tartalmazza.

4 Összegzés s:=0 Ciklus i:=1-től 5-ig s:=s+tömb[i] Ciklus vége Ki(s) Tömb:

5 Összegzés s:=0 Ciklus i:=1-től 5-ig s:=s+tömb[i] Ciklus vége Ki(s) i = 0 s = Tömb:

6 Összegzés s:=0 Ciklus i:=1-től 5-ig s:=s+tömb[i] Ciklus vége Ki(s) i = 1 s = Tömb:

7 Összegzés s:=0 Ciklus i:=1-től 5-ig s:=s+tömb[i] Ciklus vége Ki(s) i = 1 s = Tömb:

8 Összegzés s:=0 Ciklus i:=1-től 5-ig s:=s+tömb[i] Ciklus vége Ki(s) i = 1 s = Tömb:

9 Összegzés s:=0 Ciklus i:=1-től 5-ig s:=s+tömb[i] Ciklus vége Ki(s) i = 2 s = Tömb:

10 Összegzés s:=0 Ciklus i:=1-től 5-ig s:=s+tömb[i] Ciklus vége Ki(s) i = 2 s = Tömb:

11 Összegzés s:=0 Ciklus i:=1-től 5-ig s:=s+tömb[i] Ciklus vége Ki(s) i = 2 s = Tömb:

12 Összegzés s:=0 Ciklus i:=1-től 5-ig s:=s+tömb[i] Ciklus vége Ki(s) i = 3 s = Tömb:

13 Összegzés s:=0 Ciklus i:=1-től 5-ig s:=s+tömb[i] Ciklus vége Ki(s) i = 3 s = Tömb:

14 Összegzés s:=0 Ciklus i:=1-től 5-ig s:=s+tömb[i] Ciklus vége Ki(s) i = 3 s = Tömb:

15 Összegzés s:=0 Ciklus i:=1-től 5-ig s:=s+tömb[i] Ciklus vége Ki(s) i = 4 s = Tömb:

16 Összegzés s:=0 Ciklus i:=1-től 5-ig s:=s+tömb[i] Ciklus vége Ki(s) i = 4 s = Tömb:

17 Összegzés s:=0 Ciklus i:=1-től 5-ig s:=s+tömb[i] Ciklus vége Ki(s) i = 4 s = Tömb:

18 Összegzés s:=0 Ciklus i:=1-től 5-ig s:=s+tömb[i] Ciklus vége Ki(s) i = 5 s = Tömb:

19 Összegzés s:=0 Ciklus i:=1-től 5-ig s:=s+tömb[i] Ciklus vége Ki(s) i = 5 s = Tömb:

20 Összegzés s:=0 Ciklus i:=1-től 5-ig s:=s+tömb[i] Ciklus vége Ki(s) i = 5 s = Tömb:

21 Összegzés s:=0 Ciklus i:=1-től 5-ig s:=s+tömb[i] Ciklus vége Ki(s) i = 5 s = Tömb:

22 Összegzés tétele III.

23 Példa Határozza meg az [1, 100] intervallumba eső páros számok összegét! Osszeg:=0; Ciklus i:=1 - től ig /a mod a maradékképzés operátora, a feltétel arra a matematikai Ha (i mod 2 = 0) akkor / igazságra utal, hogy a páros számok 2-vel maradék nélkül osszeg:=osszeg + i; /oszthatóak; Különben semmi; /üres utasítás; Elágazás vége Ciklus vége Ki(osszeg );

24

25 Kiválasztás tétele

26 Kiválasztás i:=1 Ciklus amíg tömb[i] mod 2 <> 0 i:=i+1 Ciklus vége Ki(i) Tömb:

27 Kiválasztás i:=1 Ciklus amíg tömb[i] mod 2 <> 0 i:=i+1 Ciklus vége Ki(i) i = Tömb:

28 Kiválasztás i:=1 Ciklus amíg tömb[i] mod 2 <> 0 i:=i+1 Ciklus vége Ki(i) i = Tömb:

29 Kiválasztás i:=1 Ciklus amíg tömb[i] mod 2 <> 0 i:=i+1 Ciklus vége Ki(i) i = 1 Tömb[i] mod 2 <>0 ? igaz Tömb:

30 Kiválasztás i:=1 Ciklus amíg tömb[i] mod 2 <> 0 i:=i+1 Ciklus vége Ki(i) i = 2 Tömb[i] mod 2 <>0 ? igaz Tömb:

31 Kiválasztás i:=1 Ciklus amíg tömb[i] mod 2 <> 0 i:=i+1 Ciklus vége Ki(i) i = 2 Tömb[i] mod 2 <>0 ? igaz Tömb:

32 Kiválasztás i:=1 Ciklus amíg tömb[i] mod 2 <> 0 i:=i+1 Ciklus vége Ki(i) i = 2 Tömb[i] mod 2 <>0 ? igaz Tömb:

33 Kiválasztás i:=1 Ciklus amíg tömb[i] mod 2 <> 0 i:=i+1 Ciklus vége Ki(i) i = 3 Tömb[i] mod 2 <>0 ? igaz Tömb:

34 Kiválasztás i:=1 Ciklus amíg tömb[i] mod 2 <> 0 i:=i+1 Ciklus vége Ki(i) i = 3 Tömb[i] mod 2 <>0 ? igaz Tömb:

35 Kiválasztás i:=1 Ciklus amíg tömb[i] mod 2 <> 0 i:=i+1 Ciklus vége Ki(i) i = 3 Tömb[i] mod 2 <>0 ? igaz Tömb:

36 Kiválasztás i:=1 Ciklus amíg tömb[i] mod 2 <> 0 i:=i+1 Ciklus vége Ki(i) i = 4 Tömb[i] mod 2 <>0 ? igaz Tömb:

37 Kiválasztás i:=1 Ciklus amíg tömb[i] mod 2 <> 0 i:=i+1 Ciklus vége Ki(i) i = 4 Tömb[i] mod 2 <>0 ? igaz Tömb:

38 Kiválasztás i:=1 Ciklus amíg tömb[i] mod 2 <> 0 i:=i+1 Ciklus vége Ki(i) i = 4 Tömb[i] mod 2 <>0 ? hamis Tömb:

39 Kiválasztás i:=1 Ciklus amíg tömb[i] mod 2 <> 0 i:=i+1 Ciklus vége Ki(i) i = 4 Tömb[i] mod 2 <>0 ? hamis Tömb:

40 Kiválasztás tétele

41 Példa Válasszuk ki a 25-nél nagyobb számok közül az első héttel oszthatót! i:=25; /kezdőérték 25-re állítása; Ciklus amíg (i mod 7 <> 0) /ciklus amíg nem találunk olyan számot mely maradék nélkül osztható 7-tel; i:=i + 1; /a ciklusmagban az inkerementálás; Ciklus vége Ki(i); /érték kiírása (sorozat!);

42

43 Eldöntés tétele

44 Megszámlálás db:=0 Ciklus i:=1-től 5-ig Ha (tömb[i]mod 2 = 0) akkor db:=db+1 Elágazás vége Ciklus vége Ki(db) Tömb:

45 Megszámlálás db:=0 Ciklus i:=1-től 5-ig Ha (tömb[i]mod 2 = 0) akkor db:=db+1 Elágazás vége Ciklus vége Ki(db) Tömb: db = 0

46 Megszámlálás db:=0 Ciklus i:=1-től 5-ig Ha (tömb[i]mod 2 = 0) akkor db:=db+1 Elágazás vége Ciklus vége Ki(db) Tömb: db = 0 i = 1

47 Megszámlálás db:=0 Ciklus i:=1-től 5-ig Ha (tömb[i]mod 2 = 0) akkor db:=db+1 Elágazás vége Ciklus vége Ki(db) Tömb: db = 0 i = 1

48 Megszámlálás db:=0 Ciklus i:=1-től 5-ig Ha (tömb[i]mod 2 = 0) akkor db:=db+1 Elágazás vége Ciklus vége Ki(db) Tömb: db = 1 i = 1

49 Megszámlálás db:=0 Ciklus i:=1-től 5-ig Ha (tömb[i]mod 2 = 0) akkor db:=db+1 Elágazás vége Ciklus vége Ki(db) Tömb: db = 1 i = 1

50 Megszámlálás db:=0 Ciklus i:=1-től 5-ig Ha (tömb[i]mod 2 = 0) akkor db:=db+1 Elágazás vége Ciklus vége Ki(db) Tömb: db = 1 i = 1

51 Megszámlálás db:=0 Ciklus i:=1-től 5-ig Ha (tömb[i]mod 2 = 0) akkor db:=db+1 Elágazás vége Ciklus vége Ki(db) Tömb: db = 1 i = 2

52 Megszámlálás db:=0 Ciklus i:=1-től 5-ig Ha (tömb[i]mod 2 = 0) akkor db:=db+1 Elágazás vége Ciklus vége Ki(db) Tömb: db = 1 i = 2

53 Megszámlálás db:=0 Ciklus i:=1-től 5-ig Ha (tömb[i]mod 2 = 0) akkor db:=db+1 Elágazás vége Ciklus vége Ki(db) Tömb: db = 1 i = 2

54 Megszámlálás db:=0 Ciklus i:=1-től 5-ig Ha (tömb[i]mod 2 = 0) akkor db:=db+1 Elágazás vége Ciklus vége Ki(db) Tömb: db = 1 i = 2

55 Megszámlálás db:=0 Ciklus i:=1-től 5-ig Ha (tömb[i]mod 2 = 0) akkor db:=db+1 Elágazás vége Ciklus vége Ki(db) Tömb: db = 1 i = 3

56 Megszámlálás db:=0 Ciklus i:=1-től 5-ig Ha (tömb[i]mod 2 = 0) akkor db:=db+1 Elágazás vége Ciklus vége Ki(db) Tömb: db = 1 i = 3

57 Megszámlálás db:=0 Ciklus i:=1-től 5-ig Ha (tömb[i]mod 2 = 0) akkor db:=db+1 Elágazás vége Ciklus vége Ki(db) Tömb: db = 1 i = 3

58 Megszámlálás db:=0 Ciklus i:=1-től 5-ig Ha (tömb[i]mod 2 = 0) akkor db:=db+1 Elágazás vége Ciklus vége Ki(db) Tömb: db = 1 i = 3

59 Megszámlálás db:=0 Ciklus i:=1-től 5-ig Ha (tömb[i]mod 2 = 0) akkor db:=db+1 Elágazás vége Ciklus vége Ki(db) Tömb: db = 1 i = 4

60 Megszámlálás db:=0 Ciklus i:=1-től 5-ig Ha (tömb[i]mod 2 = 0) akkor db:=db+1 Elágazás vége Ciklus vége Ki(db) Tömb: db = 1 i = 4

61 Megszámlálás db:=0 Ciklus i:=1-től 5-ig Ha (tömb[i]mod 2 = 0) akkor db:=db+1 Elágazás vége Ciklus vége Ki(db) Tömb: db = 1 i = 4

62 Megszámlálás db:=0 Ciklus i:=1-től 5-ig Ha (tömb[i]mod 2 = 0) akkor db:=db+1 Elágazás vége Ciklus vége Ki(db) Tömb: db = 1 i = 4

63 Megszámlálás db:=0 Ciklus i:=1-től 5-ig Ha (tömb[i]mod 2 = 0) akkor db:=db+1 Elágazás vége Ciklus vége Ki(db) Tömb: db = 1 i = 5

64 Megszámlálás db:=0 Ciklus i:=1-től 5-ig Ha (tömb[i]mod 2 = 0) akkor db:=db+1 Elágazás vége Ciklus vége Ki(db) Tömb: db = 1 i = 5

65 Megszámlálás db:=0 Ciklus i:=1-től 5-ig Ha (tömb[i]mod 2 = 0) akkor db:=db+1 Elágazás vége Ciklus vége Ki(db) Tömb: db = 2 i = 5

66 Megszámlálás db:=0 Ciklus i:=1-től 5-ig Ha (tömb[i]mod 2 = 0) akkor db:=db+1 Elágazás vége Ciklus vége Ki(db) Tömb: db = 2 i = 5

67 Megszámlálás db:=0 Ciklus i:=1-től 5-ig Ha (tömb[i]mod 2 = 0) akkor db:=db+1 Elágazás vége Ciklus vége Ki(db) Tömb: db = 2 i = 5

68 Megszámlálás db:=0 Ciklus i:=1-től 5-ig Ha (tömb[i]mod 2 = 0) akkor db:=db+1 Elágazás vége Ciklus vége Ki(db) Tömb: db = 2 i = 5

69 Eldöntés tétele

70 Eldöntés i:=0 talált:=hamis Ciklus amíg ((nem talált) ÉS (i<5)) i:=i+1 talált:=(tömb[i] mod 2 = 0) Ciklus vége Ki(talált) Tömb:

71 Eldöntés i:=0 talált:=hamis Ciklus amíg ((nem talált) ÉS (i<5)) i:=i+1 talált:=(tömb[i] mod 2 = 0) Ciklus vége Ki(talált) Tömb: i = 0

72 Eldöntés i:=0 talált:=hamis Ciklus amíg ((nem talált) ÉS (i<5)) i:=i+1 talált:=(tömb[i] mod 2 = 0) Ciklus vége Ki(talált) Tömb: i = 0 talált = hamis

73 Eldöntés i:=0 talált:=hamis Ciklus amíg ((nem talált) ÉS (i<5)) i:=i+1 talált:=(tömb[i] mod 2 = 0) Ciklus vége Ki(talált) Tömb: i = 0 talált = hamis

74 Eldöntés i:=0 talált:=hamis Ciklus amíg ((nem talált) ÉS (i<5)) i:=i+1 talált:=(tömb[i] mod 2 = 0) Ciklus vége Ki(talált) Tömb: i = 1 talált = hamis

75 Eldöntés i:=0 talált:=hamis Ciklus amíg ((nem talált) ÉS (i<5)) i:=i+1 talált:=(tömb[i] mod 2 = 0) Ciklus vége Ki(talált) Tömb: i = 1 talált = hamis

76 Eldöntés i:=0 talált:=hamis Ciklus amíg ((nem talált) ÉS (i<5)) i:=i+1 talált:=(tömb[i] mod 2 = 0) Ciklus vége Ki(talált) Tömb: i = 1 talált = hamis

77 Eldöntés i:=0 talált:=hamis Ciklus amíg ((nem talált) ÉS (i<5)) i:=i+1 talált:=(tömb[i] mod 2 = 0) Ciklus vége Ki(talált) Tömb: i = 1 talált = hamis

78 Eldöntés i:=0 talált:=hamis Ciklus amíg ((nem talált) ÉS (i<5)) i:=i+1 talált:=(tömb[i] mod 2 = 0) Ciklus vége Ki(talált) Tömb: i = 2 talált = hamis

79 Eldöntés i:=0 talált:=hamis Ciklus amíg ((nem talált) ÉS (i<5)) i:=i+1 talált:=(tömb[i] mod 2 = 0) Ciklus vége Ki(talált) Tömb: i = 2 talált = hamis

80 Eldöntés i:=0 talált:=hamis Ciklus amíg ((nem talált) ÉS (i<5)) i:=i+1 talált:=(tömb[i] mod 2 = 0) Ciklus vége Ki(talált) Tömb: i = 2 talált = hamis

81 Eldöntés i:=0 talált:=hamis Ciklus amíg ((nem talált) ÉS (i<5)) i:=i+1 talált:=(tömb[i] mod 2 = 0) Ciklus vége Ki(talált) Tömb: i = 2 talált = hamis

82 Eldöntés i:=0 talált:=hamis Ciklus amíg ((nem talált) ÉS (i<5)) i:=i+1 talált:=(tömb[i] mod 2 = 0) Ciklus vége Ki(talált) Tömb: i = 3 talált = hamis

83 Eldöntés i:=0 talált:=hamis Ciklus amíg ((nem talált) ÉS (i<5)) i:=i+1 talált:=(tömb[i] mod 2 = 0) Ciklus vége Ki(talált) Tömb: i = 3 talált = igaz

84 Eldöntés i:=0 talált:=hamis Ciklus amíg ((nem talált) ÉS (i<5)) i:=i+1 talált:=(tömb[i] mod 2 = 0) Ciklus vége Ki(talált) Tömb: i = 3 talált = igaz

85 Eldöntés i:=0 talált:=hamis Ciklus amíg ((nem talált) ÉS (i<5)) i:=i+1 talált:=(tömb[i] mod 2 = 0) Ciklus vége Ki(talált) Tömb: i = 3 talált = igaz

86 Eldöntés i:=0 talált:=hamis Ciklus amíg ((nem talált) ÉS (i<5)) i:=i+1 talált:=(tömb[i] mod 2 = 0) Ciklus vége Ki(talált) Tömb: i = 3 talált = igaz

87 Eldöntés i:=0 talált:=hamis Ciklus amíg ((nem talált) ÉS (i<5)) i:=i+1 talált:=(tömb[i] mod 2 = 0) Ciklus vége Ki(talált) Tömb: i = 3 talált = igaz

88

89 Kiválogatás tétele

90 Kiválogatás tétele II.

91 Kiválogatás j:=0 Ciklus i:=1-től 5-ig Ha (tömb[i] mod 2 = 0) akkor j:=j+1 Cél[j]:=Forrás[i] Elágazás vége Ciklus vége Forrás: Cél:

92 Kiválogatás j:=0 Ciklus i:=1-től 5-ig Ha (tömb[i] mod 2 = 0) akkor j:=j+1 Cél[j]:=Forrás[i] Elágazás vége Ciklus vége Forrás: Cél: j = 0

93 Kiválogatás j:=0 Ciklus i:=1-től 5-ig Ha (tömb[i] mod 2 = 0) akkor j:=j+1 Cél[j]:=Forrás[i] Elágazás vége Ciklus vége Forrás: Cél: j = 0 i = 1

94 Kiválogatás j:=0 Ciklus i:=1-től 5-ig Ha (tömb[i] mod 2 = 0) akkor j:=j+1 Cél[j]:=Forrás[i] Elágazás vége Ciklus vége Forrás: Cél: j = 0 i = 1

95 Kiválogatás j:=0 Ciklus i:=1-től 5-ig Ha (tömb[i] mod 2 = 0) akkor j:=j+1 Cél[j]:=Forrás[i] Elágazás vége Ciklus vége Forrás: Cél: j = 0 i = 1

96 Kiválogatás j:=0 Ciklus i:=1-től 5-ig Ha (tömb[i] mod 2 = 0) akkor j:=j+1 Cél[j]:=Forrás[i] Elágazás vége Ciklus vége Forrás: Cél: j = 0 i = 1

97 Kiválogatás j:=0 Ciklus i:=1-től 5-ig Ha (tömb[i] mod 2 = 0) akkor j:=j+1 Cél[j]:=Forrás[i] Elágazás vége Ciklus vége Forrás: Cél: j = 0 i = 2

98 Kiválogatás j:=0 Ciklus i:=1-től 5-ig Ha (tömb[i] mod 2 = 0) akkor j:=j+1 Cél[j]:=Forrás[i] Elágazás vége Ciklus vége Forrás: Cél: j = 0 i = 2

99 Kiválogatás j:=0 Ciklus i:=1-től 5-ig Ha (tömb[i] mod 2 = 0) akkor j:=j+1 Cél[j]:=Forrás[i] Elágazás vége Ciklus vége Forrás: Cél: j = 0 i = 2

100 Kiválogatás j:=0 Ciklus i:=1-től 5-ig Ha (tömb[i] mod 2 = 0) akkor j:=j+1 Cél[j]:=Forrás[i] Elágazás vége Ciklus vége Forrás: Cél: j = 0 i = 2

101 Kiválogatás j:=0 Ciklus i:=1-től 5-ig Ha (tömb[i] mod 2 = 0) akkor j:=j+1 Cél[j]:=Forrás[i] Elágazás vége Ciklus vége Forrás: Cél: j = 0 i = 3

102 Kiválogatás j:=0 Ciklus i:=1-től 5-ig Ha (tömb[i] mod 2 = 0) akkor j:=j+1 Cél[j]:=Forrás[i] Elágazás vége Ciklus vége Forrás: Cél: j = 0 i = 3

103 Kiválogatás j:=0 Ciklus i:=1-től 5-ig Ha (tömb[i] mod 2 = 0) akkor j:=j+1 Cél[j]:=Forrás[i] Elágazás vége Ciklus vége Forrás: Cél: j = 1 i = 3

104 Kiválogatás j:=0 Ciklus i:=1-től 5-ig Ha (tömb[i] mod 2 = 0) akkor j:=j+1 Cél[j]:=Forrás[i] Elágazás vége Ciklus vége Forrás: Cél: j = 1 i = 3 12

105 Kiválogatás j:=0 Ciklus i:=1-től 5-ig Ha (tömb[i] mod 2 = 0) akkor j:=j+1 Cél[j]:=Forrás[i] Elágazás vége Ciklus vége Forrás: Cél: j = 1 i = 3 12

106 Kiválogatás j:=0 Ciklus i:=1-től 5-ig Ha (tömb[i] mod 2 = 0) akkor j:=j+1 Cél[j]:=Forrás[i] Elágazás vége Ciklus vége Forrás: Cél: j = 1 i = 3 12

107 Kiválogatás j:=0 Ciklus i:=1-től 5-ig Ha (tömb[i] mod 2 = 0) akkor j:=j+1 Cél[j]:=Forrás[i] Elágazás vége Ciklus vége Forrás: Cél: j = 1 i = 4 12

108 Kiválogatás j:=0 Ciklus i:=1-től 5-ig Ha (tömb[i] mod 2 = 0) akkor j:=j+1 Cél[j]:=Forrás[i] Elágazás vége Ciklus vége Forrás: Cél: j = 1 i = 4 12

109 Kiválogatás j:=0 Ciklus i:=1-től 5-ig Ha (tömb[i] mod 2 = 0) akkor j:=j+1 Cél[j]:=Forrás[i] Elágazás vége Ciklus vége Forrás: Cél: j = 1 i = 4 12

110 Kiválogatás j:=0 Ciklus i:=1-től 5-ig Ha (tömb[i] mod 2 = 0) akkor j:=j+1 Cél[j]:=Forrás[i] Elágazás vége Ciklus vége Forrás: Cél: j = 1 i = 4 12

111 Kiválogatás j:=0 Ciklus i:=1-től 5-ig Ha (tömb[i] mod 2 = 0) akkor j:=j+1 Cél[j]:=Forrás[i] Elágazás vége Ciklus vége Forrás: Cél: j = 1 i = 5 12

112 Kiválogatás j:=0 Ciklus i:=1-től 5-ig Ha (tömb[i] mod 2 = 0) akkor j:=j+1 Cél[j]:=Forrás[i] Elágazás vége Ciklus vége Forrás: Cél: j = 1 i = 5 12

113 Kiválogatás j:=0 Ciklus i:=1-től 5-ig Ha (tömb[i] mod 2 = 0) akkor j:=j+1 Cél[j]:=Forrás[i] Elágazás vége Ciklus vége Forrás: Cél: j = 2 i = 5 12

114 Kiválogatás j:=0 Ciklus i:=1-től 5-ig Ha (tömb[i] mod 2 = 0) akkor j:=j+1 Cél[j]:=Forrás[i] Elágazás vége Ciklus vége Forrás: Cél: j = 2 i =

115 Kiválogatás j:=0 Ciklus i:=1-től 5-ig Ha (tömb[i] mod 2 = 0) akkor j:=j+1 Cél[j]:=Forrás[i] Elágazás vége Ciklus vége Forrás: Cél: j = 2 i =

116 Kiválogatás j:=0 Ciklus i:=1-től 5-ig Ha (tömb[i] mod 2 = 0) akkor j:=j+1 Cél[j]:=Forrás[i] Elágazás vége Ciklus vége Forrás: Cél: j = 2 i =

117

118 Maximum-minimum kiválasztás tétele

119 Maximumkeresés tétele Legyen adott az n elemű A sorozat és egy a sorozat elemein értelmezett rendezési reláció. Határozzuk meg a sorozat legnagyobb értékű elemének sorszámát és értékét! A maximális elem sorszámát az i, értékét a max változó tartalmazza.

120 Feltételes maximumkeresés tétele Legyen adott az n elemű A sorozat, egy a sorozat elemein értelmezett β tulajdonság (logikai függvény), valamint egy a sorozat elemein értelmezett rendezési reláció. Határozzuk meg a sorozat β tulajdonságú elemei közül a legnagyobb értékű elem sorszámát és értékét! A maximális β tulajdonságú elem sorszámát az i, értékét a max változó tartalmazza.

121 Maximum kiválasztás i:=1 ind:=1 max:=tömb[1] Ciklus amíg (i<5) i:=i+1 Ha (max

122 Maximum kiválasztás i:=1 ind:=1 max:=tömb[1] Ciklus amíg (i<5) i:=i+1 Ha (max

123 Maximum kiválasztás i:=1 ind:=1 max:=tömb[1] Ciklus amíg (i<5) i:=i+1 Ha (max

124 Maximum kiválasztás i:=1 ind:=1 max:=tömb[1] Ciklus amíg (i<5) i:=i+1 Ha (max

125 Maximum kiválasztás i:=1 ind:=1 max:=tömb[1] Ciklus amíg (i<5) i:=i+1 Ha (max

126 Maximum kiválasztás i:=1 ind:=1 max:=tömb[1] Ciklus amíg (i<5) i:=i+1 Ha (max

127 Maximum kiválasztás i:=1 ind:=1 max:=tömb[1] Ciklus amíg (i<5) i:=i+1 Ha (max

128 Maximum kiválasztás i:=1 ind:=1 max:=tömb[1] Ciklus amíg (i<5) i:=i+1 Ha (max

129 Maximum kiválasztás i:=1 ind:=1 max:=tömb[1] Ciklus amíg (i<5) i:=i+1 Ha (max

130 Maximum kiválasztás i:=1 ind:=1 max:=tömb[1] Ciklus amíg (i<5) i:=i+1 Ha (max

131 Maximum kiválasztás i:=1 ind:=1 max:=tömb[1] Ciklus amíg (i<5) i:=i+1 Ha (max

132 Maximum kiválasztás i:=1 ind:=1 max:=tömb[1] Ciklus amíg (i<5) i:=i+1 Ha (max

133 Maximum kiválasztás i:=1 ind:=1 max:=tömb[1] Ciklus amíg (i<5) i:=i+1 Ha (max

134 Maximum kiválasztás i:=1 ind:=1 max:=tömb[1] Ciklus amíg (i<5) i:=i+1 Ha (max

135 Maximum kiválasztás i:=1 ind:=1 max:=tömb[1] Ciklus amíg (i<5) i:=i+1 Ha (max

136 Maximum kiválasztás i:=1 ind:=1 max:=tömb[1] Ciklus amíg (i<5) i:=i+1 Ha (max

137 Maximum kiválasztás i:=1 ind:=1 max:=tömb[1] Ciklus amíg (i<5) i:=i+1 Ha (max

138 Maximum kiválasztás i:=1 ind:=1 max:=tömb[1] Ciklus amíg (i<5) i:=i+1 Ha (max

139 Maximum kiválasztás i:=1 ind:=1 max:=tömb[1] Ciklus amíg (i<5) i:=i+1 Ha (max

140 Maximum kiválasztás i:=1 ind:=1 max:=tömb[1] Ciklus amíg (i<5) i:=i+1 Ha (max

141 Maximum kiválasztás i:=1 ind:=1 max:=tömb[1] Ciklus amíg (i<5) i:=i+1 Ha (max

142 Maximum kiválasztás i:=1 ind:=1 max:=tömb[1] Ciklus amíg (i<5) i:=i+1 Ha (max

143 Maximum kiválasztás i:=1 ind:=1 max:=tömb[1] Ciklus amíg (i<5) i:=i+1 Ha (max

144 Maximum kiválasztás i:=1 ind:=1 max:=tömb[1] Ciklus amíg (i<5) i:=i+1 Ha (max

145 Maximum kiválasztás i:=1 ind:=1 max:=tömb[1] Ciklus amíg (i<5) i:=i+1 Ha (max

146 Maximum kiválasztás i:=1 ind:=1 max:=tömb[1] Ciklus amíg (i<5) i:=i+1 Ha (max

147 Maximum kiválasztás i:=1 ind:=1 max:=tömb[1] Ciklus amíg (i<5) i:=i+1 Ha (max

148 Maximum kiválasztás i:=1 ind:=1 max:=tömb[1] Ciklus amíg (i<5) i:=i+1 Ha (max

149 Maximum kiválasztás i:=1 ind:=1 max:=tömb[1] Ciklus amíg (i<5) i:=i+1 Ha (max

150 Maximum kiválasztás i:=1 ind:=1 max:=tömb[1] Ciklus amíg (i<5) i:=i+1 Ha (max

151

152

153 Lineáris keresés tétele

154 Legyen adott az n elemű A sorozat és egy a sorozat elemein értelmezett β tulajdonság (logikai függvény). Keressük meg a sorozat első β tulajdonságú elemét! (Nem biztos, hogy van β tulajdonságú elem.) A keresés eredményeként az l logikai változó igaz értéket tartalmaz, ha találtunk β tulajdonságú elemet és hamis értéket, ha nem találtunk. Ha volt β tulajdonságú elem, akkor az első ilyen elem sorszámát a k változó tartalmazza.

155 Keresés i:=0 talált:=hamis Ciklus amíg ((nem talált) ÉS (i < 5)) i:=i + 1 talált:=(tömb[i] mod 2 = 0) Ciklus vége Ha (talált) Ki(i) Különben Ki(‘Nincs ilyen!’) Elágazás vége Tömb:

156 Keresés i:=0 talált:=hamis Ciklus amíg ((nem talált) ÉS (i < 5)) i:=i + 1 talált:=(tömb[i] mod 2 = 0) Ciklus vége Ha (talált) Ki(i) Különben Ki(‘Nincs ilyen!’) Elágazás vége Tömb: i = 0

157 Keresés i:=0 talált:=hamis Ciklus amíg ((nem talált) ÉS (i < 5)) i:=i + 1 talált:=(tömb[i] mod 2 = 0) Ciklus vége Ha (talált) Ki(i) Különben Ki(‘Nincs ilyen!’) Elágazás vége Tömb: i = 0 talált = hamis

158 Keresés i:=0 talált:=hamis Ciklus amíg ((nem talált) ÉS (i < 5)) i:=i + 1 talált:=(tömb[i] mod 2 = 0) Ciklus vége Ha (talált) Ki(i) Különben Ki(‘Nincs ilyen!’) Elágazás vége Tömb: i = 0 talált = hamis

159 Keresés i:=0 talált:=hamis Ciklus amíg ((nem talált) ÉS (i < 5)) i:=i + 1 talált:=(tömb[i] mod 2 = 0) Ciklus vége Ha (talált) Ki(i) Különben Ki(‘Nincs ilyen!’) Elágazás vége Tömb: i = 1 talált = hamis

160 Keresés i:=0 talált:=hamis Ciklus amíg ((nem talált) ÉS (i < 5)) i:=i + 1 talált:=(tömb[i] mod 2 = 0) Ciklus vége Ha (talált) Ki(i) Különben Ki(‘Nincs ilyen!’) Elágazás vége Tömb: i = 1 talált = hamis

161 Keresés i:=0 talált:=hamis Ciklus amíg ((nem talált) ÉS (i < 5)) i:=i + 1 talált:=(tömb[i] mod 2 = 0) Ciklus vége Ha (talált) Ki(i) Különben Ki(‘Nincs ilyen!’) Elágazás vége Tömb: i = 1 talált = hamis

162 Keresés i:=0 talált:=hamis Ciklus amíg ((nem talált) ÉS (i < 5)) i:=i + 1 talált:=(tömb[i] mod 2 = 0) Ciklus vége Ha (talált) Ki(i) Különben Ki(‘Nincs ilyen!’) Elágazás vége Tömb: i = 1 talált = hamis

163 Keresés i:=0 talált:=hamis Ciklus amíg ((nem talált) ÉS (i < 5)) i:=i + 1 talált:=(tömb[i] mod 2 = 0) Ciklus vége Ha (talált) Ki(i) Különben Ki(‘Nincs ilyen!’) Elágazás vége Tömb: i = 2 talált = hamis

164 Keresés i:=0 talált:=hamis Ciklus amíg ((nem talált) ÉS (i < 5)) i:=i + 1 talált:=(tömb[i] mod 2 = 0) Ciklus vége Ha (talált) Ki(i) Különben Ki(‘Nincs ilyen!’) Elágazás vége Tömb: i = 2 talált = hamis

165 Keresés i:=0 talált:=hamis Ciklus amíg ((nem talált) ÉS (i < 5)) i:=i + 1 talált:=(tömb[i] mod 2 = 0) Ciklus vége Ha (talált) Ki(i) Különben Ki(‘Nincs ilyen!’) Elágazás vége Tömb: i = 2 talált = hamis

166 Keresés i:=0 talált:=hamis Ciklus amíg ((nem talált) ÉS (i < 5)) i:=i + 1 talált:=(tömb[i] mod 2 = 0) Ciklus vége Ha (talált) Ki(i) Különben Ki(‘Nincs ilyen!’) Elágazás vége Tömb: i = 2 talált = hamis

167 Keresés i:=0 talált:=hamis Ciklus amíg ((nem talált) ÉS (i < 5)) i:=i + 1 talált:=(tömb[i] mod 2 = 0) Ciklus vége Ha (talált) Ki(i) Különben Ki(‘Nincs ilyen!’) Elágazás vége Tömb: i = 3 talált = hamis

168 Keresés i:=0 talált:=hamis Ciklus amíg ((nem talált) ÉS (i < 5)) i:=i + 1 talált:=(tömb[i] mod 2 = 0) Ciklus vége Ha (talált) Ki(i) Különben Ki(‘Nincs ilyen!’) Elágazás vége Tömb: i = 3 talált = igaz

169 Keresés i:=0 talált:=hamis Ciklus amíg ((nem talált) ÉS (i < 5)) i:=i + 1 talált:=(tömb[i] mod 2 = 0) Ciklus vége Ha (talált) Ki(i) Különben Ki(‘Nincs ilyen!’) Elágazás vége Tömb: i = 3 talált = igaz

170 Keresés i:=0 talált:=hamis Ciklus amíg ((nem talált) ÉS (i < 5)) i:=i + 1 talált:=(tömb[i] mod 2 = 0) Ciklus vége Ha (talált) Ki(i) Különben Ki(‘Nincs ilyen!’) Elágazás vége Tömb: i = 3 talált = igaz

171 Keresés i:=0 talált:=hamis Ciklus amíg ((nem talált) ÉS (i < 5)) i:=i + 1 talált:=(tömb[i] mod 2 = 0) Ciklus vége Ha (talált) Ki(i) Különben Ki(‘Nincs ilyen!’) Elágazás vége Tömb: i = 3 talált = igaz

172 Keresés i:=0 talált:=hamis Ciklus amíg ((nem talált) ÉS (i < 5)) i:=i + 1 talált:=(tömb[i] mod 2 = 0) Ciklus vége Ha (talált) Ki(i) Különben Ki(‘Nincs ilyen!’) Elágazás vége Tömb: i = 3 talált = igaz

173 Keresés i:=0 talált:=hamis Ciklus amíg ((nem talált) ÉS (i < 5)) i:=i + 1 talált:=(tömb[i] mod 2 = 0) Ciklus vége Ha (talált) Ki(i) Különben Ki(‘Nincs ilyen!’) Elágazás vége Tömb: i = 3 talált = igaz

174 Keresés i:=0 talált:=hamis Ciklus amíg ((nem talált) ÉS (i < 5)) i:=i + 1 talált:=(tömb[i] mod 2 = 0) Ciklus vége Ha (talált) Ki(i) Különben Ki(‘Nincs ilyen!’) Elágazás vége Tömb: i = 3 talált = igaz

175 Lineáris keresés tétele II.

176

177 Logaritmikus keresés tétele

178

179 Logaritmikus (felező) keresés tétele Legyen adott az n elemű, rendezett A sorozat, valamint az x elem. Döntsük el, hogy a sorozatban megtalálható-e az x elem, és ha igen, adjuk meg egy ilyen elem sorszámát! A keresés eredményeként az l logikai változó igaz értéket tartalmaz, ha megtaláltuk az x elemet és hamis értéket, ha nem találtunk. Ha megtaláltuk az x elemet, akkor annak sorszámát az i változó tartalmazza.

180

181 Feladat Készítsünk algoritmust, amely kitalálja a felhasználó által gondolt számot (1-100), és kiírja azt is, hogy hány lépésben sikerült megtalálni azt.

182 Visszalépéses keresés tétele

183

184

185 Metszet tétele

186 Egy n elemű halmaz elemeit az A, egy m elemű halmaz elemeit a B sorozat sorolja fel. Hozzuk létre a C sorozatot, mely a két halmaz metszetének elemeit sorolja fel!

187 Unió tétele

188 Egy n elemű halmaz elemeit az A, egy m elemű halmaz elemeit a B sorozat sorolja fel. Hozzuk létre a C sorozatot, mely a két halmaz uniójának elemeit sorolja fel!

189 Rendezés közvetlen kiválogatással

190 Rendezés közvetlen kiválasztással Ciklus i:=1-től 4-ig Ciklus j:=i+1-től 5-ig Ha (tömb[j]

191 Rendezés közvetlen kiválasztással Ciklus i:=1-től 4-ig Ciklus j:=i+1-től 5-ig Ha (tömb[j]

192 Rendezés közvetlen kiválasztással Ciklus i:=1-től 4-ig Ciklus j:=i+1-től 5-ig Ha (tömb[j]

193 Rendezés közvetlen kiválasztással Ciklus i:=1-től 4-ig Ciklus j:=i+1-től 5-ig Ha (tömb[j]

194 Rendezés közvetlen kiválasztással Ciklus i:=1-től 4-ig Ciklus j:=i+1-től 5-ig Ha (tömb[j]

195 Rendezés közvetlen kiválasztással Ciklus i:=1-től 4-ig Ciklus j:=i+1-től 5-ig Ha (tömb[j]

196 Rendezés közvetlen kiválasztással Ciklus i:=1-től 4-ig Ciklus j:=i+1-től 5-ig Ha (tömb[j]

197 Rendezés közvetlen kiválasztással Ciklus i:=1-től 4-ig Ciklus j:=i+1-től 5-ig Ha (tömb[j]

198 Rendezés közvetlen kiválasztással Ciklus i:=1-től 4-ig Ciklus j:=i+1-től 5-ig Ha (tömb[j]

199 Rendezés közvetlen kiválasztással Ciklus i:=1-től 4-ig Ciklus j:=i+1-től 5-ig Ha (tömb[j]

200 Rendezés közvetlen kiválasztással Ciklus i:=1-től 4-ig Ciklus j:=i+1-től 5-ig Ha (tömb[j]

201 Rendezés közvetlen kiválasztással Ciklus i:=1-től 4-ig Ciklus j:=i+1-től 5-ig Ha (tömb[j]

202 Rendezés közvetlen kiválasztással Ciklus i:=1-től 4-ig Ciklus j:=i+1-től 5-ig Ha (tömb[j]

203 Rendezés közvetlen kiválasztással Ciklus i:=1-től 4-ig Ciklus j:=i+1-től 5-ig Ha (tömb[j]

204 Rendezés közvetlen kiválasztással Ciklus i:=1-től 4-ig Ciklus j:=i+1-től 5-ig Ha (tömb[j]

205 Rendezés közvetlen kiválasztással Ciklus i:=1-től 4-ig Ciklus j:=i+1-től 5-ig Ha (tömb[j]

206 Rendezés közvetlen kiválasztással Ciklus i:=1-től 4-ig Ciklus j:=i+1-től 5-ig Ha (tömb[j]

207 Rendezés közvetlen kiválasztással Ciklus i:=1-től 4-ig Ciklus j:=i+1-től 5-ig Ha (tömb[j]

208 Rendezés közvetlen kiválasztással Ciklus i:=1-től 4-ig Ciklus j:=i+1-től 5-ig Ha (tömb[j]

209 Rendezés közvetlen kiválasztással Ciklus i:=1-től 4-ig Ciklus j:=i+1-től 5-ig Ha (tömb[j]

210 Rendezés közvetlen kiválasztással Ciklus i:=1-től 4-ig Ciklus j:=i+1-től 5-ig Ha (tömb[j]

211 Rendezés közvetlen kiválasztással Ciklus i:=1-től 4-ig Ciklus j:=i+1-től 5-ig Ha (tömb[j]

212 Rendezés közvetlen kiválasztással Ciklus i:=1-től 4-ig Ciklus j:=i+1-től 5-ig Ha (tömb[j]

213 Rendezés közvetlen kiválasztással Ciklus i:=1-től 4-ig Ciklus j:=i+1-től 5-ig Ha (tömb[j]

214 Rendezés közvetlen kiválasztással Ciklus i:=1-től 4-ig Ciklus j:=i+1-től 5-ig Ha (tömb[j]

215 Rendezés közvetlen kiválasztással Ciklus i:=1-től 4-ig Ciklus j:=i+1-től 5-ig Ha (tömb[j]

216 Rendezés közvetlen kiválasztással Ciklus i:=1-től 4-ig Ciklus j:=i+1-től 5-ig Ha (tömb[j]

217 Rendezés közvetlen kiválasztással Ciklus i:=1-től 4-ig Ciklus j:=i+1-től 5-ig Ha (tömb[j]

218 Rendezés közvetlen kiválasztással Ciklus i:=1-től 4-ig Ciklus j:=i+1-től 5-ig Ha (tömb[j]

219 Rendezés közvetlen kiválasztással Ciklus i:=1-től 4-ig Ciklus j:=i+1-től 5-ig Ha (tömb[j]

220 Rendezés közvetlen kiválasztással Ciklus i:=1-től 4-ig Ciklus j:=i+1-től 5-ig Ha (tömb[j]

221 Rendezés közvetlen kiválasztással Ciklus i:=1-től 4-ig Ciklus j:=i+1-től 5-ig Ha (tömb[j]

222 Rendezés közvetlen kiválasztással Ciklus i:=1-től 4-ig Ciklus j:=i+1-től 5-ig Ha (tömb[j]

223 Rendezés közvetlen kiválasztással Ciklus i:=1-től 4-ig Ciklus j:=i+1-től 5-ig Ha (tömb[j]

224 Rendezés közvetlen kiválasztással Ciklus i:=1-től 4-ig Ciklus j:=i+1-től 5-ig Ha (tömb[j]

225 Rendezés közvetlen kiválasztással Ciklus i:=1-től 4-ig Ciklus j:=i+1-től 5-ig Ha (tömb[j]

226 Rendezés közvetlen kiválasztással Ciklus i:=1-től 4-ig Ciklus j:=i+1-től 5-ig Ha (tömb[j]

227 Rendezés közvetlen kiválasztással Ciklus i:=1-től 4-ig Ciklus j:=i+1-től 5-ig Ha (tömb[j]

228 Rendezés közvetlen kiválasztással Ciklus i:=1-től 4-ig Ciklus j:=i+1-től 5-ig Ha (tömb[j]

229 Rendezés közvetlen kiválasztással Ciklus i:=1-től 4-ig Ciklus j:=i+1-től 5-ig Ha (tömb[j]

230 Rendezés közvetlen kiválasztással Ciklus i:=1-től 4-ig Ciklus j:=i+1-től 5-ig Ha (tömb[j]

231 Rendezés közvetlen kiválasztással Ciklus i:=1-től 4-ig Ciklus j:=i+1-től 5-ig Ha (tömb[j]

232 Rendezés közvetlen kiválasztással Ciklus i:=1-től 4-ig Ciklus j:=i+1-től 5-ig Ha (tömb[j]

233 Rendezés közvetlen kiválasztással Ciklus i:=1-től 4-ig Ciklus j:=i+1-től 5-ig Ha (tömb[j]

234 Rendezés közvetlen kiválasztással Ciklus i:=1-től 4-ig Ciklus j:=i+1-től 5-ig Ha (tömb[j]

235 Rendezés közvetlen kiválasztással Ciklus i:=1-től 4-ig Ciklus j:=i+1-től 5-ig Ha (tömb[j]

236 Rendezés közvetlen kiválasztással Ciklus i:=1-től 4-ig Ciklus j:=i+1-től 5-ig Ha (tömb[j]

237 Rendezés közvetlen kiválasztással Ciklus i:=1-től 4-ig Ciklus j:=i+1-től 5-ig Ha (tömb[j]

238 Rendezés közvetlen kiválasztással Ciklus i:=1-től 4-ig Ciklus j:=i+1-től 5-ig Ha (tömb[j]

239 Rendezés közvetlen kiválasztással Ciklus i:=1-től 4-ig Ciklus j:=i+1-től 5-ig Ha (tömb[j]

240 Rendezés közvetlen kiválasztással Ciklus i:=1-től 4-ig Ciklus j:=i+1-től 5-ig Ha (tömb[j]

241 Rendezés közvetlen kiválasztással Ciklus i:=1-től 4-ig Ciklus j:=i+1-től 5-ig Ha (tömb[j]

242 Rendezés közvetlen kiválasztással Ciklus i:=1-től 4-ig Ciklus j:=i+1-től 5-ig Ha (tömb[j]

243 Rendezés közvetlen kiválasztással Ciklus i:=1-től 4-ig Ciklus j:=i+1-től 5-ig Ha (tömb[j]

244 Rendezés közvetlen kiválasztással Ciklus i:=1-től 4-ig Ciklus j:=i+1-től 5-ig Ha (tömb[j]

245 Rendezés közvetlen kiválasztással Ciklus i:=1-től 4-ig Ciklus j:=i+1-től 5-ig Ha (tömb[j]

246 Rendezés közvetlen kiválasztással Ciklus i:=1-től 4-ig Ciklus j:=i+1-től 5-ig Ha (tömb[j]

247 Rendezés közvetlen kiválasztással Ciklus i:=1-től 4-ig Ciklus j:=i+1-től 5-ig Ha (tömb[j]

248 Rendezés minimum -maximum kiválasztással

249 Rendezés maximum-minumum kiválasztással tétele Legyen adott az n elemű A sorozat és egy a sorozat elemein értelmezett rendezési reláció. A feladat az, hogy rendezzük növekvő sorrendbe a sorozat elemeit. Az algoritmus minden iterációban megkeresi a még rendezetlen részsorozat legnagyobb elemét és kicseréli a részsorozat jobb szélső elemével.

250 Rendezés minimumkiválasztással Ciklus i:=1-től 4-ig index:=i min:=tömb[i] Ciklus j:=i+1-től 5-ig Ha (min>tömb[j]) akkor min:=tömb[j] index:=j Elágazás vége Ciklus vége tömb[index]:=tömb[i] tömb[i]:=max Ciklus vége Tömb: Min:

251 Rendezés minimumkiválasztással Ciklus i:=1-től 4-ig index:=i min:=tömb[i] Ciklus j:=i+1-től 5-ig Ha (min>tömb[j]) akkor min:=tömb[j] index:=j Elágazás vége Ciklus vége tömb[index]:=tömb[i] tömb[i]:=max Ciklus vége Tömb: Min: i = 1

252 Rendezés minimumkiválasztással Ciklus i:=1-től 4-ig index:=i min:=tömb[i] Ciklus j:=i+1-től 5-ig Ha (min>tömb[j]) akkor min:=tömb[j] index:=j Elágazás vége Ciklus vége tömb[index]:=tömb[i] tömb[i]:=max Ciklus vége Tömb: Min: i = 1 index = 1

253 Rendezés minimumkiválasztással Ciklus i:=1-től 4-ig index:=i min:=tömb[i] Ciklus j:=i+1-től 5-ig Ha (min>tömb[j]) akkor min:=tömb[j] index:=j Elágazás vége Ciklus vége tömb[index]:=tömb[i] tömb[i]:=max Ciklus vége Tömb: Min: i = 1 index = 1 11

254 Rendezés minimumkiválasztással Ciklus i:=1-től 4-ig index:=i min:=tömb[i] Ciklus j:=i+1-től 5-ig Ha (min>tömb[j]) akkor min:=tömb[j] index:=j Elágazás vége Ciklus vége tömb[index]:=tömb[i] tömb[i]:=max Ciklus vége Tömb: Min: i = 1 index = 1 j = 2 11

255 Rendezés minimumkiválasztással Ciklus i:=1-től 4-ig index:=i min:=tömb[i] Ciklus j:=i+1-től 5-ig Ha (min>tömb[j]) akkor min:=tömb[j] index:=j Elágazás vége Ciklus vége tömb[index]:=tömb[i] tömb[i]:=max Ciklus vége Tömb: Min: i = 1 index = 1 j = 2 11

256 Rendezés minimumkiválasztással Ciklus i:=1-től 4-ig index:=i min:=tömb[i] Ciklus j:=i+1-től 5-ig Ha (min>tömb[j]) akkor min:=tömb[j] index:=j Elágazás vége Ciklus vége tömb[index]:=tömb[i] tömb[i]:=max Ciklus vége Tömb: Min: i = 1 index = 1 j = 2 11

257 Rendezés minimumkiválasztással Ciklus i:=1-től 4-ig index:=i min:=tömb[i] Ciklus j:=i+1-től 5-ig Ha (min>tömb[j]) akkor min:=tömb[j] index:=j Elágazás vége Ciklus vége tömb[index]:=tömb[i] tömb[i]:=max Ciklus vége Tömb: Min: i = 1 index = 1 j = 2 11

258 Rendezés minimumkiválasztással Ciklus i:=1-től 4-ig index:=i min:=tömb[i] Ciklus j:=i+1-től 5-ig Ha (min>tömb[j]) akkor min:=tömb[j] index:=j Elágazás vége Ciklus vége tömb[index]:=tömb[i] tömb[i]:=max Ciklus vége Tömb: Min: i = 1 index = 1 j = 3 11

259 Rendezés minimumkiválasztással Ciklus i:=1-től 4-ig index:=i min:=tömb[i] Ciklus j:=i+1-től 5-ig Ha (min>tömb[j]) akkor min:=tömb[j] index:=j Elágazás vége Ciklus vége tömb[index]:=tömb[i] tömb[i]:=max Ciklus vége Tömb: Min: i = 1 index = 1 j = 3 11

260 Rendezés minimumkiválasztással Ciklus i:=1-től 4-ig index:=i min:=tömb[i] Ciklus j:=i+1-től 5-ig Ha (min>tömb[j]) akkor min:=tömb[j] index:=j Elágazás vége Ciklus vége tömb[index]:=tömb[i] tömb[i]:=max Ciklus vége Tömb: Min: i = 1 index = 1 j = 3 11

261 Rendezés minimumkiválasztással Ciklus i:=1-től 4-ig index:=i min:=tömb[i] Ciklus j:=i+1-től 5-ig Ha (min>tömb[j]) akkor min:=tömb[j] index:=j Elágazás vége Ciklus vége tömb[index]:=tömb[i] tömb[i]:=max Ciklus vége Tömb: Min: i = 1 index = 1 j = 3 11

262 Rendezés minimumkiválasztással Ciklus i:=1-től 4-ig index:=i min:=tömb[i] Ciklus j:=i+1-től 5-ig Ha (min>tömb[j]) akkor min:=tömb[j] index:=j Elágazás vége Ciklus vége tömb[index]:=tömb[i] tömb[i]:=max Ciklus vége Tömb: Min: i = 1 index = 1 j = 4 11

263 Rendezés minimumkiválasztással Ciklus i:=1-től 4-ig index:=i min:=tömb[i] Ciklus j:=i+1-től 5-ig Ha (min>tömb[j]) akkor min:=tömb[j] index:=j Elágazás vége Ciklus vége tömb[index]:=tömb[i] tömb[i]:=max Ciklus vége Tömb: Min: i = 1 index = 1 j = 4 11

264 Rendezés minimumkiválasztással Ciklus i:=1-től 4-ig index:=i min:=tömb[i] Ciklus j:=i+1-től 5-ig Ha (min>tömb[j]) akkor min:=tömb[j] index:=j Elágazás vége Ciklus vége tömb[index]:=tömb[i] tömb[i]:=max Ciklus vége Tömb: Min: i = 1 index = 1 j = 4 11

265 Rendezés minimumkiválasztással Ciklus i:=1-től 4-ig index:=i min:=tömb[i] Ciklus j:=i+1-től 5-ig Ha (min>tömb[j]) akkor min:=tömb[j] index:=j Elágazás vége Ciklus vége tömb[index]:=tömb[i] tömb[i]:=max Ciklus vége Tömb: Min: i = 1 index = 1 j = 4 11

266 Rendezés minimumkiválasztással Ciklus i:=1-től 4-ig index:=i min:=tömb[i] Ciklus j:=i+1-től 5-ig Ha (min>tömb[j]) akkor min:=tömb[j] index:=j Elágazás vége Ciklus vége tömb[index]:=tömb[i] tömb[i]:=max Ciklus vége Tömb: Min: i = 1 index = 1 j = 5 11

267 Rendezés minimumkiválasztással Ciklus i:=1-től 4-ig index:=i min:=tömb[i] Ciklus j:=i+1-től 5-ig Ha (min>tömb[j]) akkor min:=tömb[j] index:=j Elágazás vége Ciklus vége tömb[index]:=tömb[i] tömb[i]:=max Ciklus vége Tömb: Min: i = 1 index = 1 j = 5 11

268 Rendezés minimumkiválasztással Ciklus i:=1-től 4-ig index:=i min:=tömb[i] Ciklus j:=i+1-től 5-ig Ha (min>tömb[j]) akkor min:=tömb[j] index:=j Elágazás vége Ciklus vége tömb[index]:=tömb[i] tömb[i]:=max Ciklus vége Tömb: Min: i = 1 index = 1 j = 5 11

269 Rendezés minimumkiválasztással Ciklus i:=1-től 4-ig index:=i min:=tömb[i] Ciklus j:=i+1-től 5-ig Ha (min>tömb[j]) akkor min:=tömb[j] index:=j Elágazás vége Ciklus vége tömb[index]:=tömb[i] tömb[i]:=max Ciklus vége Tömb: Min: i = 1 index = 1 j = 5 11

270 Rendezés minimumkiválasztással Ciklus i:=1-től 4-ig index:=i min:=tömb[i] Ciklus j:=i+1-től 5-ig Ha (min>tömb[j]) akkor min:=tömb[j] index:=j Elágazás vége Ciklus vége tömb[index]:=tömb[i] tömb[i]:=max Ciklus vége Tömb: Min: i = 1 index = 1 j = 5 11

271 Rendezés minimumkiválasztással Ciklus i:=1-től 4-ig index:=i min:=tömb[i] Ciklus j:=i+1-től 5-ig Ha (min>tömb[j]) akkor min:=tömb[j] index:=j Elágazás vége Ciklus vége tömb[index]:=tömb[i] tömb[i]:=max Ciklus vége Tömb: Min: i = 1 index = 1 j = 5 11

272 Rendezés minimumkiválasztással Ciklus i:=1-től 4-ig index:=i min:=tömb[i] Ciklus j:=i+1-től 5-ig Ha (min>tömb[j]) akkor min:=tömb[j] index:=j Elágazás vége Ciklus vége tömb[index]:=tömb[i] tömb[i]:=max Ciklus vége Tömb: Min: i = 1 index = 1 j = 5 11

273 Rendezés minimumkiválasztással Ciklus i:=1-től 4-ig index:=i min:=tömb[i] Ciklus j:=i+1-től 5-ig Ha (min>tömb[j]) akkor min:=tömb[j] index:=j Elágazás vége Ciklus vége tömb[index]:=tömb[i] tömb[i]:=max Ciklus vége Tömb: Min: i = 2 index = 1 j = 5 11

274 Rendezés minimumkiválasztással Ciklus i:=1-től 4-ig index:=i min:=tömb[i] Ciklus j:=i+1-től 5-ig Ha (min>tömb[j]) akkor min:=tömb[j] index:=j Elágazás vége Ciklus vége tömb[index]:=tömb[i] tömb[i]:=max Ciklus vége Tömb: Min: i = 2 index = 2 j = 5 11

275 Rendezés minimumkiválasztással Ciklus i:=1-től 4-ig index:=i min:=tömb[i] Ciklus j:=i+1-től 5-ig Ha (min>tömb[j]) akkor min:=tömb[j] index:=j Elágazás vége Ciklus vége tömb[index]:=tömb[i] tömb[i]:=max Ciklus vége Tömb: Min: i = 2 index = 2 j = 5 15

276 Rendezés minimumkiválasztással Ciklus i:=1-től 4-ig index:=i min:=tömb[i] Ciklus j:=i+1-től 5-ig Ha (min>tömb[j]) akkor min:=tömb[j] index:=j Elágazás vége Ciklus vége tömb[index]:=tömb[i] tömb[i]:=max Ciklus vége Tömb: Min: i = 2 index = 2 j = 3 15

277 Rendezés minimumkiválasztással Ciklus i:=1-től 4-ig index:=i min:=tömb[i] Ciklus j:=i+1-től 5-ig Ha (min>tömb[j]) akkor min:=tömb[j] index:=j Elágazás vége Ciklus vége tömb[index]:=tömb[i] tömb[i]:=max Ciklus vége Tömb: Min: i = 2 index = 2 j = 3 15

278 Rendezés minimumkiválasztással Ciklus i:=1-től 4-ig index:=i min:=tömb[i] Ciklus j:=i+1-től 5-ig Ha (min>tömb[j]) akkor min:=tömb[j] index:=j Elágazás vége Ciklus vége tömb[index]:=tömb[i] tömb[i]:=max Ciklus vége Tömb: Min: i = 2 index = 2 j = 3 12

279 Rendezés minimumkiválasztással Ciklus i:=1-től 4-ig index:=i min:=tömb[i] Ciklus j:=i+1-től 5-ig Ha (min>tömb[j]) akkor min:=tömb[j] index:=j Elágazás vége Ciklus vége tömb[index]:=tömb[i] tömb[i]:=max Ciklus vége Tömb: Min: i = 2 index = 3 j = 3 12

280 Rendezés minimumkiválasztással Ciklus i:=1-től 4-ig index:=i min:=tömb[i] Ciklus j:=i+1-től 5-ig Ha (min>tömb[j]) akkor min:=tömb[j] index:=j Elágazás vége Ciklus vége tömb[index]:=tömb[i] tömb[i]:=max Ciklus vége Tömb: Min: i = 2 index = 3 j = 3 12

281 Rendezés minimumkiválasztással Ciklus i:=1-től 4-ig index:=i min:=tömb[i] Ciklus j:=i+1-től 5-ig Ha (min>tömb[j]) akkor min:=tömb[j] index:=j Elágazás vége Ciklus vége tömb[index]:=tömb[i] tömb[i]:=max Ciklus vége Tömb: Min: i = 2 index = 3 j = 3 12

282 Rendezés minimumkiválasztással Ciklus i:=1-től 4-ig index:=i min:=tömb[i] Ciklus j:=i+1-től 5-ig Ha (min>tömb[j]) akkor min:=tömb[j] index:=j Elágazás vége Ciklus vége tömb[index]:=tömb[i] tömb[i]:=max Ciklus vége Tömb: Min: i = 2 index = 3 j = 4 12

283 Rendezés minimumkiválasztással Ciklus i:=1-től 4-ig index:=i min:=tömb[i] Ciklus j:=i+1-től 5-ig Ha (min>tömb[j]) akkor min:=tömb[j] index:=j Elágazás vége Ciklus vége tömb[index]:=tömb[i] tömb[i]:=max Ciklus vége Tömb: Min: i = 2 index = 3 j = 4 12

284 Rendezés minimumkiválasztással Ciklus i:=1-től 4-ig index:=i min:=tömb[i] Ciklus j:=i+1-től 5-ig Ha (min>tömb[j]) akkor min:=tömb[j] index:=j Elágazás vége Ciklus vége tömb[index]:=tömb[i] tömb[i]:=max Ciklus vége Tömb: Min: i = 2 index = 3 j = 4 12

285 Rendezés minimumkiválasztással Ciklus i:=1-től 4-ig index:=i min:=tömb[i] Ciklus j:=i+1-től 5-ig Ha (min>tömb[j]) akkor min:=tömb[j] index:=j Elágazás vége Ciklus vége tömb[index]:=tömb[i] tömb[i]:=max Ciklus vége Tömb: Min: i = 2 index = 3 j = 4 12

286 Rendezés minimumkiválasztással Ciklus i:=1-től 4-ig index:=i min:=tömb[i] Ciklus j:=i+1-től 5-ig Ha (min>tömb[j]) akkor min:=tömb[j] index:=j Elágazás vége Ciklus vége tömb[index]:=tömb[i] tömb[i]:=max Ciklus vége Tömb: Min: i = 2 index = 3 j = 5 12

287 Rendezés minimumkiválasztással Ciklus i:=1-től 4-ig index:=i min:=tömb[i] Ciklus j:=i+1-től 5-ig Ha (min>tömb[j]) akkor min:=tömb[j] index:=j Elágazás vége Ciklus vége tömb[index]:=tömb[i] tömb[i]:=max Ciklus vége Tömb: Min: i = 2 index = 3 j = 5 12

288 Rendezés minimumkiválasztással Ciklus i:=1-től 4-ig index:=i min:=tömb[i] Ciklus j:=i+1-től 5-ig Ha (min>tömb[j]) akkor min:=tömb[j] index:=j Elágazás vége Ciklus vége tömb[index]:=tömb[i] tömb[i]:=max Ciklus vége Tömb: Min: i = 2 index = 3 j = 5 12

289 Rendezés minimumkiválasztással Ciklus i:=1-től 4-ig index:=i min:=tömb[i] Ciklus j:=i+1-től 5-ig Ha (min>tömb[j]) akkor min:=tömb[j] index:=j Elágazás vége Ciklus vége tömb[index]:=tömb[i] tömb[i]:=max Ciklus vége Tömb: Min: i = 2 index = 3 j = 5 12

290 Rendezés minimumkiválasztással Ciklus i:=1-től 4-ig index:=i min:=tömb[i] Ciklus j:=i+1-től 5-ig Ha (min>tömb[j]) akkor min:=tömb[j] index:=j Elágazás vége Ciklus vége tömb[index]:=tömb[i] tömb[i]:=max Ciklus vége Tömb: Min: i = 2 index = 3 j = 5 12

291 Rendezés minimumkiválasztással Ciklus i:=1-től 4-ig index:=i min:=tömb[i] Ciklus j:=i+1-től 5-ig Ha (min>tömb[j]) akkor min:=tömb[j] index:=j Elágazás vége Ciklus vége tömb[index]:=tömb[i] tömb[i]:=max Ciklus vége Tömb: Min: i = 2 index = 3 j = 5 12

292 Rendezés minimumkiválasztással Ciklus i:=1-től 4-ig index:=i min:=tömb[i] Ciklus j:=i+1-től 5-ig Ha (min>tömb[j]) akkor min:=tömb[j] index:=j Elágazás vége Ciklus vége tömb[index]:=tömb[i] tömb[i]:=max Ciklus vége Tömb: Min: i = 2 index = 3 j = 5 12

293 Rendezés minimumkiválasztással Ciklus i:=1-től 4-ig index:=i min:=tömb[i] Ciklus j:=i+1-től 5-ig Ha (min>tömb[j]) akkor min:=tömb[j] index:=j Elágazás vége Ciklus vége tömb[index]:=tömb[i] tömb[i]:=max Ciklus vége Tömb: Min: i = 3 index = 3 j = 5 12

294 Rendezés minimumkiválasztással Ciklus i:=1-től 4-ig index:=i min:=tömb[i] Ciklus j:=i+1-től 5-ig Ha (min>tömb[j]) akkor min:=tömb[j] index:=j Elágazás vége Ciklus vége tömb[index]:=tömb[i] tömb[i]:=max Ciklus vége Tömb: Min: i = 3 index = 3 j = 5 12

295 Rendezés minimumkiválasztással Ciklus i:=1-től 4-ig index:=i min:=tömb[i] Ciklus j:=i+1-től 5-ig Ha (min>tömb[j]) akkor min:=tömb[j] index:=j Elágazás vége Ciklus vége tömb[index]:=tömb[i] tömb[i]:=max Ciklus vége Tömb: Min: i = 3 index = 3 j = 5 15

296 Rendezés minimumkiválasztással Ciklus i:=1-től 4-ig index:=i min:=tömb[i] Ciklus j:=i+1-től 5-ig Ha (min>tömb[j]) akkor min:=tömb[j] index:=j Elágazás vége Ciklus vége tömb[index]:=tömb[i] tömb[i]:=max Ciklus vége Tömb: Min: i = 3 index = 3 j = 4 15

297 Rendezés minimumkiválasztással Ciklus i:=1-től 4-ig index:=i min:=tömb[i] Ciklus j:=i+1-től 5-ig Ha (min>tömb[j]) akkor min:=tömb[j] index:=j Elágazás vége Ciklus vége tömb[index]:=tömb[i] tömb[i]:=max Ciklus vége Tömb: Min: i = 3 index = 3 j = 4 15

298 Rendezés minimumkiválasztással Ciklus i:=1-től 4-ig index:=i min:=tömb[i] Ciklus j:=i+1-től 5-ig Ha (min>tömb[j]) akkor min:=tömb[j] index:=j Elágazás vége Ciklus vége tömb[index]:=tömb[i] tömb[i]:=max Ciklus vége Tömb: Min: i = 3 index = 3 j = 4 15

299 Rendezés minimumkiválasztással Ciklus i:=1-től 4-ig index:=i min:=tömb[i] Ciklus j:=i+1-től 5-ig Ha (min>tömb[j]) akkor min:=tömb[j] index:=j Elágazás vége Ciklus vége tömb[index]:=tömb[i] tömb[i]:=max Ciklus vége Tömb: Min: i = 3 index = 3 j = 4 15

300 Rendezés minimumkiválasztással Ciklus i:=1-től 4-ig index:=i min:=tömb[i] Ciklus j:=i+1-től 5-ig Ha (min>tömb[j]) akkor min:=tömb[j] index:=j Elágazás vége Ciklus vége tömb[index]:=tömb[i] tömb[i]:=max Ciklus vége Tömb: Min: i = 3 index = 3 j = 5 15

301 Rendezés minimumkiválasztással Ciklus i:=1-től 4-ig index:=i min:=tömb[i] Ciklus j:=i+1-től 5-ig Ha (min>tömb[j]) akkor min:=tömb[j] index:=j Elágazás vége Ciklus vége tömb[index]:=tömb[i] tömb[i]:=max Ciklus vége Tömb: Min: i = 3 index = 3 j = 5 15

302 Rendezés minimumkiválasztással Ciklus i:=1-től 4-ig index:=i min:=tömb[i] Ciklus j:=i+1-től 5-ig Ha (min>tömb[j]) akkor min:=tömb[j] index:=j Elágazás vége Ciklus vége tömb[index]:=tömb[i] tömb[i]:=max Ciklus vége Tömb: Min: i = 3 index = 3 j = 5 14

303 Rendezés minimumkiválasztással Ciklus i:=1-től 4-ig index:=i min:=tömb[i] Ciklus j:=i+1-től 5-ig Ha (min>tömb[j]) akkor min:=tömb[j] index:=j Elágazás vége Ciklus vége tömb[index]:=tömb[i] tömb[i]:=max Ciklus vége Tömb: Min: i = 3 index = 5 j = 5 14

304 Rendezés minimumkiválasztással Ciklus i:=1-től 4-ig index:=i min:=tömb[i] Ciklus j:=i+1-től 5-ig Ha (min>tömb[j]) akkor min:=tömb[j] index:=j Elágazás vége Ciklus vége tömb[index]:=tömb[i] tömb[i]:=max Ciklus vége Tömb: Min: i = 3 index = 5 j = 5 14

305 Rendezés minimumkiválasztással Ciklus i:=1-től 4-ig index:=i min:=tömb[i] Ciklus j:=i+1-től 5-ig Ha (min>tömb[j]) akkor min:=tömb[j] index:=j Elágazás vége Ciklus vége tömb[index]:=tömb[i] tömb[i]:=max Ciklus vége Tömb: Min: i = 3 index = 5 j = 5 14

306 Rendezés minimumkiválasztással Ciklus i:=1-től 4-ig index:=i min:=tömb[i] Ciklus j:=i+1-től 5-ig Ha (min>tömb[j]) akkor min:=tömb[j] index:=j Elágazás vége Ciklus vége tömb[index]:=tömb[i] tömb[i]:=max Ciklus vége Tömb: Min: i = 3 index = 5 j = 5 14

307 Rendezés minimumkiválasztással Ciklus i:=1-től 4-ig index:=i min:=tömb[i] Ciklus j:=i+1-től 5-ig Ha (min>tömb[j]) akkor min:=tömb[j] index:=j Elágazás vége Ciklus vége tömb[index]:=tömb[i] tömb[i]:=max Ciklus vége Tömb: Min: i = 3 index = 5 j = 5 14

308 Rendezés minimumkiválasztással Ciklus i:=1-től 4-ig index:=i min:=tömb[i] Ciklus j:=i+1-től 5-ig Ha (min>tömb[j]) akkor min:=tömb[j] index:=j Elágazás vége Ciklus vége tömb[index]:=tömb[i] tömb[i]:=max Ciklus vége Tömb: Min: i = 3 index = 5 j = 5 14

309 Rendezés minimumkiválasztással Ciklus i:=1-től 4-ig index:=i min:=tömb[i] Ciklus j:=i+1-től 5-ig Ha (min>tömb[j]) akkor min:=tömb[j] index:=j Elágazás vége Ciklus vége tömb[index]:=tömb[i] tömb[i]:=max Ciklus vége Tömb: Min: i = 4 index = 5 j = 5 14

310 Rendezés minimumkiválasztással Ciklus i:=1-től 4-ig index:=i min:=tömb[i] Ciklus j:=i+1-től 5-ig Ha (min>tömb[j]) akkor min:=tömb[j] index:=j Elágazás vége Ciklus vége tömb[index]:=tömb[i] tömb[i]:=max Ciklus vége Tömb: Min: i = 4 index = 4 j = 5 14

311 Rendezés minimumkiválasztással Ciklus i:=1-től 4-ig index:=i min:=tömb[i] Ciklus j:=i+1-től 5-ig Ha (min>tömb[j]) akkor min:=tömb[j] index:=j Elágazás vége Ciklus vége tömb[index]:=tömb[i] tömb[i]:=max Ciklus vége Tömb: Min: i = 4 index = 4 j = 5 17

312 Rendezés minimumkiválasztással Ciklus i:=1-től 4-ig index:=i min:=tömb[i] Ciklus j:=i+1-től 5-ig Ha (min>tömb[j]) akkor min:=tömb[j] index:=j Elágazás vége Ciklus vége tömb[index]:=tömb[i] tömb[i]:=max Ciklus vége Tömb: Min: i = 4 index = 4 j = 5 17

313 Rendezés minimumkiválasztással Ciklus i:=1-től 4-ig index:=i min:=tömb[i] Ciklus j:=i+1-től 5-ig Ha (min>tömb[j]) akkor min:=tömb[j] index:=j Elágazás vége Ciklus vége tömb[index]:=tömb[i] tömb[i]:=max Ciklus vége Tömb: Min: i = 4 index = 4 j = 5 17

314 Rendezés minimumkiválasztással Ciklus i:=1-től 4-ig index:=i min:=tömb[i] Ciklus j:=i+1-től 5-ig Ha (min>tömb[j]) akkor min:=tömb[j] index:=j Elágazás vége Ciklus vége tömb[index]:=tömb[i] tömb[i]:=max Ciklus vége Tömb: Min: i = 4 index = 4 j = 5 15

315 Rendezés minimumkiválasztással Ciklus i:=1-től 4-ig index:=i min:=tömb[i] Ciklus j:=i+1-től 5-ig Ha (min>tömb[j]) akkor min:=tömb[j] index:=j Elágazás vége Ciklus vége tömb[index]:=tömb[i] tömb[i]:=max Ciklus vége Tömb: Min: i = 4 index = 5 j = 5 15

316 Rendezés minimumkiválasztással Ciklus i:=1-től 4-ig index:=i min:=tömb[i] Ciklus j:=i+1-től 5-ig Ha (min>tömb[j]) akkor min:=tömb[j] index:=j Elágazás vége Ciklus vége tömb[index]:=tömb[i] tömb[i]:=max Ciklus vége Tömb: Min: i = 4 index = 5 j = 5 15

317 Rendezés minimumkiválasztással Ciklus i:=1-től 4-ig index:=i min:=tömb[i] Ciklus j:=i+1-től 5-ig Ha (min>tömb[j]) akkor min:=tömb[j] index:=j Elágazás vége Ciklus vége tömb[index]:=tömb[i] tömb[i]:=max Ciklus vége Tömb: Min: i = 4 index = 5 j = 5 15

318 Rendezés minimumkiválasztással Ciklus i:=1-től 4-ig index:=i min:=tömb[i] Ciklus j:=i+1-től 5-ig Ha (min>tömb[j]) akkor min:=tömb[j] index:=j Elágazás vége Ciklus vége tömb[index]:=tömb[i] tömb[i]:=max Ciklus vége Tömb: Min: i = 4 index = 5 j = 5 15

319 Rendezés minimumkiválasztással Ciklus i:=1-től 4-ig index:=i min:=tömb[i] Ciklus j:=i+1-től 5-ig Ha (min>tömb[j]) akkor min:=tömb[j] index:=j Elágazás vége Ciklus vége tömb[index]:=tömb[i] tömb[i]:=max Ciklus vége Tömb: Min: i = 4 index = 5 j = 5 15

320 Rendezés minimumkiválasztással Ciklus i:=1-től 4-ig index:=i min:=tömb[i] Ciklus j:=i+1-től 5-ig Ha (min>tömb[j]) akkor min:=tömb[j] index:=j Elágazás vége Ciklus vége tömb[index]:=tömb[i] tömb[i]:=max Ciklus vége Tömb: Min: i = 4 index = 5 j = 5 15

321 Rendezés egyszerű beszúrással

322 Legyen adott az n elemű A sorozat és egy a sorozat elemein értelmezett rendezési reláció. A feladat az, hogy rendezzük növekvő sorrendbe a sorozat elemeit. Az algoritmus minden iterációban a helyére visz egy elemet, azaz beszúr egy elemet a már rendezett részsorozatba.

323 B D C A ?

324 B D C A A

325 B D C D A

326 B D C D A

327 B C C D A

328 B C B D A

329 A C B D A

330 A C B D A 

331 B D C A ?

332 B D C A A

333 B D B A A

334 B B B A A

335 B B B B A

336 A B B B A

337 A B B B A 

338 Rendezés buborékos módszerrel

339 Legyen adott az n elemű A sorozat és egy a sorozat elemein értelmezett rendezési reláció. A feladat az, hogy rendezzük növekvő sorrendbe a sorozat elemeit. Az algoritmus neve arra utal, hogy minden iterációban a még rendezetlen részsorozat legnagyobb eleme (az egymást követő elemek cseréje révén) felszivárog a részsorozat jobb szélső elemének helyére, mintha egy buborék haladna a víz alatt a felszín felé.

340 Buborékrendezés Ciklus i:=2-től 5-ig Ciklus j:=5-től i-ig Ha (tömb[j-1]>tömb[j]) akkor segéd:=tömb[j-1] tömb[j-1]:=tömb[j] tömb[j]:=segéd Elágazás vége Ciklus vége Tömb: Segéd:

341 Buborékrendezés Ciklus i:=2-től 5-ig Ciklus j:=5-től i-ig Ha (tömb[j-1]>tömb[j]) akkor segéd:=tömb[j-1] tömb[j-1]:=tömb[j] tömb[j]:=segéd Elágazás vége Ciklus vége Tömb: Segéd: i = 2

342 Buborékrendezés Ciklus i:=2-től 5-ig Ciklus j:=5-től i-ig Ha (tömb[j-1]>tömb[j]) akkor segéd:=tömb[j-1] tömb[j-1]:=tömb[j] tömb[j]:=segéd Elágazás vége Ciklus vége Tömb: Segéd: i = 2 j = 5

343 Buborékrendezés Ciklus i:=2-től 5-ig Ciklus j:=5-től i-ig Ha (tömb[j-1]>tömb[j]) akkor segéd:=tömb[j-1] tömb[j-1]:=tömb[j] tömb[j]:=segéd Elágazás vége Ciklus vége Tömb: Segéd: i = 2 j = 5

344 Buborékrendezés Ciklus i:=2-től 5-ig Ciklus j:=5-től i-ig Ha (tömb[j-1]>tömb[j]) akkor segéd:=tömb[j-1] tömb[j-1]:=tömb[j] tömb[j]:=segéd Elágazás vége Ciklus vége Tömb: Segéd: i = 2 j = 5 17

345 Buborékrendezés Ciklus i:=2-től 5-ig Ciklus j:=5-től i-ig Ha (tömb[j-1]>tömb[j]) akkor segéd:=tömb[j-1] tömb[j-1]:=tömb[j] tömb[j]:=segéd Elágazás vége Ciklus vége Tömb: Segéd: i = 2 j = 5 17

346 Buborékrendezés Ciklus i:=2-től 5-ig Ciklus j:=5-től i-ig Ha (tömb[j-1]>tömb[j]) akkor segéd:=tömb[j-1] tömb[j-1]:=tömb[j] tömb[j]:=segéd Elágazás vége Ciklus vége Tömb: Segéd: i = 2 j = 5 17

347 Buborékrendezés Ciklus i:=2-től 5-ig Ciklus j:=5-től i-ig Ha (tömb[j-1]>tömb[j]) akkor segéd:=tömb[j-1] tömb[j-1]:=tömb[j] tömb[j]:=segéd Elágazás vége Ciklus vége Tömb: Segéd: i = 2 j = 5 17

348 Buborékrendezés Ciklus i:=2-től 5-ig Ciklus j:=5-től i-ig Ha (tömb[j-1]>tömb[j]) akkor segéd:=tömb[j-1] tömb[j-1]:=tömb[j] tömb[j]:=segéd Elágazás vége Ciklus vége Tömb: Segéd: i = 2 j = 5 17

349 Buborékrendezés Ciklus i:=2-től 5-ig Ciklus j:=5-től i-ig Ha (tömb[j-1]>tömb[j]) akkor segéd:=tömb[j-1] tömb[j-1]:=tömb[j] tömb[j]:=segéd Elágazás vége Ciklus vége Tömb: Segéd: i = 2 j = 4 17

350 Buborékrendezés Ciklus i:=2-től 5-ig Ciklus j:=5-től i-ig Ha (tömb[j-1]>tömb[j]) akkor segéd:=tömb[j-1] tömb[j-1]:=tömb[j] tömb[j]:=segéd Elágazás vége Ciklus vége Tömb: Segéd: i = 2 j = 4 17

351 Buborékrendezés Ciklus i:=2-től 5-ig Ciklus j:=5-től i-ig Ha (tömb[j-1]>tömb[j]) akkor segéd:=tömb[j-1] tömb[j-1]:=tömb[j] tömb[j]:=segéd Elágazás vége Ciklus vége Tömb: Segéd: i = 2 j = 4 17

352 Buborékrendezés Ciklus i:=2-től 5-ig Ciklus j:=5-től i-ig Ha (tömb[j-1]>tömb[j]) akkor segéd:=tömb[j-1] tömb[j-1]:=tömb[j] tömb[j]:=segéd Elágazás vége Ciklus vége Tömb: Segéd: i = 2 j = 4 17

353 Buborékrendezés Ciklus i:=2-től 5-ig Ciklus j:=5-től i-ig Ha (tömb[j-1]>tömb[j]) akkor segéd:=tömb[j-1] tömb[j-1]:=tömb[j] tömb[j]:=segéd Elágazás vége Ciklus vége Tömb: Segéd: i = 2 j = 3 17

354 Buborékrendezés Ciklus i:=2-től 5-ig Ciklus j:=5-től i-ig Ha (tömb[j-1]>tömb[j]) akkor segéd:=tömb[j-1] tömb[j-1]:=tömb[j] tömb[j]:=segéd Elágazás vége Ciklus vége Tömb: Segéd: i = 2 j = 3 17

355 Buborékrendezés Ciklus i:=2-től 5-ig Ciklus j:=5-től i-ig Ha (tömb[j-1]>tömb[j]) akkor segéd:=tömb[j-1] tömb[j-1]:=tömb[j] tömb[j]:=segéd Elágazás vége Ciklus vége Tömb: Segéd: i = 2 j = 3 15

356 Buborékrendezés Ciklus i:=2-től 5-ig Ciklus j:=5-től i-ig Ha (tömb[j-1]>tömb[j]) akkor segéd:=tömb[j-1] tömb[j-1]:=tömb[j] tömb[j]:=segéd Elágazás vége Ciklus vége Tömb: Segéd: i = 2 j = 3 15

357 Buborékrendezés Ciklus i:=2-től 5-ig Ciklus j:=5-től i-ig Ha (tömb[j-1]>tömb[j]) akkor segéd:=tömb[j-1] tömb[j-1]:=tömb[j] tömb[j]:=segéd Elágazás vége Ciklus vége Tömb: Segéd: i = 2 j = 3 15

358 Buborékrendezés Ciklus i:=2-től 5-ig Ciklus j:=5-től i-ig Ha (tömb[j-1]>tömb[j]) akkor segéd:=tömb[j-1] tömb[j-1]:=tömb[j] tömb[j]:=segéd Elágazás vége Ciklus vége Tömb: Segéd: i = 2 j = 3 15

359 Buborékrendezés Ciklus i:=2-től 5-ig Ciklus j:=5-től i-ig Ha (tömb[j-1]>tömb[j]) akkor segéd:=tömb[j-1] tömb[j-1]:=tömb[j] tömb[j]:=segéd Elágazás vége Ciklus vége Tömb: Segéd: i = 2 j = 3 15

360 Buborékrendezés Ciklus i:=2-től 5-ig Ciklus j:=5-től i-ig Ha (tömb[j-1]>tömb[j]) akkor segéd:=tömb[j-1] tömb[j-1]:=tömb[j] tömb[j]:=segéd Elágazás vége Ciklus vége Tömb: Segéd: i = 2 j = 2 15

361 Buborékrendezés Ciklus i:=2-től 5-ig Ciklus j:=5-től i-ig Ha (tömb[j-1]>tömb[j]) akkor segéd:=tömb[j-1] tömb[j-1]:=tömb[j] tömb[j]:=segéd Elágazás vége Ciklus vége Tömb: Segéd: i = 2 j = 2 15

362 Buborékrendezés Ciklus i:=2-től 5-ig Ciklus j:=5-től i-ig Ha (tömb[j-1]>tömb[j]) akkor segéd:=tömb[j-1] tömb[j-1]:=tömb[j] tömb[j]:=segéd Elágazás vége Ciklus vége Tömb: Segéd: i = 2 j = 2 15

363 Buborékrendezés Ciklus i:=2-től 5-ig Ciklus j:=5-től i-ig Ha (tömb[j-1]>tömb[j]) akkor segéd:=tömb[j-1] tömb[j-1]:=tömb[j] tömb[j]:=segéd Elágazás vége Ciklus vége Tömb: Segéd: i = 2 j = 2 15

364 Buborékrendezés Ciklus i:=2-től 5-ig Ciklus j:=5-től i-ig Ha (tömb[j-1]>tömb[j]) akkor segéd:=tömb[j-1] tömb[j-1]:=tömb[j] tömb[j]:=segéd Elágazás vége Ciklus vége Tömb: Segéd: i = 2 j = 2 15

365 Buborékrendezés Ciklus i:=2-től 5-ig Ciklus j:=5-től i-ig Ha (tömb[j-1]>tömb[j]) akkor segéd:=tömb[j-1] tömb[j-1]:=tömb[j] tömb[j]:=segéd Elágazás vége Ciklus vége Tömb: Segéd: i = 3 j = 2 15

366 Buborékrendezés Ciklus i:=2-től 5-ig Ciklus j:=5-től i-ig Ha (tömb[j-1]>tömb[j]) akkor segéd:=tömb[j-1] tömb[j-1]:=tömb[j] tömb[j]:=segéd Elágazás vége Ciklus vége Tömb: Segéd: i = 3 j = 5 15

367 Buborékrendezés Ciklus i:=2-től 5-ig Ciklus j:=5-től i-ig Ha (tömb[j-1]>tömb[j]) akkor segéd:=tömb[j-1] tömb[j-1]:=tömb[j] tömb[j]:=segéd Elágazás vége Ciklus vége Tömb: Segéd: i = 3 j = 5 15

368 Buborékrendezés Ciklus i:=2-től 5-ig Ciklus j:=5-től i-ig Ha (tömb[j-1]>tömb[j]) akkor segéd:=tömb[j-1] tömb[j-1]:=tömb[j] tömb[j]:=segéd Elágazás vége Ciklus vége Tömb: Segéd: i = 3 j = 5 15

369 Buborékrendezés Ciklus i:=2-től 5-ig Ciklus j:=5-től i-ig Ha (tömb[j-1]>tömb[j]) akkor segéd:=tömb[j-1] tömb[j-1]:=tömb[j] tömb[j]:=segéd Elágazás vége Ciklus vége Tömb: Segéd: i = 3 j = 5 15

370 Buborékrendezés Ciklus i:=2-től 5-ig Ciklus j:=5-től i-ig Ha (tömb[j-1]>tömb[j]) akkor segéd:=tömb[j-1] tömb[j-1]:=tömb[j] tömb[j]:=segéd Elágazás vége Ciklus vége Tömb: Segéd: i = 3 j = 4 15

371 Buborékrendezés Ciklus i:=2-től 5-ig Ciklus j:=5-től i-ig Ha (tömb[j-1]>tömb[j]) akkor segéd:=tömb[j-1] tömb[j-1]:=tömb[j] tömb[j]:=segéd Elágazás vége Ciklus vége Tömb: Segéd: i = 3 j = 4 15

372 Buborékrendezés Ciklus i:=2-től 5-ig Ciklus j:=5-től i-ig Ha (tömb[j-1]>tömb[j]) akkor segéd:=tömb[j-1] tömb[j-1]:=tömb[j] tömb[j]:=segéd Elágazás vége Ciklus vége Tömb: Segéd: i = 3 j = 4 15

373 Buborékrendezés Ciklus i:=2-től 5-ig Ciklus j:=5-től i-ig Ha (tömb[j-1]>tömb[j]) akkor segéd:=tömb[j-1] tömb[j-1]:=tömb[j] tömb[j]:=segéd Elágazás vége Ciklus vége Tömb: Segéd: i = 3 j = 4 15

374 Buborékrendezés Ciklus i:=2-től 5-ig Ciklus j:=5-től i-ig Ha (tömb[j-1]>tömb[j]) akkor segéd:=tömb[j-1] tömb[j-1]:=tömb[j] tömb[j]:=segéd Elágazás vége Ciklus vége Tömb: Segéd: i = 3 j = 4 15

375 Buborékrendezés Ciklus i:=2-től 5-ig Ciklus j:=5-től i-ig Ha (tömb[j-1]>tömb[j]) akkor segéd:=tömb[j-1] tömb[j-1]:=tömb[j] tömb[j]:=segéd Elágazás vége Ciklus vége Tömb: Segéd: i = 3 j = 4 15

376 Buborékrendezés Ciklus i:=2-től 5-ig Ciklus j:=5-től i-ig Ha (tömb[j-1]>tömb[j]) akkor segéd:=tömb[j-1] tömb[j-1]:=tömb[j] tömb[j]:=segéd Elágazás vége Ciklus vége Tömb: Segéd: i = 3 j = 4 15

377 Buborékrendezés Ciklus i:=2-től 5-ig Ciklus j:=5-től i-ig Ha (tömb[j-1]>tömb[j]) akkor segéd:=tömb[j-1] tömb[j-1]:=tömb[j] tömb[j]:=segéd Elágazás vége Ciklus vége Tömb: Segéd: i = 3 j = 3 15

378 Buborékrendezés Ciklus i:=2-től 5-ig Ciklus j:=5-től i-ig Ha (tömb[j-1]>tömb[j]) akkor segéd:=tömb[j-1] tömb[j-1]:=tömb[j] tömb[j]:=segéd Elágazás vége Ciklus vége Tömb: Segéd: i = 3 j = 3 15

379 Buborékrendezés Ciklus i:=2-től 5-ig Ciklus j:=5-től i-ig Ha (tömb[j-1]>tömb[j]) akkor segéd:=tömb[j-1] tömb[j-1]:=tömb[j] tömb[j]:=segéd Elágazás vége Ciklus vége Tömb: Segéd: i = 3 j = 3 15

380 Buborékrendezés Ciklus i:=2-től 5-ig Ciklus j:=5-től i-ig Ha (tömb[j-1]>tömb[j]) akkor segéd:=tömb[j-1] tömb[j-1]:=tömb[j] tömb[j]:=segéd Elágazás vége Ciklus vége Tömb: Segéd: i = 3 j = 3 15

381 Buborékrendezés Ciklus i:=2-től 5-ig Ciklus j:=5-től i-ig Ha (tömb[j-1]>tömb[j]) akkor segéd:=tömb[j-1] tömb[j-1]:=tömb[j] tömb[j]:=segéd Elágazás vége Ciklus vége Tömb: Segéd: i = 3 j = 3 15

382 Buborékrendezés Ciklus i:=2-től 5-ig Ciklus j:=5-től i-ig Ha (tömb[j-1]>tömb[j]) akkor segéd:=tömb[j-1] tömb[j-1]:=tömb[j] tömb[j]:=segéd Elágazás vége Ciklus vége Tömb: Segéd: i = 4 j = 3 15

383 Buborékrendezés Ciklus i:=2-től 5-ig Ciklus j:=5-től i-ig Ha (tömb[j-1]>tömb[j]) akkor segéd:=tömb[j-1] tömb[j-1]:=tömb[j] tömb[j]:=segéd Elágazás vége Ciklus vége Tömb: Segéd: i = 4 j = 5 15

384 Buborékrendezés Ciklus i:=2-től 5-ig Ciklus j:=5-től i-ig Ha (tömb[j-1]>tömb[j]) akkor segéd:=tömb[j-1] tömb[j-1]:=tömb[j] tömb[j]:=segéd Elágazás vége Ciklus vége Tömb: Segéd: i = 4 j = 5 15

385 Buborékrendezés Ciklus i:=2-től 5-ig Ciklus j:=5-től i-ig Ha (tömb[j-1]>tömb[j]) akkor segéd:=tömb[j-1] tömb[j-1]:=tömb[j] tömb[j]:=segéd Elágazás vége Ciklus vége Tömb: Segéd: i = 4 j = 5 15

386 Buborékrendezés Ciklus i:=2-től 5-ig Ciklus j:=5-től i-ig Ha (tömb[j-1]>tömb[j]) akkor segéd:=tömb[j-1] tömb[j-1]:=tömb[j] tömb[j]:=segéd Elágazás vége Ciklus vége Tömb: Segéd: i = 4 j = 5 15

387 Buborékrendezés Ciklus i:=2-től 5-ig Ciklus j:=5-től i-ig Ha (tömb[j-1]>tömb[j]) akkor segéd:=tömb[j-1] tömb[j-1]:=tömb[j] tömb[j]:=segéd Elágazás vége Ciklus vége Tömb: Segéd: i = 4 j = 4 15

388 Buborékrendezés Ciklus i:=2-től 5-ig Ciklus j:=5-től i-ig Ha (tömb[j-1]>tömb[j]) akkor segéd:=tömb[j-1] tömb[j-1]:=tömb[j] tömb[j]:=segéd Elágazás vége Ciklus vége Tömb: Segéd: i = 4 j = 4 15

389 Buborékrendezés Ciklus i:=2-től 5-ig Ciklus j:=5-től i-ig Ha (tömb[j-1]>tömb[j]) akkor segéd:=tömb[j-1] tömb[j-1]:=tömb[j] tömb[j]:=segéd Elágazás vége Ciklus vége Tömb: Segéd: i = 4 j = 4 15

390 Buborékrendezés Ciklus i:=2-től 5-ig Ciklus j:=5-től i-ig Ha (tömb[j-1]>tömb[j]) akkor segéd:=tömb[j-1] tömb[j-1]:=tömb[j] tömb[j]:=segéd Elágazás vége Ciklus vége Tömb: Segéd: i = 4 j = 4 15

391 Buborékrendezés Ciklus i:=2-től 5-ig Ciklus j:=5-től i-ig Ha (tömb[j-1]>tömb[j]) akkor segéd:=tömb[j-1] tömb[j-1]:=tömb[j] tömb[j]:=segéd Elágazás vége Ciklus vége Tömb: Segéd: i = 4 j = 4 15

392 Buborékrendezés Ciklus i:=2-től 5-ig Ciklus j:=5-től i-ig Ha (tömb[j-1]>tömb[j]) akkor segéd:=tömb[j-1] tömb[j-1]:=tömb[j] tömb[j]:=segéd Elágazás vége Ciklus vége Tömb: Segéd: i = 5 j = 4 15

393 Buborékrendezés Ciklus i:=2-től 5-ig Ciklus j:=5-től i-ig Ha (tömb[j-1]>tömb[j]) akkor segéd:=tömb[j-1] tömb[j-1]:=tömb[j] tömb[j]:=segéd Elágazás vége Ciklus vége Tömb: Segéd: i = 5 j = 5 15

394 Buborékrendezés Ciklus i:=2-től 5-ig Ciklus j:=5-től i-ig Ha (tömb[j-1]>tömb[j]) akkor segéd:=tömb[j-1] tömb[j-1]:=tömb[j] tömb[j]:=segéd Elágazás vége Ciklus vége Tömb: Segéd: i = 5 j = 5 15

395 Buborékrendezés Ciklus i:=2-től 5-ig Ciklus j:=5-től i-ig Ha (tömb[j-1]>tömb[j]) akkor segéd:=tömb[j-1] tömb[j-1]:=tömb[j] tömb[j]:=segéd Elágazás vége Ciklus vége Tömb: Segéd: i = 5 j = 5 15

396 Buborékrendezés Ciklus i:=2-től 5-ig Ciklus j:=5-től i-ig Ha (tömb[j-1]>tömb[j]) akkor segéd:=tömb[j-1] tömb[j-1]:=tömb[j] tömb[j]:=segéd Elágazás vége Ciklus vége Tömb: Segéd: i = 5 j = 5 15

397 Buborékrendezés Ciklus i:=2-től 5-ig Ciklus j:=5-től i-ig Ha (tömb[j-1]>tömb[j]) akkor segéd:=tömb[j-1] tömb[j-1]:=tömb[j] tömb[j]:=segéd Elágazás vége Ciklus vége Tömb: Segéd: i = 5 j = 5 15

398 Rendezés Shell módszerrel

399

400

401

402

403

404

405

406

407

408

409

410

411

412

413

414

415

416

417

418

419

420

421

422

423

424

425

426

427

428

429

430

431

432

433

434

435 A rendezetlen tömb

436 Lépésköz: lépés Rendezés előtt

437 Lépésköz: lépés Rendezés után

438 Lépésköz: lépés Rendezés előtt

439 Lépésköz: lépés Rendezés után

440 Lépésköz: lépés Rendezés előtt

441 Lépésköz: lépés Rendezés után

442 Lépésköz: lépés Rendezés előtt

443 Lépésköz: lépés Rendezés után

444 Lépésköz: lépés Rendezés előtt

445 Lépésköz: lépés Rendezés után

446 Lépésköz: lépés Rendezés előtt

447 Lépésköz: lépés Rendezés után

448 Lépésköz: lépés Rendezés előtt

449 Lépésköz: lépés Rendezés után

450 Lépésköz: lépés Rendezés előtt

451 Lépésköz: lépés Rendezés után

452 Lépésköz: lépés Rendezés előtt

453 Lépésköz: lépés Rendezés után

454 Lépésköz: lépés Rendezés előtt

455 Lépésköz: lépés Rendezés után

456 Lépésköz: lépés Rendezés előtt

457 Lépésköz: lépés Rendezés után

458 Lépésköz: lépés Rendezés előtt

459 Lépésköz: lépés Rendezés után

460 Lépésköz: lépés Rendezés előtt

461 Lépésköz: lépés Rendezés után

462 Lépésköz: lépés Rendezés előtt

463 Lépésköz: lépés Rendezés után

464 Lépésköz: lépés Rendezés előtt

465 Lépésköz: lépés Rendezés után

466 Lépésköz: lépés Rendezés előtt

467 Lépésköz: lépés Rendezés után

468 Lépésköz: lépés Rendezés előtt

469 Lépésköz: lépés Rendezés után

470 Lépésköz: lépés Rendezés előtt

471 Lépésköz: lépés Rendezés után

472 Lépésköz: lépés Rendezés előtt

473 Lépésköz: lépés Rendezés után

474 Lépésköz: lépés Rendezés előtt

475 Lépésköz: lépés Rendezés után

476 Lépésköz: lépés Rendezés előtt

477 Lépésköz: lépés Rendezés után

478 Lépésköz: lépés Rendezés előtt

479 Lépésköz: lépés Rendezés után

480 Lépésköz: lépés Rendezés előtt

481 Lépésköz: lépés Rendezés után

482 Lépésköz: lépés Rendezés előtt

483 Lépésköz: lépés Rendezés után

484 Lépésköz: lépés Rendezés előtt

485 Lépésköz: lépés Rendezés után

486 Lépésköz: lépés Rendezés előtt

487 Lépésköz: lépés Rendezés után

488 Lépésköz: lépés Rendezés előtt

489 Lépésköz: lépés Rendezés után

490 Lépésköz: lépés Rendezés előtt

491 Lépésköz: lépés Rendezés után

492 Lépésköz: lépés Rendezés előtt

493 Lépésköz: lépés Rendezés után

494 Lépésköz: 71. lépés Rendezés előtt

495 Lépésköz: 71. lépés Rendezés után

496 Lépésköz: 72. lépés Rendezés előtt

497 Lépésköz: 72. lépés Rendezés után

498 Lépésköz: 73. lépés Rendezés előtt

499 Lépésköz: 73. lépés Rendezés után

500 Lépésköz: 74. lépés Rendezés előtt

501 Lépésköz: 74. lépés Rendezés után

502 Lépésköz: 75. lépés Rendezés előtt

503 Lépésköz: 75. lépés Rendezés után

504 Lépésköz: 76. lépés Rendezés előtt

505 Lépésköz: 76. lépés Rendezés után

506 Lépésköz: 77. lépés Rendezés előtt

507 Lépésköz: 77. lépés Rendezés után

508 Lépésköz: 31. lépés Rendezés előtt

509 Lépésköz: 31. lépés Rendezés után

510 Lépésköz: 32. lépés Rendezés előtt

511 Lépésköz: 32. lépés Rendezés után

512 Lépésköz: 33. lépés Rendezés előtt

513 Lépésköz: 33. lépés Rendezés után

514 A részben rendezett tömb az utolsó lépés előtt


Letölteni ppt "Nevezetes algoritmusok. Összegzés tétele Összegzés tétele II. A tétel másik elterjedt neve Sorozatszámítás. Legyen adott az n elemű A sorozat. Összegezzük."