Az előadás letöltése folymat van. Kérjük, várjon

Az előadás letöltése folymat van. Kérjük, várjon

Nevezetes algoritmusok

Hasonló előadás


Az előadások a következő témára: "Nevezetes algoritmusok"— Előadás másolata:

1 Nevezetes algoritmusok

2 Összegzés tétele

3 Összegzés tétele II. A tétel másik elterjedt neve Sorozatszámítás. Legyen adott az n elemű A sorozat. Összegezzük a sorozat értékeit! A előálló összeget az s változó tartalmazza.

4 Összegzés s:=0 Ciklus i:=1-től 5-ig s:=s+tömb[i] Ciklus vége Ki(s) 15
12 11 17 14 Tömb: s:=0 Ciklus i:=1-től 5-ig s:=s+tömb[i] Ciklus vége Ki(s)

5 Összegzés s:=0 Ciklus i:=1-től 5-ig s:=s+tömb[i] Ciklus vége Ki(s) 15
12 11 17 14 Tömb: s:=0 Ciklus i:=1-től 5-ig s:=s+tömb[i] Ciklus vége Ki(s) i = 0 s = 0

6 Összegzés s:=0 Ciklus i:=1-től 5-ig s:=s+tömb[i] Ciklus vége Ki(s) 15
12 11 17 14 Tömb: s:=0 Ciklus i:=1-től 5-ig s:=s+tömb[i] Ciklus vége Ki(s) i = 1 s = 0

7 Összegzés s:=0 Ciklus i:=1-től 5-ig s:=s+tömb[i] Ciklus vége Ki(s) 15
12 11 17 14 Tömb: s:=0 Ciklus i:=1-től 5-ig s:=s+tömb[i] Ciklus vége Ki(s) i = 1 s = 12

8 Összegzés s:=0 Ciklus i:=1-től 5-ig s:=s+tömb[i] Ciklus vége Ki(s) 15
12 11 17 14 Tömb: s:=0 Ciklus i:=1-től 5-ig s:=s+tömb[i] Ciklus vége Ki(s) i = 1 s = 12

9 Összegzés s:=0 Ciklus i:=1-től 5-ig s:=s+tömb[i] Ciklus vége Ki(s) 15
12 11 17 14 Tömb: s:=0 Ciklus i:=1-től 5-ig s:=s+tömb[i] Ciklus vége Ki(s) i = 2 s = 12

10 Összegzés s:=0 Ciklus i:=1-től 5-ig s:=s+tömb[i] Ciklus vége Ki(s) 15
12 11 17 14 Tömb: s:=0 Ciklus i:=1-től 5-ig s:=s+tömb[i] Ciklus vége Ki(s) i = 2 s = 27

11 Összegzés s:=0 Ciklus i:=1-től 5-ig s:=s+tömb[i] Ciklus vége Ki(s) 15
12 11 17 14 Tömb: s:=0 Ciklus i:=1-től 5-ig s:=s+tömb[i] Ciklus vége Ki(s) i = 2 s = 27

12 Összegzés s:=0 Ciklus i:=1-től 5-ig s:=s+tömb[i] Ciklus vége Ki(s) 15
12 11 17 14 Tömb: s:=0 Ciklus i:=1-től 5-ig s:=s+tömb[i] Ciklus vége Ki(s) i = 3 s = 27

13 Összegzés s:=0 Ciklus i:=1-től 5-ig s:=s+tömb[i] Ciklus vége Ki(s) 15
12 11 17 14 Tömb: s:=0 Ciklus i:=1-től 5-ig s:=s+tömb[i] Ciklus vége Ki(s) i = 3 s = 38

14 Összegzés s:=0 Ciklus i:=1-től 5-ig s:=s+tömb[i] Ciklus vége Ki(s) 15
12 11 17 14 Tömb: s:=0 Ciklus i:=1-től 5-ig s:=s+tömb[i] Ciklus vége Ki(s) i = 3 s = 38

15 Összegzés s:=0 Ciklus i:=1-től 5-ig s:=s+tömb[i] Ciklus vége Ki(s) 15
12 11 17 14 Tömb: s:=0 Ciklus i:=1-től 5-ig s:=s+tömb[i] Ciklus vége Ki(s) i = 4 s = 38

16 Összegzés s:=0 Ciklus i:=1-től 5-ig s:=s+tömb[i] Ciklus vége Ki(s) 15
12 11 17 14 Tömb: s:=0 Ciklus i:=1-től 5-ig s:=s+tömb[i] Ciklus vége Ki(s) i = 4 s = 55

17 Összegzés s:=0 Ciklus i:=1-től 5-ig s:=s+tömb[i] Ciklus vége Ki(s) 15
12 11 17 14 Tömb: s:=0 Ciklus i:=1-től 5-ig s:=s+tömb[i] Ciklus vége Ki(s) i = 4 s = 55

18 Összegzés s:=0 Ciklus i:=1-től 5-ig s:=s+tömb[i] Ciklus vége Ki(s) 15
12 11 17 14 Tömb: s:=0 Ciklus i:=1-től 5-ig s:=s+tömb[i] Ciklus vége Ki(s) i = 5 s = 55

19 Összegzés s:=0 Ciklus i:=1-től 5-ig s:=s+tömb[i] Ciklus vége Ki(s) 15
12 11 17 14 Tömb: s:=0 Ciklus i:=1-től 5-ig s:=s+tömb[i] Ciklus vége Ki(s) i = 5 s = 69

20 Összegzés s:=0 Ciklus i:=1-től 5-ig s:=s+tömb[i] Ciklus vége Ki(s) 15
12 11 17 14 Tömb: s:=0 Ciklus i:=1-től 5-ig s:=s+tömb[i] Ciklus vége Ki(s) i = 5 s = 69

21 Összegzés s:=0 Ciklus i:=1-től 5-ig s:=s+tömb[i] Ciklus vége Ki(s) 15
12 11 17 14 Tömb: s:=0 Ciklus i:=1-től 5-ig s:=s+tömb[i] Ciklus vége Ki(s) i = 5 s = 69

22 Összegzés tétele III.

23 Példa Határozza meg az [1, 100] intervallumba eső páros számok összegét! Osszeg:=0; Ciklus i:=1 - től ig /a mod a maradékképzés operátora, a feltétel arra a matematikai Ha (i mod 2 = 0) akkor / igazságra utal, hogy a páros számok 2-vel maradék nélkül osszeg:=osszeg + i; /oszthatóak; Különben semmi; /üres utasítás; Elágazás vége Ciklus vége Ki(osszeg);

24

25 Kiválasztás tétele

26 Kiválasztás i:=1 Ciklus amíg tömb[i] mod 2 <> 0 i:=i+1
17 15 11 12 14 i:=1 Ciklus amíg tömb[i] mod 2 <> 0 i:=i+1 Ciklus vége Ki(i)

27 Kiválasztás i:=1 Ciklus amíg tömb[i] mod 2 <> 0 i:=i+1
17 15 11 12 14 i:=1 Ciklus amíg tömb[i] mod 2 <> 0 i:=i+1 Ciklus vége Ki(i) i = 1

28 Kiválasztás i:=1 Ciklus amíg tömb[i] mod 2 <> 0 i:=i+1
17 15 11 12 14 i:=1 Ciklus amíg tömb[i] mod 2 <> 0 i:=i+1 Ciklus vége Ki(i) i = 1

29 Kiválasztás i:=1 Ciklus amíg tömb[i] mod 2 <> 0 i:=i+1
17 15 11 12 14 i:=1 Ciklus amíg tömb[i] mod 2 <> 0 i:=i+1 Ciklus vége Ki(i) i = 1 Tömb[i] mod 2 <>0 ? igaz

30 Kiválasztás i:=1 Ciklus amíg tömb[i] mod 2 <> 0 i:=i+1
17 15 11 12 14 i:=1 Ciklus amíg tömb[i] mod 2 <> 0 i:=i+1 Ciklus vége Ki(i) i = 2 Tömb[i] mod 2 <>0 ? igaz

31 Kiválasztás i:=1 Ciklus amíg tömb[i] mod 2 <> 0 i:=i+1
17 15 11 12 14 i:=1 Ciklus amíg tömb[i] mod 2 <> 0 i:=i+1 Ciklus vége Ki(i) i = 2 Tömb[i] mod 2 <>0 ? igaz

32 Kiválasztás i:=1 Ciklus amíg tömb[i] mod 2 <> 0 i:=i+1
17 15 11 12 14 i:=1 Ciklus amíg tömb[i] mod 2 <> 0 i:=i+1 Ciklus vége Ki(i) i = 2 Tömb[i] mod 2 <>0 ? igaz

33 Kiválasztás i:=1 Ciklus amíg tömb[i] mod 2 <> 0 i:=i+1
17 15 11 12 14 i:=1 Ciklus amíg tömb[i] mod 2 <> 0 i:=i+1 Ciklus vége Ki(i) i = 3 Tömb[i] mod 2 <>0 ? igaz

34 Kiválasztás i:=1 Ciklus amíg tömb[i] mod 2 <> 0 i:=i+1
17 15 11 12 14 i:=1 Ciklus amíg tömb[i] mod 2 <> 0 i:=i+1 Ciklus vége Ki(i) i = 3 Tömb[i] mod 2 <>0 ? igaz

35 Kiválasztás i:=1 Ciklus amíg tömb[i] mod 2 <> 0 i:=i+1
17 15 11 12 14 i:=1 Ciklus amíg tömb[i] mod 2 <> 0 i:=i+1 Ciklus vége Ki(i) i = 3 Tömb[i] mod 2 <>0 ? igaz

36 Kiválasztás i:=1 Ciklus amíg tömb[i] mod 2 <> 0 i:=i+1
17 15 11 12 14 i:=1 Ciklus amíg tömb[i] mod 2 <> 0 i:=i+1 Ciklus vége Ki(i) i = 4 Tömb[i] mod 2 <>0 ? igaz

37 Kiválasztás i:=1 Ciklus amíg tömb[i] mod 2 <> 0 i:=i+1
17 15 11 12 14 i:=1 Ciklus amíg tömb[i] mod 2 <> 0 i:=i+1 Ciklus vége Ki(i) i = 4 Tömb[i] mod 2 <>0 ? igaz

38 Kiválasztás i:=1 Ciklus amíg tömb[i] mod 2 <> 0 i:=i+1
17 15 11 12 14 i:=1 Ciklus amíg tömb[i] mod 2 <> 0 i:=i+1 Ciklus vége Ki(i) i = 4 Tömb[i] mod 2 <>0 ? hamis

39 Kiválasztás i:=1 Ciklus amíg tömb[i] mod 2 <> 0 i:=i+1
17 15 11 12 14 i:=1 Ciklus amíg tömb[i] mod 2 <> 0 i:=i+1 Ciklus vége Ki(i) i = 4 Tömb[i] mod 2 <>0 ? hamis

40 Kiválasztás tétele

41 Példa Válasszuk ki a 25-nél nagyobb számok közül az első héttel oszthatót! i:=25; /kezdőérték 25-re állítása; Ciklus amíg (i mod 7 <> 0) /ciklus amíg nem találunk olyan számot mely maradék nélkül osztható 7-tel; i:=i + 1; /a ciklusmagban az inkerementálás; Ciklus vége Ki(i); /érték kiírása (sorozat!);

42

43 Eldöntés tétele

44 Megszámlálás db:=0 Ciklus i:=1-től 5-ig Ha (tömb[i]mod 2 = 0) akkor
15 12 11 17 14 Tömb: db:=0 Ciklus i:=1-től 5-ig Ha (tömb[i]mod 2 = 0) akkor db:=db+1 Elágazás vége Ciklus vége Ki(db)

45 Megszámlálás db:=0 Ciklus i:=1-től 5-ig Ha (tömb[i]mod 2 = 0) akkor
15 12 11 17 14 Tömb: db:=0 Ciklus i:=1-től 5-ig Ha (tömb[i]mod 2 = 0) akkor db:=db+1 Elágazás vége Ciklus vége Ki(db) db = 0

46 Megszámlálás db:=0 Ciklus i:=1-től 5-ig Ha (tömb[i]mod 2 = 0) akkor
15 12 11 17 14 Tömb: db:=0 Ciklus i:=1-től 5-ig Ha (tömb[i]mod 2 = 0) akkor db:=db+1 Elágazás vége Ciklus vége Ki(db) db = 0 i = 1

47 Megszámlálás db:=0 Ciklus i:=1-től 5-ig Ha (tömb[i]mod 2 = 0) akkor
15 12 11 17 14 Tömb: db:=0 Ciklus i:=1-től 5-ig Ha (tömb[i]mod 2 = 0) akkor db:=db+1 Elágazás vége Ciklus vége Ki(db) db = 0 i = 1

48 Megszámlálás db:=0 Ciklus i:=1-től 5-ig Ha (tömb[i]mod 2 = 0) akkor
15 12 11 17 14 Tömb: db:=0 Ciklus i:=1-től 5-ig Ha (tömb[i]mod 2 = 0) akkor db:=db+1 Elágazás vége Ciklus vége Ki(db) db = 1 i = 1

49 Megszámlálás db:=0 Ciklus i:=1-től 5-ig Ha (tömb[i]mod 2 = 0) akkor
15 12 11 17 14 Tömb: db:=0 Ciklus i:=1-től 5-ig Ha (tömb[i]mod 2 = 0) akkor db:=db+1 Elágazás vége Ciklus vége Ki(db) db = 1 i = 1

50 Megszámlálás db:=0 Ciklus i:=1-től 5-ig Ha (tömb[i]mod 2 = 0) akkor
15 12 11 17 14 Tömb: db:=0 Ciklus i:=1-től 5-ig Ha (tömb[i]mod 2 = 0) akkor db:=db+1 Elágazás vége Ciklus vége Ki(db) db = 1 i = 1

51 Megszámlálás db:=0 Ciklus i:=1-től 5-ig Ha (tömb[i]mod 2 = 0) akkor
15 12 11 17 14 Tömb: db:=0 Ciklus i:=1-től 5-ig Ha (tömb[i]mod 2 = 0) akkor db:=db+1 Elágazás vége Ciklus vége Ki(db) db = 1 i = 2

52 Megszámlálás db:=0 Ciklus i:=1-től 5-ig Ha (tömb[i]mod 2 = 0) akkor
15 12 11 17 14 Tömb: db:=0 Ciklus i:=1-től 5-ig Ha (tömb[i]mod 2 = 0) akkor db:=db+1 Elágazás vége Ciklus vége Ki(db) db = 1 i = 2

53 Megszámlálás db:=0 Ciklus i:=1-től 5-ig Ha (tömb[i]mod 2 = 0) akkor
15 12 11 17 14 Tömb: db:=0 Ciklus i:=1-től 5-ig Ha (tömb[i]mod 2 = 0) akkor db:=db+1 Elágazás vége Ciklus vége Ki(db) db = 1 i = 2

54 Megszámlálás db:=0 Ciklus i:=1-től 5-ig Ha (tömb[i]mod 2 = 0) akkor
15 12 11 17 14 Tömb: db:=0 Ciklus i:=1-től 5-ig Ha (tömb[i]mod 2 = 0) akkor db:=db+1 Elágazás vége Ciklus vége Ki(db) db = 1 i = 2

55 Megszámlálás db:=0 Ciklus i:=1-től 5-ig Ha (tömb[i]mod 2 = 0) akkor
15 12 11 17 14 Tömb: db:=0 Ciklus i:=1-től 5-ig Ha (tömb[i]mod 2 = 0) akkor db:=db+1 Elágazás vége Ciklus vége Ki(db) db = 1 i = 3

56 Megszámlálás db:=0 Ciklus i:=1-től 5-ig Ha (tömb[i]mod 2 = 0) akkor
15 12 11 17 14 Tömb: db:=0 Ciklus i:=1-től 5-ig Ha (tömb[i]mod 2 = 0) akkor db:=db+1 Elágazás vége Ciklus vége Ki(db) db = 1 i = 3

57 Megszámlálás db:=0 Ciklus i:=1-től 5-ig Ha (tömb[i]mod 2 = 0) akkor
15 12 11 17 14 Tömb: db:=0 Ciklus i:=1-től 5-ig Ha (tömb[i]mod 2 = 0) akkor db:=db+1 Elágazás vége Ciklus vége Ki(db) db = 1 i = 3

58 Megszámlálás db:=0 Ciklus i:=1-től 5-ig Ha (tömb[i]mod 2 = 0) akkor
15 12 11 17 14 Tömb: db:=0 Ciklus i:=1-től 5-ig Ha (tömb[i]mod 2 = 0) akkor db:=db+1 Elágazás vége Ciklus vége Ki(db) db = 1 i = 3

59 Megszámlálás db:=0 Ciklus i:=1-től 5-ig Ha (tömb[i]mod 2 = 0) akkor
15 12 11 17 14 Tömb: db:=0 Ciklus i:=1-től 5-ig Ha (tömb[i]mod 2 = 0) akkor db:=db+1 Elágazás vége Ciklus vége Ki(db) db = 1 i = 4

60 Megszámlálás db:=0 Ciklus i:=1-től 5-ig Ha (tömb[i]mod 2 = 0) akkor
15 12 11 17 14 Tömb: db:=0 Ciklus i:=1-től 5-ig Ha (tömb[i]mod 2 = 0) akkor db:=db+1 Elágazás vége Ciklus vége Ki(db) db = 1 i = 4

61 Megszámlálás db:=0 Ciklus i:=1-től 5-ig Ha (tömb[i]mod 2 = 0) akkor
15 12 11 17 14 Tömb: db:=0 Ciklus i:=1-től 5-ig Ha (tömb[i]mod 2 = 0) akkor db:=db+1 Elágazás vége Ciklus vége Ki(db) db = 1 i = 4

62 Megszámlálás db:=0 Ciklus i:=1-től 5-ig Ha (tömb[i]mod 2 = 0) akkor
15 12 11 17 14 Tömb: db:=0 Ciklus i:=1-től 5-ig Ha (tömb[i]mod 2 = 0) akkor db:=db+1 Elágazás vége Ciklus vége Ki(db) db = 1 i = 4

63 Megszámlálás db:=0 Ciklus i:=1-től 5-ig Ha (tömb[i]mod 2 = 0) akkor
15 12 11 17 14 Tömb: db:=0 Ciklus i:=1-től 5-ig Ha (tömb[i]mod 2 = 0) akkor db:=db+1 Elágazás vége Ciklus vége Ki(db) db = 1 i = 5

64 Megszámlálás db:=0 Ciklus i:=1-től 5-ig Ha (tömb[i]mod 2 = 0) akkor
15 12 11 17 14 Tömb: db:=0 Ciklus i:=1-től 5-ig Ha (tömb[i]mod 2 = 0) akkor db:=db+1 Elágazás vége Ciklus vége Ki(db) db = 1 i = 5

65 Megszámlálás db:=0 Ciklus i:=1-től 5-ig Ha (tömb[i]mod 2 = 0) akkor
15 12 11 17 14 Tömb: db:=0 Ciklus i:=1-től 5-ig Ha (tömb[i]mod 2 = 0) akkor db:=db+1 Elágazás vége Ciklus vége Ki(db) db = 2 i = 5

66 Megszámlálás db:=0 Ciklus i:=1-től 5-ig Ha (tömb[i]mod 2 = 0) akkor
15 12 11 17 14 Tömb: db:=0 Ciklus i:=1-től 5-ig Ha (tömb[i]mod 2 = 0) akkor db:=db+1 Elágazás vége Ciklus vége Ki(db) db = 2 i = 5

67 Megszámlálás db:=0 Ciklus i:=1-től 5-ig Ha (tömb[i]mod 2 = 0) akkor
15 12 11 17 14 Tömb: db:=0 Ciklus i:=1-től 5-ig Ha (tömb[i]mod 2 = 0) akkor db:=db+1 Elágazás vége Ciklus vége Ki(db) db = 2 i = 5

68 Megszámlálás db:=0 Ciklus i:=1-től 5-ig Ha (tömb[i]mod 2 = 0) akkor
15 12 11 17 14 Tömb: db:=0 Ciklus i:=1-től 5-ig Ha (tömb[i]mod 2 = 0) akkor db:=db+1 Elágazás vége Ciklus vége Ki(db) db = 2 i = 5

69 Eldöntés tétele

70 Eldöntés i:=0 talált:=hamis Ciklus amíg ((nem talált) ÉS (i<5))
15 12 11 17 14 Tömb: i:=0 talált:=hamis Ciklus amíg ((nem talált) ÉS (i<5)) i:=i+1 talált:=(tömb[i] mod 2 = 0) Ciklus vége Ki(talált)

71 Eldöntés i:=0 talált:=hamis Ciklus amíg ((nem talált) ÉS (i<5))
15 12 11 17 14 Tömb: i:=0 talált:=hamis Ciklus amíg ((nem talált) ÉS (i<5)) i:=i+1 talált:=(tömb[i] mod 2 = 0) Ciklus vége Ki(talált) i = 0

72 Eldöntés i:=0 talált:=hamis Ciklus amíg ((nem talált) ÉS (i<5))
15 12 11 17 14 Tömb: i:=0 talált:=hamis Ciklus amíg ((nem talált) ÉS (i<5)) i:=i+1 talált:=(tömb[i] mod 2 = 0) Ciklus vége Ki(talált) i = 0 talált = hamis

73 Eldöntés i:=0 talált:=hamis Ciklus amíg ((nem talált) ÉS (i<5))
15 12 11 17 14 Tömb: i:=0 talált:=hamis Ciklus amíg ((nem talált) ÉS (i<5)) i:=i+1 talált:=(tömb[i] mod 2 = 0) Ciklus vége Ki(talált) i = 0 talált = hamis

74 Eldöntés i:=0 talált:=hamis Ciklus amíg ((nem talált) ÉS (i<5))
15 12 11 17 14 Tömb: i:=0 talált:=hamis Ciklus amíg ((nem talált) ÉS (i<5)) i:=i+1 talált:=(tömb[i] mod 2 = 0) Ciklus vége Ki(talált) i = 1 talált = hamis

75 Eldöntés i:=0 talált:=hamis Ciklus amíg ((nem talált) ÉS (i<5))
15 12 11 17 14 Tömb: i:=0 talált:=hamis Ciklus amíg ((nem talált) ÉS (i<5)) i:=i+1 talált:=(tömb[i] mod 2 = 0) Ciklus vége Ki(talált) i = 1 talált = hamis

76 Eldöntés i:=0 talált:=hamis Ciklus amíg ((nem talált) ÉS (i<5))
15 12 11 17 14 Tömb: i:=0 talált:=hamis Ciklus amíg ((nem talált) ÉS (i<5)) i:=i+1 talált:=(tömb[i] mod 2 = 0) Ciklus vége Ki(talált) i = 1 talált = hamis

77 Eldöntés i:=0 talált:=hamis Ciklus amíg ((nem talált) ÉS (i<5))
15 12 11 17 14 Tömb: i:=0 talált:=hamis Ciklus amíg ((nem talált) ÉS (i<5)) i:=i+1 talált:=(tömb[i] mod 2 = 0) Ciklus vége Ki(talált) i = 1 talált = hamis

78 Eldöntés i:=0 talált:=hamis Ciklus amíg ((nem talált) ÉS (i<5))
15 12 11 17 14 Tömb: i:=0 talált:=hamis Ciklus amíg ((nem talált) ÉS (i<5)) i:=i+1 talált:=(tömb[i] mod 2 = 0) Ciklus vége Ki(talált) i = 2 talált = hamis

79 Eldöntés i:=0 talált:=hamis Ciklus amíg ((nem talált) ÉS (i<5))
15 12 11 17 14 Tömb: i:=0 talált:=hamis Ciklus amíg ((nem talált) ÉS (i<5)) i:=i+1 talált:=(tömb[i] mod 2 = 0) Ciklus vége Ki(talált) i = 2 talált = hamis

80 Eldöntés i:=0 talált:=hamis Ciklus amíg ((nem talált) ÉS (i<5))
15 12 11 17 14 Tömb: i:=0 talált:=hamis Ciklus amíg ((nem talált) ÉS (i<5)) i:=i+1 talált:=(tömb[i] mod 2 = 0) Ciklus vége Ki(talált) i = 2 talált = hamis

81 Eldöntés i:=0 talált:=hamis Ciklus amíg ((nem talált) ÉS (i<5))
15 12 11 17 14 Tömb: i:=0 talált:=hamis Ciklus amíg ((nem talált) ÉS (i<5)) i:=i+1 talált:=(tömb[i] mod 2 = 0) Ciklus vége Ki(talált) i = 2 talált = hamis

82 Eldöntés i:=0 talált:=hamis Ciklus amíg ((nem talált) ÉS (i<5))
15 12 11 17 14 Tömb: i:=0 talált:=hamis Ciklus amíg ((nem talált) ÉS (i<5)) i:=i+1 talált:=(tömb[i] mod 2 = 0) Ciklus vége Ki(talált) i = 3 talált = hamis

83 Eldöntés i:=0 talált:=hamis Ciklus amíg ((nem talált) ÉS (i<5))
15 12 11 17 14 Tömb: i:=0 talált:=hamis Ciklus amíg ((nem talált) ÉS (i<5)) i:=i+1 talált:=(tömb[i] mod 2 = 0) Ciklus vége Ki(talált) i = 3 talált = igaz

84 Eldöntés i:=0 talált:=hamis Ciklus amíg ((nem talált) ÉS (i<5))
15 12 11 17 14 Tömb: i:=0 talált:=hamis Ciklus amíg ((nem talált) ÉS (i<5)) i:=i+1 talált:=(tömb[i] mod 2 = 0) Ciklus vége Ki(talált) i = 3 talált = igaz

85 Eldöntés i:=0 talált:=hamis Ciklus amíg ((nem talált) ÉS (i<5))
15 12 11 17 14 Tömb: i:=0 talált:=hamis Ciklus amíg ((nem talált) ÉS (i<5)) i:=i+1 talált:=(tömb[i] mod 2 = 0) Ciklus vége Ki(talált) i = 3 talált = igaz

86 Eldöntés i:=0 talált:=hamis Ciklus amíg ((nem talált) ÉS (i<5))
15 12 11 17 14 Tömb: i:=0 talált:=hamis Ciklus amíg ((nem talált) ÉS (i<5)) i:=i+1 talált:=(tömb[i] mod 2 = 0) Ciklus vége Ki(talált) i = 3 talált = igaz

87 Eldöntés i:=0 talált:=hamis Ciklus amíg ((nem talált) ÉS (i<5))
15 12 11 17 14 Tömb: i:=0 talált:=hamis Ciklus amíg ((nem talált) ÉS (i<5)) i:=i+1 talált:=(tömb[i] mod 2 = 0) Ciklus vége Ki(talált) i = 3 talált = igaz

88

89 Kiválogatás tétele

90 Kiválogatás tétele II.

91 Kiválogatás j:=0 Ciklus i:=1-től 5-ig Ha (tömb[i] mod 2 = 0) akkor
15 12 11 17 14 Forrás: Cél: j:=0 Ciklus i:=1-től 5-ig Ha (tömb[i] mod 2 = 0) akkor j:=j+1 Cél[j]:=Forrás[i] Elágazás vége Ciklus vége

92 Kiválogatás j:=0 Ciklus i:=1-től 5-ig Ha (tömb[i] mod 2 = 0) akkor
15 12 11 17 14 Forrás: Cél: j:=0 Ciklus i:=1-től 5-ig Ha (tömb[i] mod 2 = 0) akkor j:=j+1 Cél[j]:=Forrás[i] Elágazás vége Ciklus vége j = 0

93 Kiválogatás j:=0 Ciklus i:=1-től 5-ig Ha (tömb[i] mod 2 = 0) akkor
15 12 11 17 14 Forrás: Cél: j:=0 Ciklus i:=1-től 5-ig Ha (tömb[i] mod 2 = 0) akkor j:=j+1 Cél[j]:=Forrás[i] Elágazás vége Ciklus vége j = 0 i = 1

94 Kiválogatás j:=0 Ciklus i:=1-től 5-ig Ha (tömb[i] mod 2 = 0) akkor
15 12 11 17 14 Forrás: Cél: j:=0 Ciklus i:=1-től 5-ig Ha (tömb[i] mod 2 = 0) akkor j:=j+1 Cél[j]:=Forrás[i] Elágazás vége Ciklus vége j = 0 i = 1

95 Kiválogatás j:=0 Ciklus i:=1-től 5-ig Ha (tömb[i] mod 2 = 0) akkor
15 12 11 17 14 Forrás: Cél: j:=0 Ciklus i:=1-től 5-ig Ha (tömb[i] mod 2 = 0) akkor j:=j+1 Cél[j]:=Forrás[i] Elágazás vége Ciklus vége j = 0 i = 1

96 Kiválogatás j:=0 Ciklus i:=1-től 5-ig Ha (tömb[i] mod 2 = 0) akkor
15 12 11 17 14 Forrás: Cél: j:=0 Ciklus i:=1-től 5-ig Ha (tömb[i] mod 2 = 0) akkor j:=j+1 Cél[j]:=Forrás[i] Elágazás vége Ciklus vége j = 0 i = 1

97 Kiválogatás j:=0 Ciklus i:=1-től 5-ig Ha (tömb[i] mod 2 = 0) akkor
15 12 11 17 14 Forrás: Cél: j:=0 Ciklus i:=1-től 5-ig Ha (tömb[i] mod 2 = 0) akkor j:=j+1 Cél[j]:=Forrás[i] Elágazás vége Ciklus vége j = 0 i = 2

98 Kiválogatás j:=0 Ciklus i:=1-től 5-ig Ha (tömb[i] mod 2 = 0) akkor
15 12 11 17 14 Forrás: Cél: j:=0 Ciklus i:=1-től 5-ig Ha (tömb[i] mod 2 = 0) akkor j:=j+1 Cél[j]:=Forrás[i] Elágazás vége Ciklus vége j = 0 i = 2

99 Kiválogatás j:=0 Ciklus i:=1-től 5-ig Ha (tömb[i] mod 2 = 0) akkor
15 12 11 17 14 Forrás: Cél: j:=0 Ciklus i:=1-től 5-ig Ha (tömb[i] mod 2 = 0) akkor j:=j+1 Cél[j]:=Forrás[i] Elágazás vége Ciklus vége j = 0 i = 2

100 Kiválogatás j:=0 Ciklus i:=1-től 5-ig Ha (tömb[i] mod 2 = 0) akkor
15 12 11 17 14 Forrás: Cél: j:=0 Ciklus i:=1-től 5-ig Ha (tömb[i] mod 2 = 0) akkor j:=j+1 Cél[j]:=Forrás[i] Elágazás vége Ciklus vége j = 0 i = 2

101 Kiválogatás j:=0 Ciklus i:=1-től 5-ig Ha (tömb[i] mod 2 = 0) akkor
15 12 11 17 14 Forrás: Cél: j:=0 Ciklus i:=1-től 5-ig Ha (tömb[i] mod 2 = 0) akkor j:=j+1 Cél[j]:=Forrás[i] Elágazás vége Ciklus vége j = 0 i = 3

102 Kiválogatás j:=0 Ciklus i:=1-től 5-ig Ha (tömb[i] mod 2 = 0) akkor
15 12 11 17 14 Forrás: Cél: j:=0 Ciklus i:=1-től 5-ig Ha (tömb[i] mod 2 = 0) akkor j:=j+1 Cél[j]:=Forrás[i] Elágazás vége Ciklus vége j = 0 i = 3

103 Kiválogatás j:=0 Ciklus i:=1-től 5-ig Ha (tömb[i] mod 2 = 0) akkor
15 12 11 17 14 Forrás: Cél: j:=0 Ciklus i:=1-től 5-ig Ha (tömb[i] mod 2 = 0) akkor j:=j+1 Cél[j]:=Forrás[i] Elágazás vége Ciklus vége j = 1 i = 3

104 Kiválogatás j:=0 Ciklus i:=1-től 5-ig Ha (tömb[i] mod 2 = 0) akkor
Forrás: 11 15 12 17 14 Cél: 12 j:=0 Ciklus i:=1-től 5-ig Ha (tömb[i] mod 2 = 0) akkor j:=j+1 Cél[j]:=Forrás[i] Elágazás vége Ciklus vége j = 1 i = 3

105 Kiválogatás j:=0 Ciklus i:=1-től 5-ig Ha (tömb[i] mod 2 = 0) akkor
15 12 11 17 14 Forrás: Cél: 12 j:=0 Ciklus i:=1-től 5-ig Ha (tömb[i] mod 2 = 0) akkor j:=j+1 Cél[j]:=Forrás[i] Elágazás vége Ciklus vége j = 1 i = 3

106 Kiválogatás j:=0 Ciklus i:=1-től 5-ig Ha (tömb[i] mod 2 = 0) akkor
15 12 11 17 14 Forrás: Cél: 12 j:=0 Ciklus i:=1-től 5-ig Ha (tömb[i] mod 2 = 0) akkor j:=j+1 Cél[j]:=Forrás[i] Elágazás vége Ciklus vége j = 1 i = 3

107 Kiválogatás j:=0 Ciklus i:=1-től 5-ig Ha (tömb[i] mod 2 = 0) akkor
15 12 11 17 14 Forrás: Cél: 12 j:=0 Ciklus i:=1-től 5-ig Ha (tömb[i] mod 2 = 0) akkor j:=j+1 Cél[j]:=Forrás[i] Elágazás vége Ciklus vége j = 1 i = 4

108 Kiválogatás j:=0 Ciklus i:=1-től 5-ig Ha (tömb[i] mod 2 = 0) akkor
15 12 11 17 14 Forrás: Cél: 12 j:=0 Ciklus i:=1-től 5-ig Ha (tömb[i] mod 2 = 0) akkor j:=j+1 Cél[j]:=Forrás[i] Elágazás vége Ciklus vége j = 1 i = 4

109 Kiválogatás j:=0 Ciklus i:=1-től 5-ig Ha (tömb[i] mod 2 = 0) akkor
15 12 11 17 14 Forrás: Cél: 12 j:=0 Ciklus i:=1-től 5-ig Ha (tömb[i] mod 2 = 0) akkor j:=j+1 Cél[j]:=Forrás[i] Elágazás vége Ciklus vége j = 1 i = 4

110 Kiválogatás j:=0 Ciklus i:=1-től 5-ig Ha (tömb[i] mod 2 = 0) akkor
15 12 11 17 14 Forrás: Cél: 12 j:=0 Ciklus i:=1-től 5-ig Ha (tömb[i] mod 2 = 0) akkor j:=j+1 Cél[j]:=Forrás[i] Elágazás vége Ciklus vége j = 1 i = 4

111 Kiválogatás j:=0 Ciklus i:=1-től 5-ig Ha (tömb[i] mod 2 = 0) akkor
15 12 11 17 14 Forrás: Cél: 12 j:=0 Ciklus i:=1-től 5-ig Ha (tömb[i] mod 2 = 0) akkor j:=j+1 Cél[j]:=Forrás[i] Elágazás vége Ciklus vége j = 1 i = 5

112 Kiválogatás j:=0 Ciklus i:=1-től 5-ig Ha (tömb[i] mod 2 = 0) akkor
15 12 11 17 14 Forrás: Cél: 12 j:=0 Ciklus i:=1-től 5-ig Ha (tömb[i] mod 2 = 0) akkor j:=j+1 Cél[j]:=Forrás[i] Elágazás vége Ciklus vége j = 1 i = 5

113 Kiválogatás j:=0 Ciklus i:=1-től 5-ig Ha (tömb[i] mod 2 = 0) akkor
15 12 11 17 14 Forrás: Cél: 12 j:=0 Ciklus i:=1-től 5-ig Ha (tömb[i] mod 2 = 0) akkor j:=j+1 Cél[j]:=Forrás[i] Elágazás vége Ciklus vége j = 2 i = 5

114 Kiválogatás j:=0 Ciklus i:=1-től 5-ig Ha (tömb[i] mod 2 = 0) akkor
15 12 11 17 14 Forrás: Cél: 12 14 j:=0 Ciklus i:=1-től 5-ig Ha (tömb[i] mod 2 = 0) akkor j:=j+1 Cél[j]:=Forrás[i] Elágazás vége Ciklus vége j = 2 i = 5

115 Kiválogatás j:=0 Ciklus i:=1-től 5-ig Ha (tömb[i] mod 2 = 0) akkor
15 12 11 17 14 Forrás: Cél: 12 14 j:=0 Ciklus i:=1-től 5-ig Ha (tömb[i] mod 2 = 0) akkor j:=j+1 Cél[j]:=Forrás[i] Elágazás vége Ciklus vége j = 2 i = 5

116 Kiválogatás j:=0 Ciklus i:=1-től 5-ig Ha (tömb[i] mod 2 = 0) akkor
15 12 11 17 14 Forrás: Cél: 12 14 j:=0 Ciklus i:=1-től 5-ig Ha (tömb[i] mod 2 = 0) akkor j:=j+1 Cél[j]:=Forrás[i] Elágazás vége Ciklus vége j = 2 i = 5

117

118 Maximum-minimum kiválasztás tétele

119 Maximumkeresés tétele
Legyen adott az n elemű A sorozat és egy a sorozat elemein értelmezett rendezési reláció. Határozzuk meg a sorozat legnagyobb értékű elemének sorszámát és értékét! A maximális elem sorszámát az i, értékét a max változó tartalmazza.

120 Feltételes maximumkeresés tétele
Legyen adott az n elemű A sorozat, egy a sorozat elemein értelmezett β tulajdonság (logikai függvény), valamint egy a sorozat elemein értelmezett rendezési reláció. Határozzuk meg a sorozat β tulajdonságú elemei közül a legnagyobb értékű elem sorszámát és értékét! A maximális β tulajdonságú elem sorszámát az i, értékét a max változó tartalmazza.

121 Maximum kiválasztás 15 12 11 17 14 Tömb: i:=1 ind:=1 max:=tömb[1]
Ciklus amíg (i<5) i:=i+1 Ha (max<tömb[i]) akkor max:=tömb[i] ind:=i Elágazás vége Ciklus vége Ki(max) Ki(ind)

122 Maximum kiválasztás 15 12 11 17 14 Tömb: i:=1 ind:=1 max:=tömb[1]
Ciklus amíg (i<5) i:=i+1 Ha (max<tömb[i]) akkor max:=tömb[i] ind:=i Elágazás vége Ciklus vége Ki(max) Ki(ind) i = 1

123 Maximum kiválasztás 15 12 11 17 14 Tömb: i:=1 ind:=1 max:=tömb[1]
Ciklus amíg (i<5) i:=i+1 Ha (max<tömb[i]) akkor max:=tömb[i] ind:=i Elágazás vége Ciklus vége Ki(max) Ki(ind) i = 1 ind = 1

124 Maximum kiválasztás 15 12 11 17 14 Tömb: i:=1 ind:=1 max:=tömb[1]
Ciklus amíg (i<5) i:=i+1 Ha (max<tömb[i]) akkor max:=tömb[i] ind:=i Elágazás vége Ciklus vége Ki(max) Ki(ind) i = 1 ind = 1 max = 11

125 Maximum kiválasztás 15 12 11 17 14 Tömb: i:=1 ind:=1 max:=tömb[1]
Ciklus amíg (i<5) i:=i+1 Ha (max<tömb[i]) akkor max:=tömb[i] ind:=i Elágazás vége Ciklus vége Ki(max) Ki(ind) i = 1 ind = 1 max = 11

126 Maximum kiválasztás 15 12 11 17 14 Tömb: i:=1 ind:=1 max:=tömb[1]
Ciklus amíg (i<5) i:=i+1 Ha (max<tömb[i]) akkor max:=tömb[i] ind:=i Elágazás vége Ciklus vége Ki(max) Ki(ind) i = 2 ind = 1 max = 11

127 Maximum kiválasztás 15 12 11 17 14 Tömb: i:=1 ind:=1 max:=tömb[1]
Ciklus amíg (i<5) i:=i+1 Ha (max<tömb[i]) akkor max:=tömb[i] ind:=i Elágazás vége Ciklus vége Ki(max) Ki(ind) i = 2 ind = 1 max = 11

128 Maximum kiválasztás 15 12 11 17 14 Tömb: i:=1 ind:=1 max:=tömb[1]
Ciklus amíg (i<5) i:=i+1 Ha (max<tömb[i]) akkor max:=tömb[i] ind:=i Elágazás vége Ciklus vége Ki(max) Ki(ind) i = 2 ind =1 max = 15

129 Maximum kiválasztás 15 12 11 17 14 Tömb: i:=1 ind:=1 max:=tömb[1]
Ciklus amíg (i<5) i:=i+1 Ha (max<tömb[i]) akkor max:=tömb[i] ind:=i Elágazás vége Ciklus vége Ki(max) Ki(ind) i = 2 ind = 2 max = 15

130 Maximum kiválasztás 15 12 11 17 14 Tömb: i:=1 ind:=1 max:=tömb[1]
Ciklus amíg (i<5) i:=i+1 Ha (max<tömb[i]) akkor max:=tömb[i] ind:=i Elágazás vége Ciklus vége Ki(max) Ki(ind) i = 2 ind = 2 max = 15

131 Maximum kiválasztás 15 12 11 17 14 Tömb: i:=1 ind:=1 max:=tömb[1]
Ciklus amíg (i<5) i:=i+1 Ha (max<tömb[i]) akkor max:=tömb[i] ind:=i Elágazás vége Ciklus vége Ki(max) Ki(ind) i = 2 ind = 2 max = 15

132 Maximum kiválasztás 15 12 11 17 14 Tömb: i:=1 ind:=1 max:=tömb[1]
Ciklus amíg (i<5) i:=i+1 Ha (max<tömb[i]) akkor max:=tömb[i] ind:=i Elágazás vége Ciklus vége Ki(max) Ki(ind) i = 2 ind = 2 max = 15

133 Maximum kiválasztás 15 12 11 17 14 Tömb: i:=1 ind:=1 max:=tömb[1]
Ciklus amíg (i<5) i:=i+1 Ha (max<tömb[i]) akkor max:=tömb[i] ind:=i Elágazás vége Ciklus vége Ki(max) Ki(ind) i = 3 ind = 2 max = 15

134 Maximum kiválasztás 15 12 11 17 14 Tömb: i:=1 ind:=1 max:=tömb[1]
Ciklus amíg (i<5) i:=i+1 Ha (max<tömb[i]) akkor max:=tömb[i] ind:=i Elágazás vége Ciklus vége Ki(max) Ki(ind) i = 3 ind = 2 max = 15

135 Maximum kiválasztás 15 12 11 17 14 Tömb: i:=1 ind:=1 max:=tömb[1]
Ciklus amíg (i<5) i:=i+1 Ha (max<tömb[i]) akkor max:=tömb[i] ind:=i Elágazás vége Ciklus vége Ki(max) Ki(ind) i = 3 ind = 2 max = 15

136 Maximum kiválasztás 15 12 11 17 14 Tömb: i:=1 ind:=1 max:=tömb[1]
Ciklus amíg (i<5) i:=i+1 Ha (max<tömb[i]) akkor max:=tömb[i] ind:=i Elágazás vége Ciklus vége Ki(max) Ki(ind) i = 3 ind = 2 max = 15

137 Maximum kiválasztás 15 12 11 17 14 Tömb: i:=1 ind:=1 max:=tömb[1]
Ciklus amíg (i<5) i:=i+1 Ha (max<tömb[i]) akkor max:=tömb[i] ind:=i Elágazás vége Ciklus vége Ki(max) Ki(ind) i = 3 ind = 2 max = 15

138 Maximum kiválasztás 15 12 11 17 14 Tömb: i:=1 ind:=1 max:=tömb[1]
Ciklus amíg (i<5) i:=i+1 Ha (max<tömb[i]) akkor max:=tömb[i] ind:=i Elágazás vége Ciklus vége Ki(max) Ki(ind) i = 4 ind = 2 max = 15

139 Maximum kiválasztás 15 12 11 17 14 Tömb: i:=1 ind:=1 max:=tömb[1]
Ciklus amíg (i<5) i:=i+1 Ha (max<tömb[i]) akkor max:=tömb[i] ind:=i Elágazás vége Ciklus vége Ki(max) Ki(ind) i = 4 ind = 2 max = 15

140 Maximum kiválasztás 15 12 11 17 14 Tömb: i:=1 ind:=1 max:=tömb[1]
Ciklus amíg (i<5) i:=i+1 Ha (max<tömb[i]) akkor max:=tömb[i] ind:=i Elágazás vége Ciklus vége Ki(max) Ki(ind) i = 4 ind = 2 max = 17

141 Maximum kiválasztás 15 12 11 17 14 Tömb: i:=1 ind:=1 max:=tömb[1]
Ciklus amíg (i<5) i:=i+1 Ha (max<tömb[i]) akkor max:=tömb[i] ind:=i Elágazás vége Ciklus vége Ki(max) Ki(ind) i = 4 ind = 4 max = 17

142 Maximum kiválasztás 15 12 11 17 14 Tömb: i:=1 ind:=1 max:=tömb[1]
Ciklus amíg (i<5) i:=i+1 Ha (max<tömb[i]) akkor max:=tömb[i] ind:=i Elágazás vége Ciklus vége Ki(max) Ki(ind) i = 4 ind = 4 max = 17

143 Maximum kiválasztás 15 12 11 17 14 Tömb: i:=1 ind:=1 max:=tömb[1]
Ciklus amíg (i<5) i:=i+1 Ha (max<tömb[i]) akkor max:=tömb[i] ind:=i Elágazás vége Ciklus vége Ki(max) Ki(ind) i = 4 ind = 4 max = 17

144 Maximum kiválasztás 15 12 11 17 14 Tömb: i:=1 ind:=1 max:=tömb[1]
Ciklus amíg (i<5) i:=i+1 Ha (max<tömb[i]) akkor max:=tömb[i] ind:=i Elágazás vége Ciklus vége Ki(max) Ki(ind) i = 4 ind = 4 max = 17

145 Maximum kiválasztás 15 12 11 17 14 Tömb: i:=1 ind:=1 max:=tömb[1]
Ciklus amíg (i<5) i:=i+1 Ha (max<tömb[i]) akkor max:=tömb[i] ind:=i Elágazás vége Ciklus vége Ki(max) Ki(ind) i = 5 ind = 4 max = 17

146 Maximum kiválasztás 15 12 11 17 14 Tömb: i:=1 ind:=1 max:=tömb[1]
Ciklus amíg (i<5) i:=i+1 Ha (max<tömb[i]) akkor max:=tömb[i] ind:=i Elágazás vége Ciklus vége Ki(max) Ki(ind) i = 5 ind = 4 max = 17

147 Maximum kiválasztás 15 12 11 17 14 Tömb: i:=1 ind:=1 max:=tömb[1]
Ciklus amíg (i<5) i:=i+1 Ha (max<tömb[i]) akkor max:=tömb[i] ind:=i Elágazás vége Ciklus vége Ki(max) Ki(ind) i = 5 ind = 4 max = 17

148 Maximum kiválasztás 15 12 11 17 14 Tömb: i:=1 ind:=1 max:=tömb[1]
Ciklus amíg (i<5) i:=i+1 Ha (max<tömb[i]) akkor max:=tömb[i] ind:=i Elágazás vége Ciklus vége Ki(max) Ki(ind) i = 5 ind = 4 max = 17

149 Maximum kiválasztás 15 12 11 17 14 Tömb: i:=1 ind:=1 max:=tömb[1]
Ciklus amíg (i<5) i:=i+1 Ha (max<tömb[i]) akkor max:=tömb[i] ind:=i Elágazás vége Ciklus vége Ki(max) Ki(ind) i = 5 ind = 4 max = 17

150 Maximum kiválasztás 15 12 11 17 14 Tömb: i:=1 ind:=1 max:=tömb[1]
Ciklus amíg (i<5) i:=i+1 Ha (max<tömb[i]) akkor max:=tömb[i] ind:=i Elágazás vége Ciklus vége Ki(max) Ki(ind) i = 5 ind = 4 max = 17

151

152

153 Lineáris keresés tétele

154 Lineáris keresés tétele
Legyen adott az n elemű A sorozat és egy a sorozat elemein értelmezett β tulajdonság (logikai függvény). Keressük meg a sorozat első β tulajdonságú elemét! (Nem biztos, hogy van β tulajdonságú elem.) A keresés eredményeként az l logikai változó igaz értéket tartalmaz, ha találtunk β tulajdonságú elemet és hamis értéket, ha nem találtunk. Ha volt β tulajdonságú elem, akkor az első ilyen elem sorszámát a k változó tartalmazza.

155 Keresés 15 12 11 17 14 Tömb: i:=0 talált:=hamis
Ciklus amíg ((nem talált) ÉS (i < 5)) i:=i + 1 talált:=(tömb[i] mod 2 = 0) Ciklus vége Ha (talált) Ki(i) Különben Ki(‘Nincs ilyen!’) Elágazás vége

156 Keresés 15 12 11 17 14 Tömb: i:=0 talált:=hamis
Ciklus amíg ((nem talált) ÉS (i < 5)) i:=i + 1 talált:=(tömb[i] mod 2 = 0) Ciklus vége Ha (talált) Ki(i) Különben Ki(‘Nincs ilyen!’) Elágazás vége i = 0

157 Keresés 15 12 11 17 14 Tömb: i:=0 talált:=hamis
Ciklus amíg ((nem talált) ÉS (i < 5)) i:=i + 1 talált:=(tömb[i] mod 2 = 0) Ciklus vége Ha (talált) Ki(i) Különben Ki(‘Nincs ilyen!’) Elágazás vége i = 0 talált = hamis

158 Keresés 15 12 11 17 14 Tömb: i:=0 talált:=hamis
Ciklus amíg ((nem talált) ÉS (i < 5)) i:=i + 1 talált:=(tömb[i] mod 2 = 0) Ciklus vége Ha (talált) Ki(i) Különben Ki(‘Nincs ilyen!’) Elágazás vége i = 0 talált = hamis

159 Keresés 15 12 11 17 14 Tömb: i:=0 talált:=hamis
Ciklus amíg ((nem talált) ÉS (i < 5)) i:=i + 1 talált:=(tömb[i] mod 2 = 0) Ciklus vége Ha (talált) Ki(i) Különben Ki(‘Nincs ilyen!’) Elágazás vége i = 1 talált = hamis

160 Keresés 15 12 11 17 14 Tömb: i:=0 talált:=hamis
Ciklus amíg ((nem talált) ÉS (i < 5)) i:=i + 1 talált:=(tömb[i] mod 2 = 0) Ciklus vége Ha (talált) Ki(i) Különben Ki(‘Nincs ilyen!’) Elágazás vége i = 1 talált = hamis

161 Keresés 15 12 11 17 14 Tömb: i:=0 talált:=hamis
Ciklus amíg ((nem talált) ÉS (i < 5)) i:=i + 1 talált:=(tömb[i] mod 2 = 0) Ciklus vége Ha (talált) Ki(i) Különben Ki(‘Nincs ilyen!’) Elágazás vége i = 1 talált = hamis

162 Keresés 15 12 11 17 14 Tömb: i:=0 talált:=hamis
Ciklus amíg ((nem talált) ÉS (i < 5)) i:=i + 1 talált:=(tömb[i] mod 2 = 0) Ciklus vége Ha (talált) Ki(i) Különben Ki(‘Nincs ilyen!’) Elágazás vége i = 1 talált = hamis

163 Keresés 15 12 11 17 14 Tömb: i:=0 talált:=hamis
Ciklus amíg ((nem talált) ÉS (i < 5)) i:=i + 1 talált:=(tömb[i] mod 2 = 0) Ciklus vége Ha (talált) Ki(i) Különben Ki(‘Nincs ilyen!’) Elágazás vége i = 2 talált = hamis

164 Keresés 15 12 11 17 14 Tömb: i:=0 talált:=hamis
Ciklus amíg ((nem talált) ÉS (i < 5)) i:=i + 1 talált:=(tömb[i] mod 2 = 0) Ciklus vége Ha (talált) Ki(i) Különben Ki(‘Nincs ilyen!’) Elágazás vége i = 2 talált = hamis

165 Keresés 15 12 11 17 14 Tömb: i:=0 talált:=hamis
Ciklus amíg ((nem talált) ÉS (i < 5)) i:=i + 1 talált:=(tömb[i] mod 2 = 0) Ciklus vége Ha (talált) Ki(i) Különben Ki(‘Nincs ilyen!’) Elágazás vége i = 2 talált = hamis

166 Keresés 15 12 11 17 14 Tömb: i:=0 talált:=hamis
Ciklus amíg ((nem talált) ÉS (i < 5)) i:=i + 1 talált:=(tömb[i] mod 2 = 0) Ciklus vége Ha (talált) Ki(i) Különben Ki(‘Nincs ilyen!’) Elágazás vége i = 2 talált = hamis

167 Keresés 15 12 11 17 14 Tömb: i:=0 talált:=hamis
Ciklus amíg ((nem talált) ÉS (i < 5)) i:=i + 1 talált:=(tömb[i] mod 2 = 0) Ciklus vége Ha (talált) Ki(i) Különben Ki(‘Nincs ilyen!’) Elágazás vége i = 3 talált = hamis

168 Keresés 15 12 11 17 14 Tömb: i:=0 talált:=hamis
Ciklus amíg ((nem talált) ÉS (i < 5)) i:=i + 1 talált:=(tömb[i] mod 2 = 0) Ciklus vége Ha (talált) Ki(i) Különben Ki(‘Nincs ilyen!’) Elágazás vége i = 3 talált = igaz

169 Keresés 15 12 11 17 14 Tömb: i:=0 talált:=hamis
Ciklus amíg ((nem talált) ÉS (i < 5)) i:=i + 1 talált:=(tömb[i] mod 2 = 0) Ciklus vége Ha (talált) Ki(i) Különben Ki(‘Nincs ilyen!’) Elágazás vége i = 3 talált = igaz

170 Keresés 15 12 11 17 14 Tömb: i:=0 talált:=hamis
Ciklus amíg ((nem talált) ÉS (i < 5)) i:=i + 1 talált:=(tömb[i] mod 2 = 0) Ciklus vége Ha (talált) Ki(i) Különben Ki(‘Nincs ilyen!’) Elágazás vége i = 3 talált = igaz

171 Keresés 15 12 11 17 14 Tömb: i:=0 talált:=hamis
Ciklus amíg ((nem talált) ÉS (i < 5)) i:=i + 1 talált:=(tömb[i] mod 2 = 0) Ciklus vége Ha (talált) Ki(i) Különben Ki(‘Nincs ilyen!’) Elágazás vége i = 3 talált = igaz

172 Keresés 15 12 11 17 14 Tömb: i:=0 talált:=hamis
Ciklus amíg ((nem talált) ÉS (i < 5)) i:=i + 1 talált:=(tömb[i] mod 2 = 0) Ciklus vége Ha (talált) Ki(i) Különben Ki(‘Nincs ilyen!’) Elágazás vége i = 3 talált = igaz

173 Keresés 15 12 11 17 14 Tömb: i:=0 talált:=hamis
Ciklus amíg ((nem talált) ÉS (i < 5)) i:=i + 1 talált:=(tömb[i] mod 2 = 0) Ciklus vége Ha (talált) Ki(i) Különben Ki(‘Nincs ilyen!’) Elágazás vége i = 3 talált = igaz

174 Keresés 15 12 11 17 14 Tömb: i:=0 talált:=hamis
Ciklus amíg ((nem talált) ÉS (i < 5)) i:=i + 1 talált:=(tömb[i] mod 2 = 0) Ciklus vége Ha (talált) Ki(i) Különben Ki(‘Nincs ilyen!’) Elágazás vége i = 3 talált = igaz

175 Lineáris keresés tétele II.

176

177 Logaritmikus keresés tétele

178 Logaritmikus keresés tétele

179 Logaritmikus (felező) keresés tétele
Legyen adott az n elemű, rendezett A sorozat, valamint az x elem. Döntsük el, hogy a sorozatban megtalálható-e az x elem, és ha igen, adjuk meg egy ilyen elem sorszámát! A keresés eredményeként az l logikai változó igaz értéket tartalmaz, ha megtaláltuk az x elemet és hamis értéket, ha nem találtunk. Ha megtaláltuk az x elemet, akkor annak sorszámát az i változó tartalmazza.

180

181 Feladat Készítsünk algoritmust, amely kitalálja a felhasználó által gondolt számot (1-100), és kiírja azt is, hogy hány lépésben sikerült megtalálni azt.

182 Visszalépéses keresés tétele

183

184

185 Metszet tétele

186 Metszet tétele Egy n elemű halmaz elemeit az A, egy m elemű halmaz elemeit a B sorozat sorolja fel. Hozzuk létre a C sorozatot, mely a két halmaz metszetének elemeit sorolja fel!

187 Unió tétele

188 Unió tétele Egy n elemű halmaz elemeit az A, egy m elemű halmaz elemeit a B sorozat sorolja fel. Hozzuk létre a C sorozatot, mely a két halmaz uniójának elemeit sorolja fel!

189 Rendezés közvetlen kiválogatással

190 Rendezés közvetlen kiválasztással
15 12 11 17 14 Tömb: Segéd: Ciklus i:=1-től 4-ig Ciklus j:=i+1-től 5-ig Ha (tömb[j]<tömb[i]) akkor segéd:=tömb[j] tömb[j]:=tömb[i] tömb[i]:=segéd Elágazás vége Ciklus vége

191 Rendezés közvetlen kiválasztással
15 12 11 17 14 Tömb: Segéd: Ciklus i:=1-től 4-ig Ciklus j:=i+1-től 5-ig Ha (tömb[j]<tömb[i]) akkor segéd:=tömb[j] tömb[j]:=tömb[i] tömb[i]:=segéd Elágazás vége Ciklus vége i = 1

192 Rendezés közvetlen kiválasztással
15 12 11 17 14 Tömb: Segéd: Ciklus i:=1-től 4-ig Ciklus j:=i+1-től 5-ig Ha (tömb[j]<tömb[i]) akkor segéd:=tömb[j] tömb[j]:=tömb[i] tömb[i]:=segéd Elágazás vége Ciklus vége i = 1 j = 2

193 Rendezés közvetlen kiválasztással
15 12 11 17 14 Tömb: Segéd: Ciklus i:=1-től 4-ig Ciklus j:=i+1-től 5-ig Ha (tömb[j]<tömb[i]) akkor segéd:=tömb[j] tömb[j]:=tömb[i] tömb[i]:=segéd Elágazás vége Ciklus vége i = 1 j = 2

194 Rendezés közvetlen kiválasztással
15 12 11 17 14 Tömb: Segéd: Ciklus i:=1-től 4-ig Ciklus j:=i+1-től 5-ig Ha (tömb[j]<tömb[i]) akkor segéd:=tömb[j] tömb[j]:=tömb[i] tömb[i]:=segéd Elágazás vége Ciklus vége i = 1 j = 2

195 Rendezés közvetlen kiválasztással
15 12 11 17 14 Tömb: Segéd: Ciklus i:=1-től 4-ig Ciklus j:=i+1-től 5-ig Ha (tömb[j]<tömb[i]) akkor segéd:=tömb[j] tömb[j]:=tömb[i] tömb[i]:=segéd Elágazás vége Ciklus vége i = 1 j = 2

196 Rendezés közvetlen kiválasztással
15 12 11 17 14 Tömb: Segéd: Ciklus i:=1-től 4-ig Ciklus j:=i+1-től 5-ig Ha (tömb[j]<tömb[i]) akkor segéd:=tömb[j] tömb[j]:=tömb[i] tömb[i]:=segéd Elágazás vége Ciklus vége i = 1 j = 3

197 Rendezés közvetlen kiválasztással
15 12 11 17 14 Tömb: Segéd: Ciklus i:=1-től 4-ig Ciklus j:=i+1-től 5-ig Ha (tömb[j]<tömb[i]) akkor segéd:=tömb[j] tömb[j]:=tömb[i] tömb[i]:=segéd Elágazás vége Ciklus vége i = 1 j = 3

198 Rendezés közvetlen kiválasztással
15 12 11 17 14 Tömb: Segéd: Ciklus i:=1-től 4-ig Ciklus j:=i+1-től 5-ig Ha (tömb[j]<tömb[i]) akkor segéd:=tömb[j] tömb[j]:=tömb[i] tömb[i]:=segéd Elágazás vége Ciklus vége i = 1 j = 3

199 Rendezés közvetlen kiválasztással
15 12 11 17 14 Tömb: Segéd: Ciklus i:=1-től 4-ig Ciklus j:=i+1-től 5-ig Ha (tömb[j]<tömb[i]) akkor segéd:=tömb[j] tömb[j]:=tömb[i] tömb[i]:=segéd Elágazás vége Ciklus vége i = 1 j = 3

200 Rendezés közvetlen kiválasztással
15 12 11 17 14 Tömb: Segéd: Ciklus i:=1-től 4-ig Ciklus j:=i+1-től 5-ig Ha (tömb[j]<tömb[i]) akkor segéd:=tömb[j] tömb[j]:=tömb[i] tömb[i]:=segéd Elágazás vége Ciklus vége i = 1 j = 4

201 Rendezés közvetlen kiválasztással
15 12 11 17 14 Tömb: Segéd: Ciklus i:=1-től 4-ig Ciklus j:=i+1-től 5-ig Ha (tömb[j]<tömb[i]) akkor segéd:=tömb[j] tömb[j]:=tömb[i] tömb[i]:=segéd Elágazás vége Ciklus vége i = 1 j = 4

202 Rendezés közvetlen kiválasztással
15 12 11 17 14 Tömb: Segéd: Ciklus i:=1-től 4-ig Ciklus j:=i+1-től 5-ig Ha (tömb[j]<tömb[i]) akkor segéd:=tömb[j] tömb[j]:=tömb[i] tömb[i]:=segéd Elágazás vége Ciklus vége i = 1 j = 4

203 Rendezés közvetlen kiválasztással
15 12 11 17 14 Tömb: Segéd: Ciklus i:=1-től 4-ig Ciklus j:=i+1-től 5-ig Ha (tömb[j]<tömb[i]) akkor segéd:=tömb[j] tömb[j]:=tömb[i] tömb[i]:=segéd Elágazás vége Ciklus vége i = 1 j = 4

204 Rendezés közvetlen kiválasztással
15 12 11 17 14 Tömb: Segéd: Ciklus i:=1-től 4-ig Ciklus j:=i+1-től 5-ig Ha (tömb[j]<tömb[i]) akkor segéd:=tömb[j] tömb[j]:=tömb[i] tömb[i]:=segéd Elágazás vége Ciklus vége i = 1 j = 5

205 Rendezés közvetlen kiválasztással
15 12 11 17 14 Tömb: Segéd: Ciklus i:=1-től 4-ig Ciklus j:=i+1-től 5-ig Ha (tömb[j]<tömb[i]) akkor segéd:=tömb[j] tömb[j]:=tömb[i] tömb[i]:=segéd Elágazás vége Ciklus vége i = 1 j = 5

206 Rendezés közvetlen kiválasztással
15 12 11 17 14 Tömb: Segéd: Ciklus i:=1-től 4-ig Ciklus j:=i+1-től 5-ig Ha (tömb[j]<tömb[i]) akkor segéd:=tömb[j] tömb[j]:=tömb[i] tömb[i]:=segéd Elágazás vége Ciklus vége i = 1 j = 5

207 Rendezés közvetlen kiválasztással
15 12 11 17 14 Tömb: Segéd: Ciklus i:=1-től 4-ig Ciklus j:=i+1-től 5-ig Ha (tömb[j]<tömb[i]) akkor segéd:=tömb[j] tömb[j]:=tömb[i] tömb[i]:=segéd Elágazás vége Ciklus vége i = 1 j = 5

208 Rendezés közvetlen kiválasztással
15 12 11 17 14 Tömb: Segéd: Ciklus i:=1-től 4-ig Ciklus j:=i+1-től 5-ig Ha (tömb[j]<tömb[i]) akkor segéd:=tömb[j] tömb[j]:=tömb[i] tömb[i]:=segéd Elágazás vége Ciklus vége i = 1 j = 5

209 Rendezés közvetlen kiválasztással
15 12 11 17 14 Tömb: Segéd: Ciklus i:=1-től 4-ig Ciklus j:=i+1-től 5-ig Ha (tömb[j]<tömb[i]) akkor segéd:=tömb[j] tömb[j]:=tömb[i] tömb[i]:=segéd Elágazás vége Ciklus vége i = 2 j = 5

210 Rendezés közvetlen kiválasztással
15 12 11 17 14 Tömb: Segéd: Ciklus i:=1-től 4-ig Ciklus j:=i+1-től 5-ig Ha (tömb[j]<tömb[i]) akkor segéd:=tömb[j] tömb[j]:=tömb[i] tömb[i]:=segéd Elágazás vége Ciklus vége i = 2 j = 3

211 Rendezés közvetlen kiválasztással
15 12 11 17 14 Tömb: Segéd: Ciklus i:=1-től 4-ig Ciklus j:=i+1-től 5-ig Ha (tömb[j]<tömb[i]) akkor segéd:=tömb[j] tömb[j]:=tömb[i] tömb[i]:=segéd Elágazás vége Ciklus vége i = 2 j = 3

212 Rendezés közvetlen kiválasztással
Tömb: 11 15 12 17 14 Segéd: 12 Ciklus i:=1-től 4-ig Ciklus j:=i+1-től 5-ig Ha (tömb[j]<tömb[i]) akkor segéd:=tömb[j] tömb[j]:=tömb[i] tömb[i]:=segéd Elágazás vége Ciklus vége i = 2 j = 3

213 Rendezés közvetlen kiválasztással
Tömb: 11 15 15 17 14 Segéd: 12 Ciklus i:=1-től 4-ig Ciklus j:=i+1-től 5-ig Ha (tömb[j]<tömb[i]) akkor segéd:=tömb[j] tömb[j]:=tömb[i] tömb[i]:=segéd Elágazás vége Ciklus vége i = 2 j = 3

214 Rendezés közvetlen kiválasztással
Tömb: 11 12 15 17 14 Segéd: 12 Ciklus i:=1-től 4-ig Ciklus j:=i+1-től 5-ig Ha (tömb[j]<tömb[i]) akkor segéd:=tömb[j] tömb[j]:=tömb[i] tömb[i]:=segéd Elágazás vége Ciklus vége i = 2 j = 3

215 Rendezés közvetlen kiválasztással
Tömb: 11 12 15 17 14 Segéd: 12 Ciklus i:=1-től 4-ig Ciklus j:=i+1-től 5-ig Ha (tömb[j]<tömb[i]) akkor segéd:=tömb[j] tömb[j]:=tömb[i] tömb[i]:=segéd Elágazás vége Ciklus vége i = 2 j = 3

216 Rendezés közvetlen kiválasztással
Tömb: 11 12 15 17 14 Segéd: 12 Ciklus i:=1-től 4-ig Ciklus j:=i+1-től 5-ig Ha (tömb[j]<tömb[i]) akkor segéd:=tömb[j] tömb[j]:=tömb[i] tömb[i]:=segéd Elágazás vége Ciklus vége i = 2 j = 3

217 Rendezés közvetlen kiválasztással
Tömb: 11 12 15 17 14 Segéd: 12 Ciklus i:=1-től 4-ig Ciklus j:=i+1-től 5-ig Ha (tömb[j]<tömb[i]) akkor segéd:=tömb[j] tömb[j]:=tömb[i] tömb[i]:=segéd Elágazás vége Ciklus vége i = 2 j = 4

218 Rendezés közvetlen kiválasztással
Tömb: 11 12 15 17 14 Segéd: 12 Ciklus i:=1-től 4-ig Ciklus j:=i+1-től 5-ig Ha (tömb[j]<tömb[i]) akkor segéd:=tömb[j] tömb[j]:=tömb[i] tömb[i]:=segéd Elágazás vége Ciklus vége i = 2 j = 4

219 Rendezés közvetlen kiválasztással
Tömb: 11 12 15 17 14 Segéd: 12 Ciklus i:=1-től 4-ig Ciklus j:=i+1-től 5-ig Ha (tömb[j]<tömb[i]) akkor segéd:=tömb[j] tömb[j]:=tömb[i] tömb[i]:=segéd Elágazás vége Ciklus vége i = 2 j = 4

220 Rendezés közvetlen kiválasztással
Tömb: 11 12 15 17 14 Segéd: 12 Ciklus i:=1-től 4-ig Ciklus j:=i+1-től 5-ig Ha (tömb[j]<tömb[i]) akkor segéd:=tömb[j] tömb[j]:=tömb[i] tömb[i]:=segéd Elágazás vége Ciklus vége i = 2 j = 4

221 Rendezés közvetlen kiválasztással
Tömb: 11 12 15 17 14 Segéd: 12 Ciklus i:=1-től 4-ig Ciklus j:=i+1-től 5-ig Ha (tömb[j]<tömb[i]) akkor segéd:=tömb[j] tömb[j]:=tömb[i] tömb[i]:=segéd Elágazás vége Ciklus vége i = 2 j = 5

222 Rendezés közvetlen kiválasztással
Tömb: 11 12 15 17 14 Segéd: 12 Ciklus i:=1-től 4-ig Ciklus j:=i+1-től 5-ig Ha (tömb[j]<tömb[i]) akkor segéd:=tömb[j] tömb[j]:=tömb[i] tömb[i]:=segéd Elágazás vége Ciklus vége i = 2 j = 5

223 Rendezés közvetlen kiválasztással
Tömb: 11 12 15 17 14 Segéd: 12 Ciklus i:=1-től 4-ig Ciklus j:=i+1-től 5-ig Ha (tömb[j]<tömb[i]) akkor segéd:=tömb[j] tömb[j]:=tömb[i] tömb[i]:=segéd Elágazás vége Ciklus vége i = 2 j = 5

224 Rendezés közvetlen kiválasztással
Tömb: 11 12 15 17 14 Segéd: 12 Ciklus i:=1-től 4-ig Ciklus j:=i+1-től 5-ig Ha (tömb[j]<tömb[i]) akkor segéd:=tömb[j] tömb[j]:=tömb[i] tömb[i]:=segéd Elágazás vége Ciklus vége i = 2 j = 5

225 Rendezés közvetlen kiválasztással
Tömb: 11 12 15 17 14 Segéd: 12 Ciklus i:=1-től 4-ig Ciklus j:=i+1-től 5-ig Ha (tömb[j]<tömb[i]) akkor segéd:=tömb[j] tömb[j]:=tömb[i] tömb[i]:=segéd Elágazás vége Ciklus vége i = 2 j = 5

226 Rendezés közvetlen kiválasztással
Tömb: 11 12 15 17 14 Segéd: 12 Ciklus i:=1-től 4-ig Ciklus j:=i+1-től 5-ig Ha (tömb[j]<tömb[i]) akkor segéd:=tömb[j] tömb[j]:=tömb[i] tömb[i]:=segéd Elágazás vége Ciklus vége i = 3 j = 5

227 Rendezés közvetlen kiválasztással
Tömb: 11 12 15 17 14 Segéd: 12 Ciklus i:=1-től 4-ig Ciklus j:=i+1-től 5-ig Ha (tömb[j]<tömb[i]) akkor segéd:=tömb[j] tömb[j]:=tömb[i] tömb[i]:=segéd Elágazás vége Ciklus vége i = 3 j = 4

228 Rendezés közvetlen kiválasztással
Tömb: 11 12 15 17 14 Segéd: 12 Ciklus i:=1-től 4-ig Ciklus j:=i+1-től 5-ig Ha (tömb[j]<tömb[i]) akkor segéd:=tömb[j] tömb[j]:=tömb[i] tömb[i]:=segéd Elágazás vége Ciklus vége i = 3 j = 4

229 Rendezés közvetlen kiválasztással
Tömb: 11 12 15 17 14 Segéd: 12 Ciklus i:=1-től 4-ig Ciklus j:=i+1-től 5-ig Ha (tömb[j]<tömb[i]) akkor segéd:=tömb[j] tömb[j]:=tömb[i] tömb[i]:=segéd Elágazás vége Ciklus vége i = 3 j = 4

230 Rendezés közvetlen kiválasztással
Tömb: 11 12 15 17 14 Segéd: 12 Ciklus i:=1-től 4-ig Ciklus j:=i+1-től 5-ig Ha (tömb[j]<tömb[i]) akkor segéd:=tömb[j] tömb[j]:=tömb[i] tömb[i]:=segéd Elágazás vége Ciklus vége i = 3 j = 4

231 Rendezés közvetlen kiválasztással
Tömb: 11 12 15 17 14 Segéd: 12 Ciklus i:=1-től 4-ig Ciklus j:=i+1-től 5-ig Ha (tömb[j]<tömb[i]) akkor segéd:=tömb[j] tömb[j]:=tömb[i] tömb[i]:=segéd Elágazás vége Ciklus vége i = 3 j = 5

232 Rendezés közvetlen kiválasztással
Tömb: 11 12 15 17 14 Segéd: 12 Ciklus i:=1-től 4-ig Ciklus j:=i+1-től 5-ig Ha (tömb[j]<tömb[i]) akkor segéd:=tömb[j] tömb[j]:=tömb[i] tömb[i]:=segéd Elágazás vége Ciklus vége i = 3 j = 5

233 Rendezés közvetlen kiválasztással
Tömb: 11 12 15 17 14 Segéd: 14 Ciklus i:=1-től 4-ig Ciklus j:=i+1-től 5-ig Ha (tömb[j]<tömb[i]) akkor segéd:=tömb[j] tömb[j]:=tömb[i] tömb[i]:=segéd Elágazás vége Ciklus vége i = 3 j = 5

234 Rendezés közvetlen kiválasztással
Tömb: 11 12 15 17 15 Segéd: 14 Ciklus i:=1-től 4-ig Ciklus j:=i+1-től 5-ig Ha (tömb[j]<tömb[i]) akkor segéd:=tömb[j] tömb[j]:=tömb[i] tömb[i]:=segéd Elágazás vége Ciklus vége i = 3 j = 5

235 Rendezés közvetlen kiválasztással
Tömb: 11 11 15 12 12 14 17 17 14 15 Segéd: 14 Ciklus i:=1-től 4-ig Ciklus j:=i+1-től 5-ig Ha (tömb[j]<tömb[i]) akkor segéd:=tömb[j] tömb[j]:=tömb[i] tömb[i]:=segéd Elágazás vége Ciklus vége i = 3 j = 5

236 Rendezés közvetlen kiválasztással
Tömb: 11 11 15 12 14 12 17 17 14 15 Segéd: 14 Ciklus i:=1-től 4-ig Ciklus j:=i+1-től 5-ig Ha (tömb[j]<tömb[i]) akkor segéd:=tömb[j] tömb[j]:=tömb[i] tömb[i]:=segéd Elágazás vége Ciklus vége i = 3 j = 5

237 Rendezés közvetlen kiválasztással
Tömb: 11 11 15 12 14 12 17 17 14 15 Segéd: 14 Ciklus i:=1-től 4-ig Ciklus j:=i+1-től 5-ig Ha (tömb[j]<tömb[i]) akkor segéd:=tömb[j] tömb[j]:=tömb[i] tömb[i]:=segéd Elágazás vége Ciklus vége i = 3 j = 5

238 Rendezés közvetlen kiválasztással
Tömb: 11 11 15 12 14 12 17 17 14 15 Segéd: 14 Ciklus i:=1-től 4-ig Ciklus j:=i+1-től 5-ig Ha (tömb[j]<tömb[i]) akkor segéd:=tömb[j] tömb[j]:=tömb[i] tömb[i]:=segéd Elágazás vége Ciklus vége i = 3 j = 5

239 Rendezés közvetlen kiválasztással
Tömb: 11 11 15 12 14 12 17 17 14 15 Segéd: 14 Ciklus i:=1-től 4-ig Ciklus j:=i+1-től 5-ig Ha (tömb[j]<tömb[i]) akkor segéd:=tömb[j] tömb[j]:=tömb[i] tömb[i]:=segéd Elágazás vége Ciklus vége i = 4 j = 5

240 Rendezés közvetlen kiválasztással
Tömb: 11 11 15 12 14 12 17 17 14 15 Segéd: 14 Ciklus i:=1-től 4-ig Ciklus j:=i+1-től 5-ig Ha (tömb[j]<tömb[i]) akkor segéd:=tömb[j] tömb[j]:=tömb[i] tömb[i]:=segéd Elágazás vége Ciklus vége i = 4 j = 5

241 Rendezés közvetlen kiválasztással
Tömb: 11 11 15 12 14 12 17 17 14 15 Segéd: 14 Ciklus i:=1-től 4-ig Ciklus j:=i+1-től 5-ig Ha (tömb[j]<tömb[i]) akkor segéd:=tömb[j] tömb[j]:=tömb[i] tömb[i]:=segéd Elágazás vége Ciklus vége i = 4 j = 5

242 Rendezés közvetlen kiválasztással
Tömb: 11 11 12 15 14 12 17 17 14 15 Segéd: 15 Ciklus i:=1-től 4-ig Ciklus j:=i+1-től 5-ig Ha (tömb[j]<tömb[i]) akkor segéd:=tömb[j] tömb[j]:=tömb[i] tömb[i]:=segéd Elágazás vége Ciklus vége i = 4 j = 5

243 Rendezés közvetlen kiválasztással
Tömb: 11 11 12 15 14 12 17 17 17 14 Segéd: 15 Ciklus i:=1-től 4-ig Ciklus j:=i+1-től 5-ig Ha (tömb[j]<tömb[i]) akkor segéd:=tömb[j] tömb[j]:=tömb[i] tömb[i]:=segéd Elágazás vége Ciklus vége i = 4 j = 5

244 Rendezés közvetlen kiválasztással
Tömb: 11 11 12 15 14 12 15 17 17 14 Segéd: 15 Ciklus i:=1-től 4-ig Ciklus j:=i+1-től 5-ig Ha (tömb[j]<tömb[i]) akkor segéd:=tömb[j] tömb[j]:=tömb[i] tömb[i]:=segéd Elágazás vége Ciklus vége i = 4 j = 5

245 Rendezés közvetlen kiválasztással
Tömb: 11 11 12 15 14 12 15 17 17 14 Segéd: 15 Ciklus i:=1-től 4-ig Ciklus j:=i+1-től 5-ig Ha (tömb[j]<tömb[i]) akkor segéd:=tömb[j] tömb[j]:=tömb[i] tömb[i]:=segéd Elágazás vége Ciklus vége i = 4 j = 5

246 Rendezés közvetlen kiválasztással
Tömb: 11 11 12 15 14 12 15 17 17 14 Segéd: 15 Ciklus i:=1-től 4-ig Ciklus j:=i+1-től 5-ig Ha (tömb[j]<tömb[i]) akkor segéd:=tömb[j] tömb[j]:=tömb[i] tömb[i]:=segéd Elágazás vége Ciklus vége i = 4 j = 5

247 Rendezés közvetlen kiválasztással
Tömb: 11 11 12 15 14 12 15 17 17 14 Segéd: 15 Ciklus i:=1-től 4-ig Ciklus j:=i+1-től 5-ig Ha (tömb[j]<tömb[i]) akkor segéd:=tömb[j] tömb[j]:=tömb[i] tömb[i]:=segéd Elágazás vége Ciklus vége i = 4 j = 5

248 Rendezés minimum -maximum kiválasztással

249 Rendezés maximum-minumum kiválasztással tétele
Legyen adott az n elemű A sorozat és egy a sorozat elemein értelmezett rendezési reláció. A feladat az, hogy rendezzük növekvő sorrendbe a sorozat elemeit. Az algoritmus minden iterációban megkeresi a még rendezetlen részsorozat legnagyobb elemét és kicseréli a részsorozat jobb szélső elemével.

250 Rendezés minimumkiválasztással
Tömb: 11 15 12 17 14 Min: Ciklus i:=1-től 4-ig index:=i min:=tömb[i] Ciklus j:=i+1-től 5-ig Ha (min>tömb[j]) akkor min:=tömb[j] index:=j Elágazás vége Ciklus vége tömb[index]:=tömb[i] tömb[i]:=max

251 Rendezés minimumkiválasztással
Tömb: 11 15 12 17 14 Min: Ciklus i:=1-től 4-ig index:=i min:=tömb[i] Ciklus j:=i+1-től 5-ig Ha (min>tömb[j]) akkor min:=tömb[j] index:=j Elágazás vége Ciklus vége tömb[index]:=tömb[i] tömb[i]:=max i = 1

252 Rendezés minimumkiválasztással
Tömb: 11 15 12 17 14 Min: Ciklus i:=1-től 4-ig index:=i min:=tömb[i] Ciklus j:=i+1-től 5-ig Ha (min>tömb[j]) akkor min:=tömb[j] index:=j Elágazás vége Ciklus vége tömb[index]:=tömb[i] tömb[i]:=max i = 1 index = 1

253 Rendezés minimumkiválasztással
Tömb: 11 15 12 17 14 Min: 11 Ciklus i:=1-től 4-ig index:=i min:=tömb[i] Ciklus j:=i+1-től 5-ig Ha (min>tömb[j]) akkor min:=tömb[j] index:=j Elágazás vége Ciklus vége tömb[index]:=tömb[i] tömb[i]:=max i = 1 index = 1

254 Rendezés minimumkiválasztással
Tömb: 11 15 12 17 14 Min: 11 Ciklus i:=1-től 4-ig index:=i min:=tömb[i] Ciklus j:=i+1-től 5-ig Ha (min>tömb[j]) akkor min:=tömb[j] index:=j Elágazás vége Ciklus vége tömb[index]:=tömb[i] tömb[i]:=max i = 1 index = 1 j = 2

255 Rendezés minimumkiválasztással
Tömb: 11 15 12 17 14 Min: 11 Ciklus i:=1-től 4-ig index:=i min:=tömb[i] Ciklus j:=i+1-től 5-ig Ha (min>tömb[j]) akkor min:=tömb[j] index:=j Elágazás vége Ciklus vége tömb[index]:=tömb[i] tömb[i]:=max i = 1 index = 1 j = 2

256 Rendezés minimumkiválasztással
Tömb: 11 15 12 17 14 Min: 11 Ciklus i:=1-től 4-ig index:=i min:=tömb[i] Ciklus j:=i+1-től 5-ig Ha (min>tömb[j]) akkor min:=tömb[j] index:=j Elágazás vége Ciklus vége tömb[index]:=tömb[i] tömb[i]:=max i = 1 index = 1 j = 2

257 Rendezés minimumkiválasztással
Tömb: 11 15 12 17 14 Min: 11 Ciklus i:=1-től 4-ig index:=i min:=tömb[i] Ciklus j:=i+1-től 5-ig Ha (min>tömb[j]) akkor min:=tömb[j] index:=j Elágazás vége Ciklus vége tömb[index]:=tömb[i] tömb[i]:=max i = 1 index = 1 j = 2

258 Rendezés minimumkiválasztással
Tömb: 11 15 12 17 14 Min: 11 Ciklus i:=1-től 4-ig index:=i min:=tömb[i] Ciklus j:=i+1-től 5-ig Ha (min>tömb[j]) akkor min:=tömb[j] index:=j Elágazás vége Ciklus vége tömb[index]:=tömb[i] tömb[i]:=max i = 1 index = 1 j = 3

259 Rendezés minimumkiválasztással
Tömb: 11 15 12 17 14 Min: 11 Ciklus i:=1-től 4-ig index:=i min:=tömb[i] Ciklus j:=i+1-től 5-ig Ha (min>tömb[j]) akkor min:=tömb[j] index:=j Elágazás vége Ciklus vége tömb[index]:=tömb[i] tömb[i]:=max i = 1 index = 1 j = 3

260 Rendezés minimumkiválasztással
Tömb: 11 15 12 17 14 Min: 11 Ciklus i:=1-től 4-ig index:=i min:=tömb[i] Ciklus j:=i+1-től 5-ig Ha (min>tömb[j]) akkor min:=tömb[j] index:=j Elágazás vége Ciklus vége tömb[index]:=tömb[i] tömb[i]:=max i = 1 index = 1 j = 3

261 Rendezés minimumkiválasztással
Tömb: 11 15 12 17 14 Min: 11 Ciklus i:=1-től 4-ig index:=i min:=tömb[i] Ciklus j:=i+1-től 5-ig Ha (min>tömb[j]) akkor min:=tömb[j] index:=j Elágazás vége Ciklus vége tömb[index]:=tömb[i] tömb[i]:=max i = 1 index = 1 j = 3

262 Rendezés minimumkiválasztással
Tömb: 11 15 12 17 14 Min: 11 Ciklus i:=1-től 4-ig index:=i min:=tömb[i] Ciklus j:=i+1-től 5-ig Ha (min>tömb[j]) akkor min:=tömb[j] index:=j Elágazás vége Ciklus vége tömb[index]:=tömb[i] tömb[i]:=max i = 1 index = 1 j = 4

263 Rendezés minimumkiválasztással
Tömb: 11 15 12 17 14 Min: 11 Ciklus i:=1-től 4-ig index:=i min:=tömb[i] Ciklus j:=i+1-től 5-ig Ha (min>tömb[j]) akkor min:=tömb[j] index:=j Elágazás vége Ciklus vége tömb[index]:=tömb[i] tömb[i]:=max i = 1 index = 1 j = 4

264 Rendezés minimumkiválasztással
Tömb: 11 15 12 17 14 Min: 11 Ciklus i:=1-től 4-ig index:=i min:=tömb[i] Ciklus j:=i+1-től 5-ig Ha (min>tömb[j]) akkor min:=tömb[j] index:=j Elágazás vége Ciklus vége tömb[index]:=tömb[i] tömb[i]:=max i = 1 index = 1 j = 4

265 Rendezés minimumkiválasztással
Tömb: 11 15 12 17 14 Min: 11 Ciklus i:=1-től 4-ig index:=i min:=tömb[i] Ciklus j:=i+1-től 5-ig Ha (min>tömb[j]) akkor min:=tömb[j] index:=j Elágazás vége Ciklus vége tömb[index]:=tömb[i] tömb[i]:=max i = 1 index = 1 j = 4

266 Rendezés minimumkiválasztással
Tömb: 11 15 12 17 14 Min: 11 Ciklus i:=1-től 4-ig index:=i min:=tömb[i] Ciklus j:=i+1-től 5-ig Ha (min>tömb[j]) akkor min:=tömb[j] index:=j Elágazás vége Ciklus vége tömb[index]:=tömb[i] tömb[i]:=max i = 1 index = 1 j = 5

267 Rendezés minimumkiválasztással
Tömb: 11 15 12 17 14 Min: 11 Ciklus i:=1-től 4-ig index:=i min:=tömb[i] Ciklus j:=i+1-től 5-ig Ha (min>tömb[j]) akkor min:=tömb[j] index:=j Elágazás vége Ciklus vége tömb[index]:=tömb[i] tömb[i]:=max i = 1 index = 1 j = 5

268 Rendezés minimumkiválasztással
Tömb: 11 15 12 17 14 Min: 11 Ciklus i:=1-től 4-ig index:=i min:=tömb[i] Ciklus j:=i+1-től 5-ig Ha (min>tömb[j]) akkor min:=tömb[j] index:=j Elágazás vége Ciklus vége tömb[index]:=tömb[i] tömb[i]:=max i = 1 index = 1 j = 5

269 Rendezés minimumkiválasztással
Tömb: 11 15 12 17 14 Min: 11 Ciklus i:=1-től 4-ig index:=i min:=tömb[i] Ciklus j:=i+1-től 5-ig Ha (min>tömb[j]) akkor min:=tömb[j] index:=j Elágazás vége Ciklus vége tömb[index]:=tömb[i] tömb[i]:=max i = 1 index = 1 j = 5

270 Rendezés minimumkiválasztással
Tömb: 11 15 12 17 14 Min: 11 Ciklus i:=1-től 4-ig index:=i min:=tömb[i] Ciklus j:=i+1-től 5-ig Ha (min>tömb[j]) akkor min:=tömb[j] index:=j Elágazás vége Ciklus vége tömb[index]:=tömb[i] tömb[i]:=max i = 1 index = 1 j = 5

271 Rendezés minimumkiválasztással
Tömb: 11 15 12 17 14 Min: 11 Ciklus i:=1-től 4-ig index:=i min:=tömb[i] Ciklus j:=i+1-től 5-ig Ha (min>tömb[j]) akkor min:=tömb[j] index:=j Elágazás vége Ciklus vége tömb[index]:=tömb[i] tömb[i]:=max i = 1 index = 1 j = 5

272 Rendezés minimumkiválasztással
Tömb: 11 15 12 17 14 Min: 11 Ciklus i:=1-től 4-ig index:=i min:=tömb[i] Ciklus j:=i+1-től 5-ig Ha (min>tömb[j]) akkor min:=tömb[j] index:=j Elágazás vége Ciklus vége tömb[index]:=tömb[i] tömb[i]:=max i = 1 index = 1 j = 5

273 Rendezés minimumkiválasztással
Tömb: 11 15 12 17 14 Min: 11 Ciklus i:=1-től 4-ig index:=i min:=tömb[i] Ciklus j:=i+1-től 5-ig Ha (min>tömb[j]) akkor min:=tömb[j] index:=j Elágazás vége Ciklus vége tömb[index]:=tömb[i] tömb[i]:=max i = 2 index = 1 j = 5

274 Rendezés minimumkiválasztással
Tömb: 11 15 12 17 14 Min: 11 Ciklus i:=1-től 4-ig index:=i min:=tömb[i] Ciklus j:=i+1-től 5-ig Ha (min>tömb[j]) akkor min:=tömb[j] index:=j Elágazás vége Ciklus vége tömb[index]:=tömb[i] tömb[i]:=max i = 2 index = 2 j = 5

275 Rendezés minimumkiválasztással
Tömb: 11 15 12 17 14 Min: 15 Ciklus i:=1-től 4-ig index:=i min:=tömb[i] Ciklus j:=i+1-től 5-ig Ha (min>tömb[j]) akkor min:=tömb[j] index:=j Elágazás vége Ciklus vége tömb[index]:=tömb[i] tömb[i]:=max i = 2 index = 2 j = 5

276 Rendezés minimumkiválasztással
Tömb: 11 15 12 17 14 Min: 15 Ciklus i:=1-től 4-ig index:=i min:=tömb[i] Ciklus j:=i+1-től 5-ig Ha (min>tömb[j]) akkor min:=tömb[j] index:=j Elágazás vége Ciklus vége tömb[index]:=tömb[i] tömb[i]:=max i = 2 index = 2 j = 3

277 Rendezés minimumkiválasztással
Tömb: 11 15 12 17 14 Min: 15 Ciklus i:=1-től 4-ig index:=i min:=tömb[i] Ciklus j:=i+1-től 5-ig Ha (min>tömb[j]) akkor min:=tömb[j] index:=j Elágazás vége Ciklus vége tömb[index]:=tömb[i] tömb[i]:=max i = 2 index = 2 j = 3

278 Rendezés minimumkiválasztással
Tömb: 11 15 12 17 14 Min: 12 Ciklus i:=1-től 4-ig index:=i min:=tömb[i] Ciklus j:=i+1-től 5-ig Ha (min>tömb[j]) akkor min:=tömb[j] index:=j Elágazás vége Ciklus vége tömb[index]:=tömb[i] tömb[i]:=max i = 2 index = 2 j = 3

279 Rendezés minimumkiválasztással
Tömb: 11 15 12 17 14 Min: 12 Ciklus i:=1-től 4-ig index:=i min:=tömb[i] Ciklus j:=i+1-től 5-ig Ha (min>tömb[j]) akkor min:=tömb[j] index:=j Elágazás vége Ciklus vége tömb[index]:=tömb[i] tömb[i]:=max i = 2 index = 3 j = 3

280 Rendezés minimumkiválasztással
Tömb: 11 15 12 17 14 Min: 12 Ciklus i:=1-től 4-ig index:=i min:=tömb[i] Ciklus j:=i+1-től 5-ig Ha (min>tömb[j]) akkor min:=tömb[j] index:=j Elágazás vége Ciklus vége tömb[index]:=tömb[i] tömb[i]:=max i = 2 index = 3 j = 3

281 Rendezés minimumkiválasztással
Tömb: 11 15 12 17 14 Min: 12 Ciklus i:=1-től 4-ig index:=i min:=tömb[i] Ciklus j:=i+1-től 5-ig Ha (min>tömb[j]) akkor min:=tömb[j] index:=j Elágazás vége Ciklus vége tömb[index]:=tömb[i] tömb[i]:=max i = 2 index = 3 j = 3

282 Rendezés minimumkiválasztással
Tömb: 11 15 12 17 14 Min: 12 Ciklus i:=1-től 4-ig index:=i min:=tömb[i] Ciklus j:=i+1-től 5-ig Ha (min>tömb[j]) akkor min:=tömb[j] index:=j Elágazás vége Ciklus vége tömb[index]:=tömb[i] tömb[i]:=max i = 2 index = 3 j = 4

283 Rendezés minimumkiválasztással
Tömb: 11 15 12 17 14 Min: 12 Ciklus i:=1-től 4-ig index:=i min:=tömb[i] Ciklus j:=i+1-től 5-ig Ha (min>tömb[j]) akkor min:=tömb[j] index:=j Elágazás vége Ciklus vége tömb[index]:=tömb[i] tömb[i]:=max i = 2 index = 3 j = 4

284 Rendezés minimumkiválasztással
Tömb: 11 15 12 17 14 Min: 12 Ciklus i:=1-től 4-ig index:=i min:=tömb[i] Ciklus j:=i+1-től 5-ig Ha (min>tömb[j]) akkor min:=tömb[j] index:=j Elágazás vége Ciklus vége tömb[index]:=tömb[i] tömb[i]:=max i = 2 index = 3 j = 4

285 Rendezés minimumkiválasztással
Tömb: 11 15 12 17 14 Min: 12 Ciklus i:=1-től 4-ig index:=i min:=tömb[i] Ciklus j:=i+1-től 5-ig Ha (min>tömb[j]) akkor min:=tömb[j] index:=j Elágazás vége Ciklus vége tömb[index]:=tömb[i] tömb[i]:=max i = 2 index = 3 j = 4

286 Rendezés minimumkiválasztással
Tömb: 11 15 12 17 14 Min: 12 Ciklus i:=1-től 4-ig index:=i min:=tömb[i] Ciklus j:=i+1-től 5-ig Ha (min>tömb[j]) akkor min:=tömb[j] index:=j Elágazás vége Ciklus vége tömb[index]:=tömb[i] tömb[i]:=max i = 2 index = 3 j = 5

287 Rendezés minimumkiválasztással
Tömb: 11 15 12 17 14 Min: 12 Ciklus i:=1-től 4-ig index:=i min:=tömb[i] Ciklus j:=i+1-től 5-ig Ha (min>tömb[j]) akkor min:=tömb[j] index:=j Elágazás vége Ciklus vége tömb[index]:=tömb[i] tömb[i]:=max i = 2 index = 3 j = 5

288 Rendezés minimumkiválasztással
Tömb: 11 15 12 17 14 Min: 12 Ciklus i:=1-től 4-ig index:=i min:=tömb[i] Ciklus j:=i+1-től 5-ig Ha (min>tömb[j]) akkor min:=tömb[j] index:=j Elágazás vége Ciklus vége tömb[index]:=tömb[i] tömb[i]:=max i = 2 index = 3 j = 5

289 Rendezés minimumkiválasztással
Tömb: 11 15 12 17 14 Min: 12 Ciklus i:=1-től 4-ig index:=i min:=tömb[i] Ciklus j:=i+1-től 5-ig Ha (min>tömb[j]) akkor min:=tömb[j] index:=j Elágazás vége Ciklus vége tömb[index]:=tömb[i] tömb[i]:=max i = 2 index = 3 j = 5

290 Rendezés minimumkiválasztással
Tömb: 11 15 15 17 14 Min: 12 Ciklus i:=1-től 4-ig index:=i min:=tömb[i] Ciklus j:=i+1-től 5-ig Ha (min>tömb[j]) akkor min:=tömb[j] index:=j Elágazás vége Ciklus vége tömb[index]:=tömb[i] tömb[i]:=max i = 2 index = 3 j = 5

291 Rendezés minimumkiválasztással
Tömb: 11 12 15 17 14 Min: 12 Ciklus i:=1-től 4-ig index:=i min:=tömb[i] Ciklus j:=i+1-től 5-ig Ha (min>tömb[j]) akkor min:=tömb[j] index:=j Elágazás vége Ciklus vége tömb[index]:=tömb[i] tömb[i]:=max i = 2 index = 3 j = 5

292 Rendezés minimumkiválasztással
Tömb: 11 12 15 17 14 Min: 12 Ciklus i:=1-től 4-ig index:=i min:=tömb[i] Ciklus j:=i+1-től 5-ig Ha (min>tömb[j]) akkor min:=tömb[j] index:=j Elágazás vége Ciklus vége tömb[index]:=tömb[i] tömb[i]:=max i = 2 index = 3 j = 5

293 Rendezés minimumkiválasztással
Tömb: 11 12 15 17 14 Min: 12 Ciklus i:=1-től 4-ig index:=i min:=tömb[i] Ciklus j:=i+1-től 5-ig Ha (min>tömb[j]) akkor min:=tömb[j] index:=j Elágazás vége Ciklus vége tömb[index]:=tömb[i] tömb[i]:=max i = 3 index = 3 j = 5

294 Rendezés minimumkiválasztással
Tömb: 11 12 15 17 14 Min: 12 Ciklus i:=1-től 4-ig index:=i min:=tömb[i] Ciklus j:=i+1-től 5-ig Ha (min>tömb[j]) akkor min:=tömb[j] index:=j Elágazás vége Ciklus vége tömb[index]:=tömb[i] tömb[i]:=max i = 3 index = 3 j = 5

295 Rendezés minimumkiválasztással
Tömb: 11 12 15 17 14 Min: 15 Ciklus i:=1-től 4-ig index:=i min:=tömb[i] Ciklus j:=i+1-től 5-ig Ha (min>tömb[j]) akkor min:=tömb[j] index:=j Elágazás vége Ciklus vége tömb[index]:=tömb[i] tömb[i]:=max i = 3 index = 3 j = 5

296 Rendezés minimumkiválasztással
Tömb: 11 12 15 17 14 Min: 15 Ciklus i:=1-től 4-ig index:=i min:=tömb[i] Ciklus j:=i+1-től 5-ig Ha (min>tömb[j]) akkor min:=tömb[j] index:=j Elágazás vége Ciklus vége tömb[index]:=tömb[i] tömb[i]:=max i = 3 index = 3 j = 4

297 Rendezés minimumkiválasztással
Tömb: 11 12 15 17 14 Min: 15 Ciklus i:=1-től 4-ig index:=i min:=tömb[i] Ciklus j:=i+1-től 5-ig Ha (min>tömb[j]) akkor min:=tömb[j] index:=j Elágazás vége Ciklus vége tömb[index]:=tömb[i] tömb[i]:=max i = 3 index = 3 j = 4

298 Rendezés minimumkiválasztással
Tömb: 11 12 15 17 14 Min: 15 Ciklus i:=1-től 4-ig index:=i min:=tömb[i] Ciklus j:=i+1-től 5-ig Ha (min>tömb[j]) akkor min:=tömb[j] index:=j Elágazás vége Ciklus vége tömb[index]:=tömb[i] tömb[i]:=max i = 3 index = 3 j = 4

299 Rendezés minimumkiválasztással
Tömb: 11 12 15 17 14 Min: 15 Ciklus i:=1-től 4-ig index:=i min:=tömb[i] Ciklus j:=i+1-től 5-ig Ha (min>tömb[j]) akkor min:=tömb[j] index:=j Elágazás vége Ciklus vége tömb[index]:=tömb[i] tömb[i]:=max i = 3 index = 3 j = 4

300 Rendezés minimumkiválasztással
Tömb: 11 12 15 17 14 Min: 15 Ciklus i:=1-től 4-ig index:=i min:=tömb[i] Ciklus j:=i+1-től 5-ig Ha (min>tömb[j]) akkor min:=tömb[j] index:=j Elágazás vége Ciklus vége tömb[index]:=tömb[i] tömb[i]:=max i = 3 index = 3 j = 5

301 Rendezés minimumkiválasztással
Tömb: 11 12 15 17 14 Min: 15 Ciklus i:=1-től 4-ig index:=i min:=tömb[i] Ciklus j:=i+1-től 5-ig Ha (min>tömb[j]) akkor min:=tömb[j] index:=j Elágazás vége Ciklus vége tömb[index]:=tömb[i] tömb[i]:=max i = 3 index = 3 j = 5

302 Rendezés minimumkiválasztással
Tömb: 11 12 15 17 14 Min: 14 Ciklus i:=1-től 4-ig index:=i min:=tömb[i] Ciklus j:=i+1-től 5-ig Ha (min>tömb[j]) akkor min:=tömb[j] index:=j Elágazás vége Ciklus vége tömb[index]:=tömb[i] tömb[i]:=max i = 3 index = 3 j = 5

303 Rendezés minimumkiválasztással
Tömb: 11 12 15 17 14 Min: 14 Ciklus i:=1-től 4-ig index:=i min:=tömb[i] Ciklus j:=i+1-től 5-ig Ha (min>tömb[j]) akkor min:=tömb[j] index:=j Elágazás vége Ciklus vége tömb[index]:=tömb[i] tömb[i]:=max i = 3 index = 5 j = 5

304 Rendezés minimumkiválasztással
Tömb: 11 12 15 17 14 Min: 14 Ciklus i:=1-től 4-ig index:=i min:=tömb[i] Ciklus j:=i+1-től 5-ig Ha (min>tömb[j]) akkor min:=tömb[j] index:=j Elágazás vége Ciklus vége tömb[index]:=tömb[i] tömb[i]:=max i = 3 index = 5 j = 5

305 Rendezés minimumkiválasztással
Tömb: 11 12 15 17 14 Min: 14 Ciklus i:=1-től 4-ig index:=i min:=tömb[i] Ciklus j:=i+1-től 5-ig Ha (min>tömb[j]) akkor min:=tömb[j] index:=j Elágazás vége Ciklus vége tömb[index]:=tömb[i] tömb[i]:=max i = 3 index = 5 j = 5

306 Rendezés minimumkiválasztással
Tömb: 11 12 15 17 15 Min: 14 Ciklus i:=1-től 4-ig index:=i min:=tömb[i] Ciklus j:=i+1-től 5-ig Ha (min>tömb[j]) akkor min:=tömb[j] index:=j Elágazás vége Ciklus vége tömb[index]:=tömb[i] tömb[i]:=max i = 3 index = 5 j = 5

307 Rendezés minimumkiválasztással
Tömb: 11 12 14 17 15 Min: 14 Ciklus i:=1-től 4-ig index:=i min:=tömb[i] Ciklus j:=i+1-től 5-ig Ha (min>tömb[j]) akkor min:=tömb[j] index:=j Elágazás vége Ciklus vége tömb[index]:=tömb[i] tömb[i]:=max i = 3 index = 5 j = 5

308 Rendezés minimumkiválasztással
Tömb: 11 12 14 17 15 Min: 14 Ciklus i:=1-től 4-ig index:=i min:=tömb[i] Ciklus j:=i+1-től 5-ig Ha (min>tömb[j]) akkor min:=tömb[j] index:=j Elágazás vége Ciklus vége tömb[index]:=tömb[i] tömb[i]:=max i = 3 index = 5 j = 5

309 Rendezés minimumkiválasztással
Tömb: 11 12 14 17 15 Min: 14 Ciklus i:=1-től 4-ig index:=i min:=tömb[i] Ciklus j:=i+1-től 5-ig Ha (min>tömb[j]) akkor min:=tömb[j] index:=j Elágazás vége Ciklus vége tömb[index]:=tömb[i] tömb[i]:=max i = 4 index = 5 j = 5

310 Rendezés minimumkiválasztással
Tömb: 11 12 14 17 15 Min: 14 Ciklus i:=1-től 4-ig index:=i min:=tömb[i] Ciklus j:=i+1-től 5-ig Ha (min>tömb[j]) akkor min:=tömb[j] index:=j Elágazás vége Ciklus vége tömb[index]:=tömb[i] tömb[i]:=max i = 4 index = 4 j = 5

311 Rendezés minimumkiválasztással
Tömb: 11 12 14 17 15 Min: 17 Ciklus i:=1-től 4-ig index:=i min:=tömb[i] Ciklus j:=i+1-től 5-ig Ha (min>tömb[j]) akkor min:=tömb[j] index:=j Elágazás vége Ciklus vége tömb[index]:=tömb[i] tömb[i]:=max i = 4 index = 4 j = 5

312 Rendezés minimumkiválasztással
Tömb: 11 12 14 17 15 Min: 17 Ciklus i:=1-től 4-ig index:=i min:=tömb[i] Ciklus j:=i+1-től 5-ig Ha (min>tömb[j]) akkor min:=tömb[j] index:=j Elágazás vége Ciklus vége tömb[index]:=tömb[i] tömb[i]:=max i = 4 index = 4 j = 5

313 Rendezés minimumkiválasztással
Tömb: 11 12 14 17 15 Min: 17 Ciklus i:=1-től 4-ig index:=i min:=tömb[i] Ciklus j:=i+1-től 5-ig Ha (min>tömb[j]) akkor min:=tömb[j] index:=j Elágazás vége Ciklus vége tömb[index]:=tömb[i] tömb[i]:=max i = 4 index = 4 j = 5

314 Rendezés minimumkiválasztással
Tömb: 11 12 14 17 15 Min: 15 Ciklus i:=1-től 4-ig index:=i min:=tömb[i] Ciklus j:=i+1-től 5-ig Ha (min>tömb[j]) akkor min:=tömb[j] index:=j Elágazás vége Ciklus vége tömb[index]:=tömb[i] tömb[i]:=max i = 4 index = 4 j = 5

315 Rendezés minimumkiválasztással
Tömb: 11 12 14 17 15 Min: 15 Ciklus i:=1-től 4-ig index:=i min:=tömb[i] Ciklus j:=i+1-től 5-ig Ha (min>tömb[j]) akkor min:=tömb[j] index:=j Elágazás vége Ciklus vége tömb[index]:=tömb[i] tömb[i]:=max i = 4 index = 5 j = 5

316 Rendezés minimumkiválasztással
Tömb: 11 12 14 17 15 Min: 15 Ciklus i:=1-től 4-ig index:=i min:=tömb[i] Ciklus j:=i+1-től 5-ig Ha (min>tömb[j]) akkor min:=tömb[j] index:=j Elágazás vége Ciklus vége tömb[index]:=tömb[i] tömb[i]:=max i = 4 index = 5 j = 5

317 Rendezés minimumkiválasztással
Tömb: 11 12 14 17 15 Min: 15 Ciklus i:=1-től 4-ig index:=i min:=tömb[i] Ciklus j:=i+1-től 5-ig Ha (min>tömb[j]) akkor min:=tömb[j] index:=j Elágazás vége Ciklus vége tömb[index]:=tömb[i] tömb[i]:=max i = 4 index = 5 j = 5

318 Rendezés minimumkiválasztással
Tömb: 11 12 14 17 17 Min: 15 Ciklus i:=1-től 4-ig index:=i min:=tömb[i] Ciklus j:=i+1-től 5-ig Ha (min>tömb[j]) akkor min:=tömb[j] index:=j Elágazás vége Ciklus vége tömb[index]:=tömb[i] tömb[i]:=max i = 4 index = 5 j = 5

319 Rendezés minimumkiválasztással
Tömb: 11 12 14 15 17 Min: 15 Ciklus i:=1-től 4-ig index:=i min:=tömb[i] Ciklus j:=i+1-től 5-ig Ha (min>tömb[j]) akkor min:=tömb[j] index:=j Elágazás vége Ciklus vége tömb[index]:=tömb[i] tömb[i]:=max i = 4 index = 5 j = 5

320 Rendezés minimumkiválasztással
Tömb: 11 12 14 15 17 Min: 15 Ciklus i:=1-től 4-ig index:=i min:=tömb[i] Ciklus j:=i+1-től 5-ig Ha (min>tömb[j]) akkor min:=tömb[j] index:=j Elágazás vége Ciklus vége tömb[index]:=tömb[i] tömb[i]:=max i = 4 index = 5 j = 5

321 Rendezés egyszerű beszúrással

322 Rendezés egyszerű beszúrással
Legyen adott az n elemű A sorozat és egy a sorozat elemein értelmezett rendezési reláció. A feladat az, hogy rendezzük növekvő sorrendbe a sorozat elemeit. Az algoritmus minden iterációban a helyére visz egy elemet, azaz beszúr egy elemet a már rendezett részsorozatba.

323 B C ? D A

324 B C A D A

325 B C A D D

326 B C A D D

327 B C A C D

328 B B A C D

329 A B A C D

330 A B A C D

331 B C ? D A

332 B C A D A

333 B B A D A

334 B B A B A

335 B B A B B

336 A B A B B

337 A B A B B

338 Rendezés buborékos módszerrel

339 Rendezés buborékos módszerrel
Legyen adott az n elemű A sorozat és egy a sorozat elemein értelmezett rendezési reláció. A feladat az, hogy rendezzük növekvő sorrendbe a sorozat elemeit. Az algoritmus neve arra utal, hogy minden iterációban a még rendezetlen részsorozat legnagyobb eleme (az egymást követő elemek cseréje révén) felszivárog a részsorozat jobb szélső elemének helyére, mintha egy buborék haladna a víz alatt a felszín felé.

340 Buborékrendezés Tömb: 11 15 12 17 14 Segéd: Ciklus i:=2-től 5-ig
Ciklus j:=5-től i-ig Ha (tömb[j-1]>tömb[j]) akkor segéd:=tömb[j-1] tömb[j-1]:=tömb[j] tömb[j]:=segéd Elágazás vége Ciklus vége

341 Buborékrendezés Tömb: 11 15 12 17 14 Segéd: Ciklus i:=2-től 5-ig
Ciklus j:=5-től i-ig Ha (tömb[j-1]>tömb[j]) akkor segéd:=tömb[j-1] tömb[j-1]:=tömb[j] tömb[j]:=segéd Elágazás vége Ciklus vége i = 2

342 Buborékrendezés Tömb: 11 15 12 17 14 Segéd: Ciklus i:=2-től 5-ig
Ciklus j:=5-től i-ig Ha (tömb[j-1]>tömb[j]) akkor segéd:=tömb[j-1] tömb[j-1]:=tömb[j] tömb[j]:=segéd Elágazás vége Ciklus vége i = 2 j = 5

343 Buborékrendezés Tömb: 11 15 12 17 14 Segéd: Ciklus i:=2-től 5-ig
Ciklus j:=5-től i-ig Ha (tömb[j-1]>tömb[j]) akkor segéd:=tömb[j-1] tömb[j-1]:=tömb[j] tömb[j]:=segéd Elágazás vége Ciklus vége i = 2 j = 5

344 Buborékrendezés Tömb: 11 15 12 17 14 Segéd: 17 Ciklus i:=2-től 5-ig
Ciklus j:=5-től i-ig Ha (tömb[j-1]>tömb[j]) akkor segéd:=tömb[j-1] tömb[j-1]:=tömb[j] tömb[j]:=segéd Elágazás vége Ciklus vége i = 2 j = 5

345 Buborékrendezés Tömb: 11 15 12 14 14 Segéd: 17 Ciklus i:=2-től 5-ig
Ciklus j:=5-től i-ig Ha (tömb[j-1]>tömb[j]) akkor segéd:=tömb[j-1] tömb[j-1]:=tömb[j] tömb[j]:=segéd Elágazás vége Ciklus vége i = 2 j = 5

346 Buborékrendezés Tömb: 11 15 12 14 17 Segéd: 17 Ciklus i:=2-től 5-ig
Ciklus j:=5-től i-ig Ha (tömb[j-1]>tömb[j]) akkor segéd:=tömb[j-1] tömb[j-1]:=tömb[j] tömb[j]:=segéd Elágazás vége Ciklus vége i = 2 j = 5

347 Buborékrendezés Tömb: 11 15 12 14 17 Segéd: 17 Ciklus i:=2-től 5-ig
Ciklus j:=5-től i-ig Ha (tömb[j-1]>tömb[j]) akkor segéd:=tömb[j-1] tömb[j-1]:=tömb[j] tömb[j]:=segéd Elágazás vége Ciklus vége i = 2 j = 5

348 Buborékrendezés Tömb: 11 15 12 14 17 Segéd: 17 Ciklus i:=2-től 5-ig
Ciklus j:=5-től i-ig Ha (tömb[j-1]>tömb[j]) akkor segéd:=tömb[j-1] tömb[j-1]:=tömb[j] tömb[j]:=segéd Elágazás vége Ciklus vége i = 2 j = 5

349 Buborékrendezés Tömb: 11 15 12 14 17 Segéd: 17 Ciklus i:=2-től 5-ig
Ciklus j:=5-től i-ig Ha (tömb[j-1]>tömb[j]) akkor segéd:=tömb[j-1] tömb[j-1]:=tömb[j] tömb[j]:=segéd Elágazás vége Ciklus vége i = 2 j = 4

350 Buborékrendezés Tömb: 11 15 12 14 17 Segéd: 17 Ciklus i:=2-től 5-ig
Ciklus j:=5-től i-ig Ha (tömb[j-1]>tömb[j]) akkor segéd:=tömb[j-1] tömb[j-1]:=tömb[j] tömb[j]:=segéd Elágazás vége Ciklus vége i = 2 j = 4

351 Buborékrendezés Tömb: 11 15 12 14 17 Segéd: 17 Ciklus i:=2-től 5-ig
Ciklus j:=5-től i-ig Ha (tömb[j-1]>tömb[j]) akkor segéd:=tömb[j-1] tömb[j-1]:=tömb[j] tömb[j]:=segéd Elágazás vége Ciklus vége i = 2 j = 4

352 Buborékrendezés Tömb: 11 15 12 14 17 Segéd: 17 Ciklus i:=2-től 5-ig
Ciklus j:=5-től i-ig Ha (tömb[j-1]>tömb[j]) akkor segéd:=tömb[j-1] tömb[j-1]:=tömb[j] tömb[j]:=segéd Elágazás vége Ciklus vége i = 2 j = 4

353 Buborékrendezés Tömb: 11 15 12 14 17 Segéd: 17 Ciklus i:=2-től 5-ig
Ciklus j:=5-től i-ig Ha (tömb[j-1]>tömb[j]) akkor segéd:=tömb[j-1] tömb[j-1]:=tömb[j] tömb[j]:=segéd Elágazás vége Ciklus vége i = 2 j = 3

354 Buborékrendezés Tömb: 11 15 12 14 17 Segéd: 17 Ciklus i:=2-től 5-ig
Ciklus j:=5-től i-ig Ha (tömb[j-1]>tömb[j]) akkor segéd:=tömb[j-1] tömb[j-1]:=tömb[j] tömb[j]:=segéd Elágazás vége Ciklus vége i = 2 j = 3

355 Buborékrendezés Tömb: 11 15 12 14 17 Segéd: 15 Ciklus i:=2-től 5-ig
Ciklus j:=5-től i-ig Ha (tömb[j-1]>tömb[j]) akkor segéd:=tömb[j-1] tömb[j-1]:=tömb[j] tömb[j]:=segéd Elágazás vége Ciklus vége i = 2 j = 3

356 Buborékrendezés Tömb: 11 12 12 14 17 Segéd: 15 Ciklus i:=2-től 5-ig
Ciklus j:=5-től i-ig Ha (tömb[j-1]>tömb[j]) akkor segéd:=tömb[j-1] tömb[j-1]:=tömb[j] tömb[j]:=segéd Elágazás vége Ciklus vége i = 2 j = 3

357 Buborékrendezés Tömb: 11 12 15 14 17 Segéd: 15 Ciklus i:=2-től 5-ig
Ciklus j:=5-től i-ig Ha (tömb[j-1]>tömb[j]) akkor segéd:=tömb[j-1] tömb[j-1]:=tömb[j] tömb[j]:=segéd Elágazás vége Ciklus vége i = 2 j = 3

358 Buborékrendezés Tömb: 11 12 15 14 17 Segéd: 15 Ciklus i:=2-től 5-ig
Ciklus j:=5-től i-ig Ha (tömb[j-1]>tömb[j]) akkor segéd:=tömb[j-1] tömb[j-1]:=tömb[j] tömb[j]:=segéd Elágazás vége Ciklus vége i = 2 j = 3

359 Buborékrendezés Tömb: 11 12 15 14 17 Segéd: 15 Ciklus i:=2-től 5-ig
Ciklus j:=5-től i-ig Ha (tömb[j-1]>tömb[j]) akkor segéd:=tömb[j-1] tömb[j-1]:=tömb[j] tömb[j]:=segéd Elágazás vége Ciklus vége i = 2 j = 3

360 Buborékrendezés Tömb: 11 12 15 14 17 Segéd: 15 Ciklus i:=2-től 5-ig
Ciklus j:=5-től i-ig Ha (tömb[j-1]>tömb[j]) akkor segéd:=tömb[j-1] tömb[j-1]:=tömb[j] tömb[j]:=segéd Elágazás vége Ciklus vége i = 2 j = 2

361 Buborékrendezés Tömb: 11 12 15 14 17 Segéd: 15 Ciklus i:=2-től 5-ig
Ciklus j:=5-től i-ig Ha (tömb[j-1]>tömb[j]) akkor segéd:=tömb[j-1] tömb[j-1]:=tömb[j] tömb[j]:=segéd Elágazás vége Ciklus vége i = 2 j = 2

362 Buborékrendezés Tömb: 11 12 15 14 17 Segéd: 15 Ciklus i:=2-től 5-ig
Ciklus j:=5-től i-ig Ha (tömb[j-1]>tömb[j]) akkor segéd:=tömb[j-1] tömb[j-1]:=tömb[j] tömb[j]:=segéd Elágazás vége Ciklus vége i = 2 j = 2

363 Buborékrendezés Tömb: 11 12 15 14 17 Segéd: 15 Ciklus i:=2-től 5-ig
Ciklus j:=5-től i-ig Ha (tömb[j-1]>tömb[j]) akkor segéd:=tömb[j-1] tömb[j-1]:=tömb[j] tömb[j]:=segéd Elágazás vége Ciklus vége i = 2 j = 2

364 Buborékrendezés Tömb: 11 12 15 14 17 Segéd: 15 Ciklus i:=2-től 5-ig
Ciklus j:=5-től i-ig Ha (tömb[j-1]>tömb[j]) akkor segéd:=tömb[j-1] tömb[j-1]:=tömb[j] tömb[j]:=segéd Elágazás vége Ciklus vége i = 2 j = 2

365 Buborékrendezés Tömb: 11 12 15 14 17 Segéd: 15 Ciklus i:=2-től 5-ig
Ciklus j:=5-től i-ig Ha (tömb[j-1]>tömb[j]) akkor segéd:=tömb[j-1] tömb[j-1]:=tömb[j] tömb[j]:=segéd Elágazás vége Ciklus vége i = 3 j = 2

366 Buborékrendezés Tömb: 11 12 15 14 17 Segéd: 15 Ciklus i:=2-től 5-ig
Ciklus j:=5-től i-ig Ha (tömb[j-1]>tömb[j]) akkor segéd:=tömb[j-1] tömb[j-1]:=tömb[j] tömb[j]:=segéd Elágazás vége Ciklus vége i = 3 j = 5

367 Buborékrendezés Tömb: 11 12 15 14 17 Segéd: 15 Ciklus i:=2-től 5-ig
Ciklus j:=5-től i-ig Ha (tömb[j-1]>tömb[j]) akkor segéd:=tömb[j-1] tömb[j-1]:=tömb[j] tömb[j]:=segéd Elágazás vége Ciklus vége i = 3 j = 5

368 Buborékrendezés Tömb: 11 12 15 14 17 Segéd: 15 Ciklus i:=2-től 5-ig
Ciklus j:=5-től i-ig Ha (tömb[j-1]>tömb[j]) akkor segéd:=tömb[j-1] tömb[j-1]:=tömb[j] tömb[j]:=segéd Elágazás vége Ciklus vége i = 3 j = 5

369 Buborékrendezés Tömb: 11 12 15 14 17 Segéd: 15 Ciklus i:=2-től 5-ig
Ciklus j:=5-től i-ig Ha (tömb[j-1]>tömb[j]) akkor segéd:=tömb[j-1] tömb[j-1]:=tömb[j] tömb[j]:=segéd Elágazás vége Ciklus vége i = 3 j = 5

370 Buborékrendezés Tömb: 11 12 15 14 17 Segéd: 15 Ciklus i:=2-től 5-ig
Ciklus j:=5-től i-ig Ha (tömb[j-1]>tömb[j]) akkor segéd:=tömb[j-1] tömb[j-1]:=tömb[j] tömb[j]:=segéd Elágazás vége Ciklus vége i = 3 j = 4

371 Buborékrendezés Tömb: 11 12 15 14 17 Segéd: 15 Ciklus i:=2-től 5-ig
Ciklus j:=5-től i-ig Ha (tömb[j-1]>tömb[j]) akkor segéd:=tömb[j-1] tömb[j-1]:=tömb[j] tömb[j]:=segéd Elágazás vége Ciklus vége i = 3 j = 4

372 Buborékrendezés Tömb: 11 12 15 14 17 Segéd: 15 Ciklus i:=2-től 5-ig
Ciklus j:=5-től i-ig Ha (tömb[j-1]>tömb[j]) akkor segéd:=tömb[j-1] tömb[j-1]:=tömb[j] tömb[j]:=segéd Elágazás vége Ciklus vége i = 3 j = 4

373 Buborékrendezés Tömb: 11 12 14 14 17 Segéd: 15 Ciklus i:=2-től 5-ig
Ciklus j:=5-től i-ig Ha (tömb[j-1]>tömb[j]) akkor segéd:=tömb[j-1] tömb[j-1]:=tömb[j] tömb[j]:=segéd Elágazás vége Ciklus vége i = 3 j = 4

374 Buborékrendezés Tömb: 11 12 14 15 17 Segéd: 15 Ciklus i:=2-től 5-ig
Ciklus j:=5-től i-ig Ha (tömb[j-1]>tömb[j]) akkor segéd:=tömb[j-1] tömb[j-1]:=tömb[j] tömb[j]:=segéd Elágazás vége Ciklus vége i = 3 j = 4

375 Buborékrendezés Tömb: 11 12 14 15 17 Segéd: 15 Ciklus i:=2-től 5-ig
Ciklus j:=5-től i-ig Ha (tömb[j-1]>tömb[j]) akkor segéd:=tömb[j-1] tömb[j-1]:=tömb[j] tömb[j]:=segéd Elágazás vége Ciklus vége i = 3 j = 4

376 Buborékrendezés Tömb: 11 12 14 15 17 Segéd: 15 Ciklus i:=2-től 5-ig
Ciklus j:=5-től i-ig Ha (tömb[j-1]>tömb[j]) akkor segéd:=tömb[j-1] tömb[j-1]:=tömb[j] tömb[j]:=segéd Elágazás vége Ciklus vége i = 3 j = 4

377 Buborékrendezés Tömb: 11 12 14 15 17 Segéd: 15 Ciklus i:=2-től 5-ig
Ciklus j:=5-től i-ig Ha (tömb[j-1]>tömb[j]) akkor segéd:=tömb[j-1] tömb[j-1]:=tömb[j] tömb[j]:=segéd Elágazás vége Ciklus vége i = 3 j = 3

378 Buborékrendezés Tömb: 11 12 14 15 17 Segéd: 15 Ciklus i:=2-től 5-ig
Ciklus j:=5-től i-ig Ha (tömb[j-1]>tömb[j]) akkor segéd:=tömb[j-1] tömb[j-1]:=tömb[j] tömb[j]:=segéd Elágazás vége Ciklus vége i = 3 j = 3

379 Buborékrendezés Tömb: 11 12 14 15 17 Segéd: 15 Ciklus i:=2-től 5-ig
Ciklus j:=5-től i-ig Ha (tömb[j-1]>tömb[j]) akkor segéd:=tömb[j-1] tömb[j-1]:=tömb[j] tömb[j]:=segéd Elágazás vége Ciklus vége i = 3 j = 3

380 Buborékrendezés Tömb: 11 12 14 15 17 Segéd: 15 Ciklus i:=2-től 5-ig
Ciklus j:=5-től i-ig Ha (tömb[j-1]>tömb[j]) akkor segéd:=tömb[j-1] tömb[j-1]:=tömb[j] tömb[j]:=segéd Elágazás vége Ciklus vége i = 3 j = 3

381 Buborékrendezés Tömb: 11 12 14 15 17 Segéd: 15 Ciklus i:=2-től 5-ig
Ciklus j:=5-től i-ig Ha (tömb[j-1]>tömb[j]) akkor segéd:=tömb[j-1] tömb[j-1]:=tömb[j] tömb[j]:=segéd Elágazás vége Ciklus vége i = 3 j = 3

382 Buborékrendezés Tömb: 11 12 14 15 17 Segéd: 15 Ciklus i:=2-től 5-ig
Ciklus j:=5-től i-ig Ha (tömb[j-1]>tömb[j]) akkor segéd:=tömb[j-1] tömb[j-1]:=tömb[j] tömb[j]:=segéd Elágazás vége Ciklus vége i = 4 j = 3

383 Buborékrendezés Tömb: 11 12 14 15 17 Segéd: 15 Ciklus i:=2-től 5-ig
Ciklus j:=5-től i-ig Ha (tömb[j-1]>tömb[j]) akkor segéd:=tömb[j-1] tömb[j-1]:=tömb[j] tömb[j]:=segéd Elágazás vége Ciklus vége i = 4 j = 5

384 Buborékrendezés Tömb: 11 12 14 15 17 Segéd: 15 Ciklus i:=2-től 5-ig
Ciklus j:=5-től i-ig Ha (tömb[j-1]>tömb[j]) akkor segéd:=tömb[j-1] tömb[j-1]:=tömb[j] tömb[j]:=segéd Elágazás vége Ciklus vége i = 4 j = 5

385 Buborékrendezés Tömb: 11 12 14 15 17 Segéd: 15 Ciklus i:=2-től 5-ig
Ciklus j:=5-től i-ig Ha (tömb[j-1]>tömb[j]) akkor segéd:=tömb[j-1] tömb[j-1]:=tömb[j] tömb[j]:=segéd Elágazás vége Ciklus vége i = 4 j = 5

386 Buborékrendezés Tömb: 11 12 14 15 17 Segéd: 15 Ciklus i:=2-től 5-ig
Ciklus j:=5-től i-ig Ha (tömb[j-1]>tömb[j]) akkor segéd:=tömb[j-1] tömb[j-1]:=tömb[j] tömb[j]:=segéd Elágazás vége Ciklus vége i = 4 j = 5

387 Buborékrendezés Tömb: 11 12 14 15 17 Segéd: 15 Ciklus i:=2-től 5-ig
Ciklus j:=5-től i-ig Ha (tömb[j-1]>tömb[j]) akkor segéd:=tömb[j-1] tömb[j-1]:=tömb[j] tömb[j]:=segéd Elágazás vége Ciklus vége i = 4 j = 4

388 Buborékrendezés Tömb: 11 12 14 15 17 Segéd: 15 Ciklus i:=2-től 5-ig
Ciklus j:=5-től i-ig Ha (tömb[j-1]>tömb[j]) akkor segéd:=tömb[j-1] tömb[j-1]:=tömb[j] tömb[j]:=segéd Elágazás vége Ciklus vége i = 4 j = 4

389 Buborékrendezés Tömb: 11 12 14 15 17 Segéd: 15 Ciklus i:=2-től 5-ig
Ciklus j:=5-től i-ig Ha (tömb[j-1]>tömb[j]) akkor segéd:=tömb[j-1] tömb[j-1]:=tömb[j] tömb[j]:=segéd Elágazás vége Ciklus vége i = 4 j = 4

390 Buborékrendezés Tömb: 11 12 14 15 17 Segéd: 15 Ciklus i:=2-től 5-ig
Ciklus j:=5-től i-ig Ha (tömb[j-1]>tömb[j]) akkor segéd:=tömb[j-1] tömb[j-1]:=tömb[j] tömb[j]:=segéd Elágazás vége Ciklus vége i = 4 j = 4

391 Buborékrendezés Tömb: 11 12 14 15 17 Segéd: 15 Ciklus i:=2-től 5-ig
Ciklus j:=5-től i-ig Ha (tömb[j-1]>tömb[j]) akkor segéd:=tömb[j-1] tömb[j-1]:=tömb[j] tömb[j]:=segéd Elágazás vége Ciklus vége i = 4 j = 4

392 Buborékrendezés Tömb: 11 12 14 15 17 Segéd: 15 Ciklus i:=2-től 5-ig
Ciklus j:=5-től i-ig Ha (tömb[j-1]>tömb[j]) akkor segéd:=tömb[j-1] tömb[j-1]:=tömb[j] tömb[j]:=segéd Elágazás vége Ciklus vége i = 5 j = 4

393 Buborékrendezés Tömb: 11 12 14 15 17 Segéd: 15 Ciklus i:=2-től 5-ig
Ciklus j:=5-től i-ig Ha (tömb[j-1]>tömb[j]) akkor segéd:=tömb[j-1] tömb[j-1]:=tömb[j] tömb[j]:=segéd Elágazás vége Ciklus vége i = 5 j = 5

394 Buborékrendezés Tömb: 11 12 14 15 17 Segéd: 15 Ciklus i:=2-től 5-ig
Ciklus j:=5-től i-ig Ha (tömb[j-1]>tömb[j]) akkor segéd:=tömb[j-1] tömb[j-1]:=tömb[j] tömb[j]:=segéd Elágazás vége Ciklus vége i = 5 j = 5

395 Buborékrendezés Tömb: 11 12 14 15 17 Segéd: 15 Ciklus i:=2-től 5-ig
Ciklus j:=5-től i-ig Ha (tömb[j-1]>tömb[j]) akkor segéd:=tömb[j-1] tömb[j-1]:=tömb[j] tömb[j]:=segéd Elágazás vége Ciklus vége i = 5 j = 5

396 Buborékrendezés Tömb: 11 12 14 15 17 Segéd: 15 Ciklus i:=2-től 5-ig
Ciklus j:=5-től i-ig Ha (tömb[j-1]>tömb[j]) akkor segéd:=tömb[j-1] tömb[j-1]:=tömb[j] tömb[j]:=segéd Elágazás vége Ciklus vége i = 5 j = 5

397 Buborékrendezés Tömb: 11 12 14 15 17 Segéd: 15 Ciklus i:=2-től 5-ig
Ciklus j:=5-től i-ig Ha (tömb[j-1]>tömb[j]) akkor segéd:=tömb[j-1] tömb[j-1]:=tömb[j] tömb[j]:=segéd Elágazás vége Ciklus vége i = 5 j = 5

398 Rendezés Shell módszerrel

399 6 4 1 2 7 3 5

400 6 4 1 2 7 3 5

401 6 4 1 2 7 3 5

402 4 6 1 2 7 3 5

403 4 6 1 2 7 3 5

404 4 1 6 2 7 3 5

405 4 1 6 2 7 3 5

406 4 1 2 6 7 3 5

407 4 1 2 6 7 3 5

408 4 1 2 6 7 3 5

409 4 1 2 6 3 7 5

410 4 1 2 6 3 7 5

411 4 1 2 6 3 5 7

412 4 1 2 6 3 5 7

413 4 1 2 6 3 5 7

414 4 1 2 6 3 5 7

415 1 4 2 6 3 5 7

416 1 4 2 6 3 5 7

417 1 2 4 6 3 5 7

418 1 2 4 6 3 5 7

419 1 2 4 6 3 5 7

420 1 2 4 3 6 5 7

421 1 2 4 3 6 5 7

422 1 2 4 3 5 6 7

423 1 2 4 3 5 6 7

424 1 2 4 3 5 6 7

425 1 2 4 3 5 6 7

426 1 2 4 3 5 6 7

427 1 2 4 3 5 6 7

428 1 2 3 4 5 6 7

429 1 2 3 4 5 6 7

430 1 2 3 4 5 6 7

431 1 2 3 4 5 6 7

432 1 2 3 4 5 6 7

433 1 2 3 4 5 6 7

434 1 2 3 4 5 6 7

435 13 23 43 38 39 41 3 15 28 1 37 8 44 2 34 30 32 26 21 5 22 31 27 16 17 9 33 10 18 40 7 12 19 25 4 45 36 42 20 14 35 6 11 24 29 A rendezetlen tömb

436 13 23 43 38 39 41 3 15 28 1 37 8 44 2 34 30 32 26 21 5 22 31 27 16 17 9 33 10 18 40 7 12 19 25 4 45 36 42 20 14 35 6 11 24 29 Lépésköz: 31 1. lépés Rendezés előtt

437 12 23 43 38 39 41 3 15 28 1 37 8 44 2 34 30 32 26 21 5 22 31 27 16 17 9 33 10 18 40 7 13 19 25 4 45 36 42 20 14 35 6 11 24 29 Lépésköz: 31 1. lépés Rendezés után

438 12 23 43 38 39 41 3 15 28 1 37 8 44 2 34 30 32 26 21 5 22 31 27 16 17 9 33 10 18 40 7 13 19 25 4 45 36 42 20 14 35 6 11 24 29 Lépésköz: 31 2. lépés Rendezés előtt

439 12 19 43 38 39 41 3 15 28 1 37 8 44 2 34 30 32 26 21 5 22 31 27 16 17 9 33 10 18 40 7 13 23 25 4 45 36 42 20 14 35 6 11 24 29 Lépésköz: 31 2. lépés Rendezés után

440 12 19 43 38 39 41 3 15 28 1 37 8 44 2 34 30 32 26 21 5 22 31 27 16 17 9 33 10 18 40 7 13 23 25 4 45 36 42 20 14 35 6 11 24 29 Lépésköz: 31 3. lépés Rendezés előtt

441 12 19 25 38 39 41 3 15 28 1 37 8 44 2 34 30 32 26 21 5 22 31 27 16 17 9 33 10 18 40 7 13 23 43 4 45 36 42 20 14 35 6 11 24 29 Lépésköz: 31 3. lépés Rendezés után

442 12 19 25 38 39 41 3 15 28 1 37 8 44 2 34 30 32 26 21 5 22 31 27 16 17 9 33 10 18 40 7 13 23 43 4 45 36 42 20 14 35 6 11 24 29 Lépésköz: 31 4. lépés Rendezés előtt

443 12 19 25 4 39 41 3 15 28 1 37 8 44 2 34 30 32 26 21 5 22 31 27 16 17 9 33 10 18 40 7 13 23 43 38 45 36 42 20 14 35 6 11 24 29 Lépésköz: 31 4. lépés Rendezés után

444 12 19 25 4 39 41 3 15 28 1 37 8 44 2 34 30 32 26 21 5 22 31 27 16 17 9 33 10 18 40 7 13 23 43 38 45 36 42 20 14 35 6 11 24 29 Lépésköz: 31 5. lépés Rendezés előtt

445 12 19 25 4 39 41 3 15 28 1 37 8 44 2 34 30 32 26 21 5 22 31 27 16 17 9 33 10 18 40 7 13 23 43 38 45 36 42 20 14 35 6 11 24 29 Lépésköz: 31 5. lépés Rendezés után

446 12 19 25 4 39 41 3 15 28 1 37 8 44 2 34 30 32 26 21 5 22 31 27 16 17 9 33 10 18 40 7 13 23 43 38 45 36 42 20 14 35 6 11 24 29 Lépésköz: 31 6. lépés Rendezés előtt

447 12 19 25 4 39 36 3 15 28 1 37 8 44 2 34 30 32 26 21 5 22 31 27 16 17 9 33 10 18 40 7 13 23 43 38 45 41 42 20 14 35 6 11 24 29 Lépésköz: 31 6. lépés Rendezés után

448 12 19 25 4 39 36 3 15 28 1 37 8 44 2 34 30 32 26 21 5 22 31 27 16 17 9 33 10 18 40 7 13 23 43 38 45 41 42 20 14 35 6 11 24 29 Lépésköz: 31 7. lépés Rendezés előtt

449 12 19 25 4 39 36 3 15 28 1 37 8 44 2 34 30 32 26 21 5 22 31 27 16 17 9 33 10 18 40 7 13 23 43 38 45 41 42 20 14 35 6 11 24 29 Lépésköz: 31 7. lépés Rendezés után

450 12 19 25 4 39 36 3 15 28 1 37 8 44 2 34 30 32 26 21 5 22 31 27 16 17 9 33 10 18 40 7 13 23 43 38 45 41 42 20 14 35 6 11 24 29 Lépésköz: 31 8. lépés Rendezés előtt

451 12 19 25 4 39 36 3 15 28 1 37 8 44 2 34 30 32 26 21 5 22 31 27 16 17 9 33 10 18 40 7 13 23 43 38 45 41 42 20 14 35 6 11 24 29 Lépésköz: 31 8. lépés Rendezés után

452 12 19 25 4 39 36 3 15 28 1 37 8 44 2 34 30 32 26 21 5 22 31 27 16 17 9 33 10 18 40 7 13 23 43 38 45 41 42 20 14 35 6 11 24 29 Lépésköz: 31 9. lépés Rendezés előtt

453 12 19 25 4 39 36 3 15 14 1 37 8 44 2 34 30 32 26 21 5 22 31 27 16 17 9 33 10 18 40 7 13 23 43 38 45 41 42 20 28 35 6 11 24 29 Lépésköz: 31 9. lépés Rendezés után

454 12 19 25 4 39 36 3 15 14 1 37 8 44 2 34 30 32 26 21 5 22 31 27 16 17 9 33 10 18 40 7 13 23 43 38 45 41 42 20 28 35 6 11 24 29 Lépésköz: 31 10. lépés Rendezés előtt

455 12 19 25 4 39 36 3 15 14 1 37 8 44 2 34 30 32 26 21 5 22 31 27 16 17 9 33 10 18 40 7 13 23 43 38 45 41 42 20 28 35 6 11 24 29 Lépésköz: 31 10. lépés Rendezés után

456 12 19 25 4 39 36 3 15 14 1 37 8 44 2 34 30 32 26 21 5 22 31 27 16 17 9 33 10 18 40 7 13 23 43 38 45 41 42 20 28 35 6 11 24 29 Lépésköz: 31 11. lépés Rendezés előtt

457 12 19 25 4 39 36 3 15 14 1 6 8 44 2 34 30 32 26 21 5 22 31 27 16 17 9 33 10 18 40 7 13 23 43 38 45 41 42 20 28 35 37 11 24 29 Lépésköz: 31 11. lépés Rendezés után

458 12 19 25 4 39 36 3 15 14 1 6 8 44 2 34 30 32 26 21 5 22 31 27 16 17 9 33 10 18 40 7 13 23 43 38 45 41 42 20 28 35 37 11 24 29 Lépésköz: 31 12. lépés Rendezés előtt

459 12 19 25 4 39 36 3 15 14 1 6 8 44 2 34 30 32 26 21 5 22 31 27 16 17 9 33 10 18 40 7 13 23 43 38 45 41 42 20 28 35 37 11 24 29 Lépésköz: 31 12. lépés Rendezés után

460 12 19 25 4 39 36 3 15 14 1 6 8 44 2 34 30 32 26 21 5 22 31 27 16 17 9 33 10 18 40 7 13 23 43 38 45 41 42 20 28 35 37 11 24 29 Lépésköz: 31 13. lépés Rendezés előtt

461 12 19 25 4 39 36 3 15 14 1 6 8 24 2 34 30 32 26 21 5 22 31 27 16 17 9 33 10 18 40 7 13 23 43 38 45 41 42 20 28 35 37 11 44 29 Lépésköz: 31 13. lépés Rendezés után

462 12 19 25 4 39 36 3 15 14 1 6 8 24 2 34 30 32 26 21 5 22 31 27 16 17 9 33 10 18 40 7 13 23 43 38 45 41 42 20 28 35 37 11 44 29 Lépésköz: 31 14. lépés Rendezés előtt

463 12 19 25 4 39 36 3 15 14 1 6 8 24 2 34 30 32 26 21 5 22 31 27 16 17 9 33 10 18 40 7 13 23 43 38 45 41 42 20 28 35 37 11 44 29 Lépésköz: 31 14. lépés Rendezés után

464 12 19 25 4 39 36 3 15 14 1 6 8 24 2 34 30 32 26 21 5 22 31 27 16 17 9 33 10 18 40 7 13 23 43 38 45 41 42 20 28 35 37 11 44 29 Lépésköz: 15 1. lépés Rendezés előtt

465 7 19 25 4 39 36 3 15 14 1 6 8 24 2 34 12 32 26 21 5 22 31 27 16 17 9 33 10 18 40 30 13 23 43 38 45 41 42 20 28 35 37 11 44 29 Lépésköz: 15 1. lépés Rendezés után

466 7 19 25 4 39 36 3 15 14 1 6 8 24 2 34 12 32 26 21 5 22 31 27 16 17 9 33 10 18 40 30 13 23 43 38 45 41 42 20 28 35 37 11 44 29 Lépésköz: 15 2. lépés Rendezés előtt

467 7 13 25 4 39 36 3 15 14 1 6 8 24 2 34 12 19 26 21 5 22 31 27 16 17 9 33 10 18 40 30 32 23 43 38 45 41 42 20 28 35 37 11 44 29 Lépésköz: 15 2. lépés Rendezés után

468 7 13 25 4 39 36 3 15 14 1 6 8 24 2 34 12 19 26 21 5 22 31 27 16 17 9 33 10 18 40 30 32 23 43 38 45 41 42 20 28 35 37 11 44 29 Lépésköz: 15 3. lépés Rendezés előtt

469 7 13 23 4 39 36 3 15 14 1 6 8 24 2 34 12 19 25 21 5 22 31 27 16 17 9 33 10 18 40 30 32 26 43 38 45 41 42 20 28 35 37 11 44 29 Lépésköz: 15 3. lépés Rendezés után

470 7 13 23 4 39 36 3 15 14 1 6 8 24 2 34 12 19 25 21 5 22 31 27 16 17 9 33 10 18 40 30 32 26 43 38 45 41 42 20 28 35 37 11 44 29 Lépésköz: 15 4. lépés Rendezés előtt

471 7 13 23 4 39 36 3 15 14 1 6 8 24 2 34 12 19 25 21 5 22 31 27 16 17 9 33 10 18 40 30 32 26 43 38 45 41 42 20 28 35 37 11 44 29 Lépésköz: 15 4. lépés Rendezés után

472 7 13 23 4 39 36 3 15 14 1 6 8 24 2 34 12 19 25 21 5 22 31 27 16 17 9 33 10 18 40 30 32 26 43 38 45 41 42 20 28 35 37 11 44 29 Lépésköz: 15 5. lépés Rendezés előtt

473 7 13 23 4 5 36 3 15 14 1 6 8 24 2 34 12 19 25 21 38 22 31 27 16 17 9 33 10 18 40 30 32 26 43 39 45 41 42 20 28 35 37 11 44 29 Lépésköz: 15 5. lépés Rendezés után

474 7 13 23 4 5 36 3 15 14 1 6 8 24 2 34 12 19 25 21 38 22 31 27 16 17 9 33 10 18 40 30 32 26 43 39 45 41 42 20 28 35 37 11 44 29 Lépésköz: 15 6. lépés Rendezés előtt

475 7 13 23 4 5 22 3 15 14 1 6 8 24 2 34 12 19 25 21 38 36 31 27 16 17 9 33 10 18 40 30 32 26 43 39 45 41 42 20 28 35 37 11 44 29 Lépésköz: 15 6. lépés Rendezés után

476 7 13 23 4 5 22 3 15 14 1 6 8 24 2 34 12 19 25 21 38 36 31 27 16 17 9 33 10 18 40 30 32 26 43 39 45 41 42 20 28 35 37 11 44 29 Lépésköz: 15 7. lépés Rendezés előtt

477 7 13 23 4 5 22 3 15 14 1 6 8 24 2 34 12 19 25 21 38 36 31 27 16 17 9 33 10 18 40 30 32 26 43 39 45 41 42 20 28 35 37 11 44 29 Lépésköz: 15 7. lépés Rendezés után

478 7 13 23 4 5 22 3 15 14 1 6 8 24 2 34 12 19 25 21 38 36 31 27 16 17 9 33 10 18 40 30 32 26 43 39 45 41 42 20 28 35 37 11 44 29 Lépésköz: 15 8. lépés Rendezés előtt

479 7 13 23 4 5 22 3 15 14 1 6 8 24 2 34 12 19 25 21 38 36 31 27 16 17 9 33 10 18 40 30 32 26 43 39 45 41 42 20 28 35 37 11 44 29 Lépésköz: 15 8. lépés Rendezés után

480 7 13 23 4 5 22 3 15 14 1 6 8 24 2 34 12 19 25 21 38 36 31 27 16 17 9 33 10 18 40 30 32 26 43 39 45 41 42 20 28 35 37 11 44 29 Lépésköz: 15 9. lépés Rendezés előtt

481 7 13 23 4 5 22 3 15 14 1 6 8 24 2 34 12 19 25 21 38 36 31 27 16 17 9 33 10 18 40 30 32 26 43 39 45 41 42 20 28 35 37 11 44 29 Lépésköz: 15 9. lépés Rendezés után

482 7 13 23 4 5 22 3 15 14 1 6 8 24 2 34 12 19 25 21 38 36 31 27 16 17 9 33 10 18 40 30 32 26 43 39 45 41 42 20 28 35 37 11 44 29 Lépésköz: 15 10. lépés Rendezés előtt

483 7 13 23 4 5 22 3 15 14 1 6 8 24 2 34 12 19 25 21 38 36 31 27 16 17 9 33 10 18 40 30 32 26 43 39 45 41 42 20 28 35 37 11 44 29 Lépésköz: 15 10. lépés Rendezés után

484 7 13 23 4 5 22 3 15 14 1 6 8 24 2 34 12 19 25 21 38 36 31 27 16 17 9 33 10 18 40 30 32 26 43 39 45 41 42 20 28 35 37 11 44 29 Lépésköz: 15 11. lépés Rendezés előtt

485 7 13 23 4 5 22 3 15 14 1 6 8 24 2 34 12 19 25 21 38 36 31 27 16 17 9 33 10 18 40 30 32 26 43 39 45 41 42 20 28 35 37 11 44 29 Lépésköz: 15 11. lépés Rendezés után

486 7 13 23 4 5 22 3 15 14 1 6 8 24 2 34 12 19 25 21 38 36 31 27 16 17 9 33 10 18 40 30 32 26 43 39 45 41 42 20 28 35 37 11 44 29 Lépésköz: 15 12. lépés Rendezés előtt

487 7 13 23 4 5 22 3 15 14 1 6 8 24 2 34 12 19 25 21 38 36 31 27 16 17 9 33 10 18 40 30 32 26 43 39 45 41 42 20 28 35 37 11 44 29 Lépésköz: 15 12. lépés Rendezés után

488 7 13 23 4 5 22 3 15 14 1 6 8 24 2 34 12 19 25 21 38 36 31 27 16 17 9 33 10 18 40 30 32 26 43 39 45 41 42 20 28 35 37 11 44 29 Lépésköz: 15 13. lépés Rendezés előtt

489 7 13 23 4 5 22 3 15 14 1 6 8 10 2 34 12 19 25 21 38 36 31 27 16 17 9 33 11 18 40 30 32 26 43 39 45 41 42 20 28 35 37 24 44 29 Lépésköz: 15 13. lépés Rendezés után

490 7 13 23 4 5 22 3 15 14 1 6 8 10 2 34 12 19 25 21 38 36 31 27 16 17 9 33 11 18 40 30 32 26 43 39 45 41 42 20 28 35 37 24 44 29 Lépésköz: 15 14. lépés Rendezés előtt

491 7 13 23 4 5 22 3 15 14 1 6 8 10 2 34 12 19 25 21 38 36 31 27 16 17 9 33 11 18 40 30 32 26 43 39 45 41 42 20 28 35 37 24 44 29 Lépésköz: 15 14. lépés Rendezés után

492 7 13 23 4 5 22 3 15 14 1 6 8 10 2 34 12 19 25 21 38 36 31 27 16 17 9 33 11 18 40 30 32 26 43 39 45 41 42 20 28 35 37 24 44 29 Lépésköz: 15 15. lépés Rendezés előtt

493 7 13 23 4 5 22 3 15 14 1 6 8 10 2 29 12 19 25 21 38 36 31 27 16 17 9 33 11 18 34 30 32 26 43 39 45 41 42 20 28 35 37 24 44 40 Lépésköz: 15 15. lépés Rendezés után

494 7 13 23 4 5 22 3 15 14 1 6 8 10 2 29 12 19 25 21 38 36 31 27 16 17 9 33 11 18 34 30 32 26 43 39 45 41 42 20 28 35 37 24 44 40 Lépésköz: 7 1. lépés Rendezés előtt

495 7 13 23 4 5 22 3 15 14 1 6 8 10 2 18 12 19 25 21 38 36 24 27 16 17 9 33 11 29 34 30 32 26 43 39 31 41 42 20 28 35 37 45 44 40 Lépésköz: 7 1. lépés Rendezés után

496 7 13 23 4 5 22 3 15 14 1 6 8 10 2 18 12 19 25 21 38 36 24 27 16 17 9 33 11 29 34 30 32 26 43 39 31 41 42 20 28 35 37 45 44 40 Lépésköz: 7 2. lépés Rendezés előtt

497 7 12 23 4 5 22 3 15 13 1 6 8 10 2 18 14 19 25 21 38 36 24 27 16 17 9 33 11 29 34 30 32 26 43 39 31 41 42 20 28 35 37 45 44 40 Lépésköz: 7 2. lépés Rendezés után

498 7 12 23 4 5 22 3 15 13 1 6 8 10 2 18 14 19 25 21 38 36 24 27 16 17 9 33 11 29 34 30 32 26 43 39 31 41 42 20 28 35 37 45 44 40 Lépésköz: 7 3. lépés Rendezés előtt

499 7 12 1 4 5 22 3 15 13 16 6 8 10 2 18 14 19 25 21 38 36 24 27 23 17 9 33 11 29 34 30 32 26 43 39 31 41 40 20 28 35 37 45 44 42 Lépésköz: 7 3. lépés Rendezés után

500 7 12 1 4 5 22 3 15 13 16 6 8 10 2 18 14 19 25 21 38 36 24 27 23 17 9 33 11 29 34 30 32 26 43 39 31 41 40 20 28 35 37 45 44 42 Lépésköz: 7 4. lépés Rendezés előtt

501 7 12 1 4 5 22 3 15 13 16 6 8 10 2 18 14 19 17 21 38 36 24 27 23 20 9 33 11 29 34 30 25 26 43 39 31 41 40 32 28 35 37 45 44 42 Lépésköz: 7 4. lépés Rendezés után

502 7 12 1 4 5 22 3 15 13 16 6 8 10 2 18 14 19 17 21 38 36 24 27 23 20 9 33 11 29 34 30 25 26 43 39 31 41 40 32 28 35 37 45 44 42 Lépésköz: 7 5. lépés Rendezés előtt

503 7 12 1 4 5 22 3 15 13 16 6 8 10 2 18 14 19 17 9 38 36 24 27 23 20 21 33 11 29 34 30 25 26 43 39 31 41 40 32 28 35 37 45 44 42 Lépésköz: 7 5. lépés Rendezés után

504 7 12 1 4 5 22 3 15 13 16 6 8 10 2 18 14 19 17 9 38 36 24 27 23 20 21 33 11 29 34 30 25 26 43 39 31 41 40 32 28 35 37 45 44 42 Lépésköz: 7 6. lépés Rendezés előtt

505 7 12 1 4 5 10 3 15 13 16 6 8 22 2 18 14 19 17 9 33 36 24 27 23 20 21 35 11 29 34 30 25 26 38 39 31 41 40 32 28 43 37 45 44 42 Lépésköz: 7 6. lépés Rendezés után

506 7 12 1 4 5 10 3 15 13 16 6 8 22 2 18 14 19 17 9 33 36 24 27 23 20 21 35 11 29 34 30 25 26 38 39 31 41 40 32 28 43 37 45 44 42 Lépésköz: 7 7. lépés Rendezés előtt

507 7 12 1 4 5 10 2 15 13 16 6 8 22 3 18 14 19 17 9 33 11 24 27 23 20 21 35 36 29 34 30 25 26 38 37 31 41 40 32 28 43 39 45 44 42 Lépésköz: 7 7. lépés Rendezés után

508 7 12 1 4 5 10 2 15 13 16 6 8 22 3 18 14 19 17 9 33 11 24 27 23 20 21 35 36 29 34 30 25 26 38 37 31 41 40 32 28 43 39 45 44 42 Lépésköz: 3 1. lépés Rendezés előtt

509 2 12 1 4 5 10 7 15 13 9 6 8 14 3 18 16 19 17 20 33 11 22 27 23 24 21 35 28 29 34 30 25 26 36 37 31 38 40 32 41 43 39 45 44 42 Lépésköz: 3 1. lépés Rendezés után

510 2 12 1 4 5 10 7 15 13 9 6 8 14 3 18 16 19 17 20 33 11 22 27 23 24 21 35 28 29 34 30 25 26 36 37 31 38 40 32 41 43 39 45 44 42 Lépésköz: 3 2. lépés Rendezés előtt

511 2 3 1 4 5 10 7 6 13 9 12 8 14 15 18 16 19 17 20 21 11 22 25 23 24 27 35 28 29 34 30 33 26 36 37 31 38 40 32 41 43 39 45 44 42 Lépésköz: 3 2. lépés Rendezés után

512 2 3 1 4 5 10 7 6 13 9 12 8 14 15 18 16 19 17 20 21 11 22 25 23 24 27 35 28 29 34 30 33 26 36 37 31 38 40 32 41 43 39 45 44 42 Lépésköz: 3 3. lépés Rendezés előtt

513 2 3 1 4 5 8 7 6 10 9 12 11 14 15 13 16 19 17 20 21 18 22 25 23 24 27 26 28 29 31 30 33 32 36 37 34 38 40 35 41 43 39 45 44 42 Lépésköz: 3 3. lépés Rendezés után

514 A részben rendezett tömb az utolsó lépés előtt
2 3 1 4 5 8 7 6 10 9 12 11 14 15 13 16 19 17 20 21 18 22 25 23 24 27 26 28 29 31 30 33 32 36 37 34 38 40 35 41 43 39 45 44 42 A részben rendezett tömb az utolsó lépés előtt


Letölteni ppt "Nevezetes algoritmusok"