Az előadás letöltése folymat van. Kérjük, várjon

Az előadás letöltése folymat van. Kérjük, várjon

Sorozatszámítás (N,A,s) s := kezdőérték Ciklus i=1-től N-ig s := s művelet A(i) Ciklus vége Eljárás vége Sorozatszámítás.

Hasonló előadás


Az előadások a következő témára: "Sorozatszámítás (N,A,s) s := kezdőérték Ciklus i=1-től N-ig s := s művelet A(i) Ciklus vége Eljárás vége Sorozatszámítás."— Előadás másolata:

1 Sorozatszámítás (N,A,s) s := kezdőérték Ciklus i=1-től N-ig s := s művelet A(i) Ciklus vége Eljárás vége Sorozatszámítás

2 Példa összegzésre Adott egy 11 elemű tömb számokkal feltöltve. Mennyi a tömbben lévő számok összege?

3 A() Eljárás Összead (N, A, s) s:=0 Ciklus i=1-től N-ig s:=s+A(i) Ciklus vége Eljárás vége 1 N ↓

4 A() Eljárás Összead (N, A, s) s:=0 Ciklus i=1-től N-ig s:=s+A(i) Ciklus vége Eljárás vége 1 N S = 0

5 A() Eljárás Összead (N, A, s) s:=0 Ciklus i=1-től N-ig s:=s+A(i) Ciklus vége Eljárás vége 1 N S = 0 i = 1

6 A() Eljárás Összead (N, A, s) s:=0 Ciklus i=1-től N-ig s:=s+A(i) Ciklus vége Eljárás vége 1 N S = 0+1 i = 1

7 A() Eljárás Összead (N, A, s) s:=0 Ciklus i=1-től N-ig s:=s+A(i) Ciklus vége Eljárás vége 1 N S = 1 i = 1

8 A() Eljárás Összead (N, A, s) s:=0 Ciklus i=1-től N-ig s:=s+A(i) Ciklus vége Eljárás vége 1 N S = 1 i = 2

9 A() Eljárás Összead (N, A, s) s:=0 Ciklus i=1-től N-ig s:=s+A(i) Ciklus vége Eljárás vége 1 N S = 1+5 i = 2

10 A() Eljárás Összead (N, A, s) s:=0 Ciklus i=1-től N-ig s:=s+A(i) Ciklus vége Eljárás vége 1 N S = 6 i = 2

11 A() Eljárás Összead (N, A, s) s:=0 Ciklus i=1-től N-ig s:=s+A(i) Ciklus vége Eljárás vége 1 N S = 6 i = 3

12 A() Eljárás Összead (N, A, s) s:=0 Ciklus i=1-től N-ig s:=s+A(i) Ciklus vége Eljárás vége 1 N S = 6+10 i = 3

13 A() Eljárás Összead (N, A, s) s:=0 Ciklus i=1-től N-ig s:=s+A(i) Ciklus vége Eljárás vége 1 N S = 16 i = 3

14 A() Eljárás Összead (N, A, s) s:=0 Ciklus i=1-től N-ig s:=s+A(i) Ciklus vége Eljárás vége 1 N S = 16 i = 4

15 A() Eljárás Összead (N, A, s) s:=0 Ciklus i=1-től N-ig s:=s+A(i) Ciklus vége Eljárás vége 1 N S = 16+7 i = 4

16 A() Eljárás Összead (N, A, s) s:=0 Ciklus i=1-től N-ig s:=s+A(i) Ciklus vége Eljárás vége 1 N S = 23 i = 4

17 A() Eljárás Összead (N, A, s) s:=0 Ciklus i=1-től N-ig s:=s+A(i) Ciklus vége Eljárás vége 1 N S = 23 i = 5

18 A() Eljárás Összead (N, A, s) s:=0 Ciklus i=1-től N-ig s:=s+A(i) Ciklus vége Eljárás vége 1 N S = 23+9 i = 5

19 A() Eljárás Összead (N, A, s) s:=0 Ciklus i=1-től N-ig s:=s+A(i) Ciklus vége Eljárás vége 1 N S = 32 i = 5

20 A() Eljárás Összead (N, A, s) s:=0 Ciklus i=1-től N-ig s:=s+A(i) Ciklus vége Eljárás vége 1 N S = 32 i = 6

21 A() Eljárás Összead (N, A, s) s:=0 Ciklus i=1-től N-ig s:=s+A(i) Ciklus vége Eljárás vége 1 N S = 32+3 i = 6

22 A() Eljárás Összead (N, A, s) s:=0 Ciklus i=1-től N-ig s:=s+A(i) Ciklus vége Eljárás vége 1 N S = 35 i = 6

23 A() Eljárás Összead (N, A, s) s:=0 Ciklus i=1-től N-ig s:=s+A(i) Ciklus vége Eljárás vége 1 N S = 35 i = 7

24 A() Eljárás Összead (N, A, s) s:=0 Ciklus i=1-től N-ig s:=s+A(i) Ciklus vége Eljárás vége 1 N S = i = 7

25 A() Eljárás Összead (N, A, s) s:=0 Ciklus i=1-től N-ig s:=s+A(i) Ciklus vége Eljárás vége 1 N S = 46 i = 7

26 A() Eljárás Összead (N, A, s) s:=0 Ciklus i=1-től N-ig s:=s+A(i) Ciklus vége Eljárás vége 1 N S = 46 i = 8

27 A() Eljárás Összead (N, A, s) s:=0 Ciklus i=1-től N-ig s:=s+A(i) Ciklus vége Eljárás vége 1 N S = 46+2 i = 8

28 A() Eljárás Összead (N, A, s) s:=0 Ciklus i=1-től N-ig s:=s+A(i) Ciklus vége Eljárás vége 1 N S = 48 i = 8

29 A() Eljárás Összead (N, A, s) s:=0 Ciklus i=1-től N-ig s:=s+A(i) Ciklus vége Eljárás vége 1 N S = 48 i = 9

30 A() Eljárás Összead (N, A, s) s:=0 Ciklus i=1-től N-ig s:=s+A(i) Ciklus vége Eljárás vége 1 N S = i = 9

31 A() Eljárás Összead (N, A, s) s:=0 Ciklus i=1-től N-ig s:=s+A(i) Ciklus vége Eljárás vége 1 N S = 70 i = 9

32 A() Eljárás Összead (N, A, s) s:=0 Ciklus i=1-től N-ig s:=s+A(i) Ciklus vége Eljárás vége 1 N S = 70 i = 10

33 A() Eljárás Összead (N, A, s) s:=0 Ciklus i=1-től N-ig s:=s+A(i) Ciklus vége Eljárás vége 1 N S = 70+4 i = 10

34 A() Eljárás Összead (N, A, s) s:=0 Ciklus i=1-től N-ig s:=s+A(i) Ciklus vége Eljárás vége 1 N S = 74 i = 10

35 A() Eljárás Összead (N, A, s) s:=0 Ciklus i=1-től N-ig s:=s+A(i) Ciklus vége Eljárás vége 1 N S = 74 i = 11

36 A() Eljárás Összead (N, A, s) s:=0 Ciklus i=1-től N-ig s:=s+A(i) Ciklus vége Eljárás vége 1 N S = 74+6 i = 11

37 A() Eljárás Összead (N, A, s) s:=0 Ciklus i=1-től N-ig s:=s+A(i) Ciklus vége Eljárás vége 1 N S = 80 i = 11

38 A() Eljárás Összead (N, A, s) s:=0 Ciklus i=1-től N-ig s:=s+A(i) Ciklus vége Eljárás vége 1 N S = 80 ↑


Letölteni ppt "Sorozatszámítás (N,A,s) s := kezdőérték Ciklus i=1-től N-ig s := s művelet A(i) Ciklus vége Eljárás vége Sorozatszámítás."

Hasonló előadás


Google Hirdetések