Az előadás letöltése folymat van. Kérjük, várjon

Az előadás letöltése folymat van. Kérjük, várjon

Algoritmusok Algoritmus szerkezetek Algoritmus: egy feladat megoldására szolgáló egyértelműen végrehajtandó folyamat (tevékenység sorozat), mely véges.

Hasonló előadás


Az előadások a következő témára: "Algoritmusok Algoritmus szerkezetek Algoritmus: egy feladat megoldására szolgáló egyértelműen végrehajtandó folyamat (tevékenység sorozat), mely véges."— Előadás másolata:

1 Algoritmusok Algoritmus szerkezetek Algoritmus: egy feladat megoldására szolgáló egyértelműen végrehajtandó folyamat (tevékenység sorozat), mely véges idő alatt befejeződik Egyszerű utasítás: ami egyértelműen elvégezhető, magáért beszél: pl matematikai, fizikai képletek Összetett utasítás: több elemi utasításra is lebontható, ha nem egyértelmű, akkor azzá kell tenni, részekre kell bontani. Tevékenység=utasítás Szekvencia: utasítások egymás után való elvégzése Elágazás: feltételhez kötött utasítások végrehajtása, választás tevékenységek közül Ciklus: adott számszor lefutó, vagy feltételhez kötött többször megismételt utasítás

2 Algoritmusok Algoritmus szerkezetek Szekvencia: Tevékenység 1 Tevékenység 2

3 Algoritmusok Algoritmus szerkezetek Elágazás: 1.Ha feltétel akkor utasítás 2.Ha feltétel akkor utasítás 1 különben utasítás 2 3.Ha feltétel akkor utasítás 1, utasítás 2 különben utasítás 3, utasítás 4 elágazás vége 4.Elágazás feltétel 1 esetén utasítás 1 feltétel 2 esetén utasítás 2 feltétel 3 esetén utasítás 3 … feltételn esetén utasítás n egyébként utasítas n+1 elágazás vége

4 Algoritmusok Algoritmus szerkezetek Ciklus: 1.Adott számszor lefutó ciklus Ciklus n-szer utasítás ciklus vége 2.Számlálós ciklus: a.Ciklus i:=kezdőértéktől végértékig ciklusmag (ide írom az utasításokat) ciklus vége b.Ciklus i:=kezdőértéktől végértékig x-esével ciklusmag (ide írom az utasításokat) ciklus vége

5 Algoritmusok Algoritmus szerkezetek Ciklus: 3.Előltesztelős ciklus Ciklus amíg feltétel ciklusmag ciklus vége Ahhoz, hogy a ciklusban maradjunk, azaz, hogy elvégezzük-e az ott szereplő utasítást megadunk előre egy feltételt 4.Hátultesztelős ciklus Ciklus ciklusmag feltétel ciklus vége Az utasítás elvégzése után megvizsgálja a feltételt, hogy teljesül-e, azaz hogy folytassa-e a ciklusban leírt utasításokat, vagy kilépjen. Egyszer biztosan végrehajtódik. Akkor fejezzük be a végrehajtást, ha a logikai kifejezés hamis értékű.

6 Algoritmusok Adatok és algoritmusok kapcsolata 1.Egy adatból egy adattranszformáció 2.Egy adatból több adatszekvencia 3.Sok azonos jellegű adatból több különböző adatciklus 4.Sok azonos jellegű adatból sok azonos jellegű adatciklus

7 Algoritmusok Milyen lehet egy adat a)Egyszerű: skaláradat b)Sok azonos jellegű adat (sorozatok): vektor, mátrix tömb(1..n:valós), tömb(1..n,1..m:valós) c)Több információt tároló adat: rekord d)Több információt tároló adat, de lehet különböző rész is: alternatív rekord


Letölteni ppt "Algoritmusok Algoritmus szerkezetek Algoritmus: egy feladat megoldására szolgáló egyértelműen végrehajtandó folyamat (tevékenység sorozat), mely véges."

Hasonló előadás


Google Hirdetések