Az előadás letöltése folymat van. Kérjük, várjon

Az előadás letöltése folymat van. Kérjük, várjon

Nagypontosságú aritmetika II.. ELTE Nagypontosságú aritmetika: közelítések Gyök(2) közelítése: Pell egyenlet: A P 2 –N*Q 2 =4 egyenletnek végte- len sok.

Hasonló előadás


Az előadások a következő témára: "Nagypontosságú aritmetika II.. ELTE Nagypontosságú aritmetika: közelítések Gyök(2) közelítése: Pell egyenlet: A P 2 –N*Q 2 =4 egyenletnek végte- len sok."— Előadás másolata:

1 Nagypontosságú aritmetika II.

2 ELTE Nagypontosságú aritmetika: közelítések Gyök(2) közelítése: Pell egyenlet: A P 2 –N*Q 2 =4 egyenletnek végte- len sok megoldása van, ha N nem négyzetszám. N=2 esetén legyen Ha (P n,Q n ) megoldása a Pell egyenletnek, akkor (P n+1,Q n+1 ) is az, tehát: Zsakó László: Nagypontosságú aritmetika 2/15

3 ELTE Nagypontosságú aritmetika: közelítések Gyök(2) közelítése M lépésben: Gyök2(M,P,Q): (P,Q):=(6,4) Ciklus i=1-től M-ig Q:=P*Q; P:=P*P-2 Ciklus vége Eljárás vége Zsakó László: Nagypontosságú aritmetika 3/15

4 ELTE Nagypontosságú aritmetika: közelítések Az e közelítése: eközelítés(M,P,Q): (P,Q):=(1,M) Ciklus i=M-től 2-ig -1-esével P:=P+Q; Q:=Q*(i-1) Ciklus vége P:=P+Q Eljárás vége Zsakó László: Nagypontosságú aritmetika 4/15

5 ELTE Nagypontosságú aritmetika: közelítések A  közelítése: Nevezetes törtek: 256/81  3.16, 22/7 >  > 223/71 Wallis formula: piközelítés(M,P,Q): (P,Q):=(1,1) Ciklus i=2-től M-ig 2-esével P:=P*i*i; Q:=Q*(i-1)*(i-1) Ciklus vége Q:=Q*(M+1) Eljárás vége Zsakó László: Nagypontosságú aritmetika 5/15

6 ELTE Nagypontosságú aritmetika: közelítések A  közelítése: arctg(x,M): R:=x; y:=x; e:=-1 Ciklus i=3-től M-ig 2-esével y:=y*x*x; R:=R+e*y/i; e:=-e Ciklus vége arctg:=R Eljárás vége Zsakó László: Nagypontosságú aritmetika 6/15

7 ELTE Nagypontosságú aritmetika: számrendszerek Általános feladat: (  u n...u 1 u 0,u -1...u -m ) A →(  v p...v 1 v 0,v -1,...v -q ) B ahol Kérdések:  pozitív számból pozitív, negatív számból negatív lesz?  egészrészből egészrész, törtrészből törtrész lesz?  A=B K, B=A K ? Zsakó László: Nagypontosságú aritmetika 7/15

8 ELTE Nagypontosságú aritmetika: számrendszerek Egész számok: B-vel osztás A alapúban U A→ (v m...v 0 ) B Átalakítás(U,V): i:=0 Ciklus amíg U>0 V.t(i):=U mod B; U:=U div B i:=i+1 Ciklus vége V.N:=i-1 Eljárás vége Zsakó László: Nagypontosságú aritmetika 8/15

9 ELTE Nagypontosságú aritmetika: számrendszerek Egész számok: A-val szorzás B alapúban (u n...u 0 ) A →V B Átalakítás(U,V): V:=U.t(n) Ciklus i=n-1-től 0-ig -1-esével V:=V*A+U.t(i) Ciklus vége Eljárás vége Zsakó László: Nagypontosságú aritmetika 9/15

10 ELTE Nagypontosságú aritmetika: számrendszerek Törtek: B-vel szorzás A alapúban U A →(0,v -1,...v -m ) B Átalakítás(U,V): i:=-1 Ciklus amíg U≠0 és i>-Maxm V.t(i):=egészrész(U*B) U:=törtrész(U*B) i:=i-1 Ciklus vége Eljárás vége Zsakó László: Nagypontosságú aritmetika 10/15

11 ELTE Nagypontosságú aritmetika: számrendszerek Törtek: A-val osztás B alapúban (0,u -1,...u -m ) A →V B ) Átalakítás(U,V): V:=U.t(-m) Ciklus i=-n+1-től -1-ig V:=V/A+U.t(i) Ciklus vége V:=V/A Eljárás vége Zsakó László: Nagypontosságú aritmetika 11/15

12 ELTE Nagypontosságú aritmetika: számrendszerek Vegyes alapú számrendszerek  faktoriális  idő  … Megoldási ötlet:  átvitel helyes számolása Zsakó László: Nagypontosságú aritmetika 12/15

13 ELTE Nagypontosságú aritmetika: számrendszerek Negatív alapú számrendszer  -10-es számrendszer: Reciprok alapú számrendszerek  1/10 alapú számrendszer Zsakó László: Nagypontosságú aritmetika 13/15

14 ELTE Nagypontosságú aritmetika: számrendszerek Általános feladat: (  u n...u 1 u 0,u -1...u -m ) A →(  v p...v 1 v 0,v -1,...v -q ) B  Speciális eset: A=B K ( ...u 0,u -1...) A →(  … v k-1...v 1 v 0,v -1...v -k …) B  Speciális eset: B=A K ( ... u k-1...u 1 u 0,u -1...u -k...) A →(  …v 0,v -1 …) B Zsakó László: Nagypontosságú aritmetika 14/15

15 Zsakó László: Programozási alapismeretek M Vége


Letölteni ppt "Nagypontosságú aritmetika II.. ELTE Nagypontosságú aritmetika: közelítések Gyök(2) közelítése: Pell egyenlet: A P 2 –N*Q 2 =4 egyenletnek végte- len sok."

Hasonló előadás


Google Hirdetések