Az előadás letöltése folymat van. Kérjük, várjon

Az előadás letöltése folymat van. Kérjük, várjon

Algoritmizálás, adatmodellezés 1. előadás. Algoritmus-leíró eszközök Folyamatábra Irányított gráf, amely csomópontokból és őket összekötő élekből áll,

Hasonló előadás


Az előadások a következő témára: "Algoritmizálás, adatmodellezés 1. előadás. Algoritmus-leíró eszközök Folyamatábra Irányított gráf, amely csomópontokból és őket összekötő élekből áll,"— Előadás másolata:

1 Algoritmizálás, adatmodellezés 1. előadás

2 Algoritmus-leíró eszközök Folyamatábra Irányított gráf, amely csomópontokból és őket összekötő élekből áll, egyetlen induló és befejező éle van, az induló élből bármely csomópont elérhető, s bármely csomópontból el lehet jutni a befejező élre. Háromféle csomópontot tartalmaz: /30Pap Gáborné, Zsakó László: Algoritmizálás, adatmodellezés

3 Algoritmus-leíró eszközök Folyamatábra A csomópontokból előállíthatók az algoritmikus struktúrák: /30Pap Gáborné, Zsakó László: Algoritmizálás, adatmodellezés

4 Algoritmus-leíró eszközök Definíció: Strukturált programnak nevezzük azt a programot, amely csak a fenti három algoritmikus szerkezetet (szekvencia, elágazás, ciklus) tartalmazza. Nem strukturált alapszerkezetek: /30Pap Gáborné, Zsakó László: Algoritmizálás, adatmodellezés

5 Algoritmus-leíró eszközök Nem strukturált alapszerkezetek: /30Pap Gáborné, Zsakó László: Algoritmizálás, adatmodellezés

6 Algoritmus-leíró eszközök Kiegészítő elemek a folyamatábrához: /30Pap Gáborné, Zsakó László: Algoritmizálás, adatmodellezés

7 Algoritmus-leíró eszközök Struktogram Programgráf élek nélkül: /30Pap Gáborné, Zsakó László: Algoritmizálás, adatmodellezés

8 Algoritmus-leíró eszközök Mondatszerű leírás Program: utasítássorok Program vége. azonosító := kifejezés Be: azonosítók[feltételek] Ki: kifejezések [formátum megkötés] /30Pap Gáborné, Zsakó László: Algoritmizálás, adatmodellezés

9 Algoritmus-leíró eszközök Mondatszerű leírás Ha logikai kifejezés akkor utasítássor Ha logikai kifejezés akkor utasítássor 1 különben utasítássor 2 Ha logikai kifejezés akkor utasítássorok 1 különben utasítássorok 2 Elágazás vége /30Pap Gáborné, Zsakó László: Algoritmizálás, adatmodellezés

10 Algoritmus-leíró eszközök Mondatszerű leírás Ha logikai kifejezés 1 akkor utasítássorok 1 különben ha logikai kifejezés 2 akkor utasítássorok 2 különben ha... különben utasítássorok n Elágazás vége /30Pap Gáborné, Zsakó László: Algoritmizálás, adatmodellezés

11 Algoritmus-leíró eszközök Mondatszerű leírás Elágazás feltétel 1 esetén utasítássorok 1 feltétel 2 esetén utasítássorok 2 … feltétel n esetén utasítássorok n egyéb esetben utasítássorok n+1 Elágazás vége /30Pap Gáborné, Zsakó László: Algoritmizálás, adatmodellezés

12 Algoritmus-leíró eszközök Mondatszerű leírás Ciklus amíg logikai kifejezés utasítássorok Ciklus vége Ciklus utasítássorok amíg logikai kifejezés Ciklus vége /30Pap Gáborné, Zsakó László: Algoritmizálás, adatmodellezés

13 Algoritmus-leíró eszközök Mondatszerű leírás Ciklus cv=K-tól V-ig utasítássorok Ciklus vége Ciklus cv=K-tól V-ig L-esével utasítássorok Ciklus vége Ciklus cv  H utasítássorok Ciklus vége /30Pap Gáborné, Zsakó László: Algoritmizálás, adatmodellezés

14 Algoritmus-leíró eszközök Mondatszerű leírás Eljárás Eljárásnév(paraméterek): utasítássorok Eljárás vége. Függvény Függvénynév(paraméterek): értéktípus utasítássorok Függvénynév := kifejezés Függvény vége /30Pap Gáborné, Zsakó László: Algoritmizálás, adatmodellezés

15 Algoritmus-leíró eszközök Mondatszerű leírás Művelet Operátornév(paraméterek) név: értéktípus utasítássorok név := kifejezés Eljárás vége /30Pap Gáborné, Zsakó László: Algoritmizálás, adatmodellezés

16 Pascal programozási nyelv A Pascal nyelv elemei Mindent deklarálni kell a felhasználása előtt. Mindent mindentől pontosvessző választ el. Műveletek (nem szokásosak): and, or, not, xor, div, mod. Blokkstruktúra, hatáskör, láthatóság. Fejlesztői környezet Geany /30Pap Gáborné, Zsakó László: Algoritmizálás, adatmodellezés

17 Kódolási szabályok /30Pap Gáborné, Zsakó László: Algoritmizálás, adatmodellezés Program

18 Kódolási szabályok /30Pap Gáborné, Zsakó László: Algoritmizálás, adatmodellezés Deklarációk

19 Kódolási szabályok /30Pap Gáborné, Zsakó László: Algoritmizálás, adatmodellezés Típusok: Speciális egész: longint, byte, word. Speciális műveletek: succ, pred, ord, shl, shr, >.

20 Kódolási szabályok /30Pap Gáborné, Zsakó László: Algoritmizálás, adatmodellezés Típusok: Fájl típus: file of elemtípus; szövegfájl típus: text.

21 Kódolási szabályok /30Pap Gáborné, Zsakó László: Algoritmizálás, adatmodellezés Elemi utasítások

22 Kódolási szabályok /30Pap Gáborné, Zsakó László: Algoritmizálás, adatmodellezés Elágazások

23 Kódolási szabályok /30Pap Gáborné, Zsakó László: Algoritmizálás, adatmodellezés Elágazások

24 Kódolási szabályok /30Pap Gáborné, Zsakó László: Algoritmizálás, adatmodellezés Elágazások

25 Kódolási szabályok /30Pap Gáborné, Zsakó László: Algoritmizálás, adatmodellezés Ciklusok

26 Kódolási szabályok /30Pap Gáborné, Zsakó László: Algoritmizálás, adatmodellezés Ciklusok

27 Kódolási szabályok /30Pap Gáborné, Zsakó László: Algoritmizálás, adatmodellezés Eljárások Eljárás név(par,...): deklarációk utasítások Eljárás vége. Procedure név(par...); deklarációk Begin utasítások End Függvény név(par,...):típus deklarációk utasítások név:=érték Függvény vége. Function név(fpar;...):típus; deklarációk Begin utasítások név:=érték End  [hbv1][hbv1] M21_1_1_10K.png

28 Kódolási szabályok /30Pap Gáborné, Zsakó László: Algoritmizálás, adatmodellezés Operátorok Művelet név(par 1,par 2 ):típus deklarációk utasítások név:=érték Művelet vége. operator OP(par1,par2)kimenet:típus deklarációk Begin utasítások kimenet:=érték End  [hbv1][hbv1] M21_1_1_10K.png

29 Algoritmizálás, adatmodellezés 1. előadás vége


Letölteni ppt "Algoritmizálás, adatmodellezés 1. előadás. Algoritmus-leíró eszközök Folyamatábra Irányított gráf, amely csomópontokból és őket összekötő élekből áll,"

Hasonló előadás


Google Hirdetések