Az előadás letöltése folymat van. Kérjük, várjon

Az előadás letöltése folymat van. Kérjük, várjon

Programozási tételek. Összegzés ( sorozatszámítás ) tétele Összegzés: S:=F 0 Ciklus i:=1-től N-ig S:=f(S,t(i)) Ciklus vége Eljárás vége 2.

Hasonló előadás


Az előadások a következő témára: "Programozási tételek. Összegzés ( sorozatszámítás ) tétele Összegzés: S:=F 0 Ciklus i:=1-től N-ig S:=f(S,t(i)) Ciklus vége Eljárás vége 2."— Előadás másolata:

1 Programozási tételek

2 Összegzés ( sorozatszámítás ) tétele Összegzés: S:=F 0 Ciklus i:=1-től N-ig S:=f(S,t(i)) Ciklus vége Eljárás vége 2

3 1. feladat: Írj programot, amely összeadja az első 100 természetes számot! int i, s; s = 0; for (i = 1; i <= 100; i++) s = s + i; Console.Write("Az első 100 szám összege: {0}", s); Console.ReadKey(); 3

4 2. feladat: Egy héten keresztül mértük a déli hőmérsékleteket. Írj programot, ami meghatározza az átlagukat! double [ ] t=new double [7]; double s; int i; s = 0; for (i=0; i<7; i++) { Console.Write("{0}. nap: ", i+1); t[i]=Convert.ToDouble(Console.ReadLine()); s = s + t[i]; } Console.WriteLine("A heti átlag: {0} °C", s/7); Console.ReadKey(); 4

5 3. feladat: Számoljuk ki egy 30 fős osztály dolgozatainak átlagát! (Az osztályzatokat véletlen számként generáljuk!) int [ ] t=new int [30]; int i,s; Random rnd =new Random(); s=0; for (i=0; i<30; i++) { t[i]=rnd.Next(1,6); Console.Write(" {0}", t[i]); s = s + t[i]; } Console.WriteLine(); Console.Write("Az osztály átlaga: {0}", s / 30); Console.ReadKey(); 5

6 Megszámlálás tétele (Hány db adott tulajdonságú elem van?) Megszámlálás: DB:=0 Ciklus i:=1-től N-ig Ha (t[i] adott tulajdonságú) akkor DB:=DB+1 Ciklus vége Eljárás vége 6

7 1. feladat: Készíts programot, amely meghatározza, hogy egy egész számokból álló 20 elemű tömbben mennyi a pozitív elemek száma! int [ ] t=new int [20]; int i,db; Random rnd =new Random(); db = 0; for (i=0; i<20; i++) { t[i]=rnd.Next(-10,10); Console.Write(" {0}", t[i]); if (t[i]>0) db=db+1; } Console.WriteLine(); Console.Write("A pozitív elemek száma: {0}", db); Console.ReadKey(); 7

8 2. feladat: Határozd meg egy szövegben az „a” betűk számát! string s; int i,db; Console.Write("Írj be egy szöveget!"); s=Console.ReadLine(); db = 0; for (i=0;i

9 3. feladat: Módosítsd az első feladatot úgy, hogy a 0 és a negatív elemek számát is megadja a program! int[ ] t = new int[20]; int i, dbn,db0,dbp; Random rnd = new Random(); dbn = 0; db0 = 0; dbp = 0; for (i = 0; i < 20; i++) { t[i] = rnd.Next(-10, 10); Console.Write(" {0}", t[i]); if (t[i] > 0) dbp = dbp + 1; else if (t[i] == 0) db0 = db0 + 1; else dbn = dbn + 1; } Console.WriteLine(); Console.WriteLine("A pozitív elemek száma: {0}", dbp); Console.WriteLine("A nulla elemek száma: {0}", db0); Console.WriteLine("A negatív elemek száma: {0}", dbn); Console.ReadKey(); 9

10 Szélsőérték kiválasztás tétele (A legnagyobb vagy legkisebb elemet, annak sorszámát, vagy mindkettőt adja meg.) Maximumkiválasztás: MAX:=1, MAXERTEK:=t[1] Ciklus i:=2-től N-ig Ha (MAXERTEK

11 1. feladat: Adott egy 10 elemű számsor, adjuk meg a legnagyobb elemét! int[ ] t = new int[10]; int i, maxertek; Random rnd = new Random(); for (i = 0; i < 10; i++) { t[i] = rnd.Next(-10, 10); Console.Write(" {0}", t[i]); } Console.WriteLine(); maxertek = t[0]; for (i = 1; i < 10; i++) { if (maxertek

12 2. feladat: Módosítsd az előző programot úgy, hogy a sorszámot is írja ki a program! int[ ] t = new int[10]; int i, max, maxertek; Random rnd = new Random(); for (i = 0; i < 10; i++) { t[i] = rnd.Next(-10, 10); Console.Write(" {0}", t[i]); } Console.WriteLine(); max = 0; maxertek = t[0]; for (i = 1; i < 10; i++) if (maxertek < t[i]) { maxertek = t[i]; max = i; } Console.WriteLine("A {0} elem a legnagyobb, értéke {1}.", max+1,maxertek); Console.ReadKey(); 12

13 Eldöntés tétele (Van-e? Mindegy mennyi, az elsőt kell megtalálni. VAGY. Mind olyan-e?) Eldöntés: i:=1 Ciklus amíg (i<=N és nem adott tulajdonságú t[i]) i:=i+1 Ciklus vége Ha i<=N akkor Ki: „Van” különben Ki: „Nincs” Elágazás vége Eljárás vége 13

14 1. feladat: Írj programot, ami beolvas 10 pozitív egész számot, és eldönti, hogy van-e köztük 5-tel osztható! int[ ] t = new int[10]; int i; Random rnd = new Random(); for (i = 0; i < 10; i++) { t[i] = rnd.Next(1,100); Console.Write(" {0}", t[i]); } i=0; while (i < 10 && t[i]%5!=0) i++; if (i < 10) Console.Write("Van."); else Console.Write("Nincs."); Console.ReadKey(); 14

15 2. feladat: Ismert 20 db autó fogyasztása (100km/l). Írj programot, ami eldönti, hogy minden autó 8l alatt fogyasztott-e! int[ ] t = new int[20]; int i; Random rnd = new Random(); for (i = 0; i < 10; i++) { t[i] = rnd.Next(4,20); Console.Write(" {0}", t[i]); } i=0; while (i < 10 && t[i]<8) i++; if (i >= 10) Console.Write("Mind."); else Console.Write("Nem mind."); Console.ReadKey(); 15

16 Kiválasztás tétele (Egy adott tulajdonságú elemet ad meg. Biztos, hogy van ilyen. Ha több is van, csak az első kell.) Kiválasztás: i:=1 Ciklus amíg (nem adott tulajdonságú t[i]) i:=i+1 Ciklus vége SORSZ:=i Eljárás vége 16

17 1. feladat: Írj programot, ami egy 10 elemű tömb elemei közül kiválasztja az első 5-tel oszthatót! int[ ] t = new int[10]; int i; Random rnd = new Random(); for (i = 0; i < 10; i++) { t[i] = rnd.Next(1, 100); Console.Write(" {0}", t[i]); } Console.WriteLine(); i = 0; while (t[i] % 5 != 0) i++; Console.Write("A {0}. sorszámú elem osztható 5-tel.",i+1); Console.ReadKey(); 17

18 2. feladat: Egy téli hét déli hőmérsékleteit tároljuk egy tömbben. Adjuk meg egy nap sorszámát, amikor nem fagyott!. int[ ] t = new int[7]; int i; Random rnd = new Random(); for (i = 0; i < 7; i++) { t[i] = rnd.Next(-5, 5); Console.Write(" {0}", t[i]); } i = 0; while (t[i] < 0) i++; Console.Write("A {0}. napon nem fagyott.",i+1); Console.ReadKey(); 18

19 19


Letölteni ppt "Programozási tételek. Összegzés ( sorozatszámítás ) tétele Összegzés: S:=F 0 Ciklus i:=1-től N-ig S:=f(S,t(i)) Ciklus vége Eljárás vége 2."

Hasonló előadás


Google Hirdetések