Az előadás letöltése folymat van. Kérjük, várjon

Az előadás letöltése folymat van. Kérjük, várjon

TÁMOP 2.2.3-07/1-2F-2008-0011 Informatikai gyakorlatok 11. évfolyam Alapvető programozási tételek megvalósítása Czigléczky Gábor 2009.

Hasonló előadás


Az előadások a következő témára: "TÁMOP 2.2.3-07/1-2F-2008-0011 Informatikai gyakorlatok 11. évfolyam Alapvető programozási tételek megvalósítása Czigléczky Gábor 2009."— Előadás másolata:

1 TÁMOP /1-2F Informatikai gyakorlatok 11. évfolyam Alapvető programozási tételek megvalósítása Czigléczky Gábor 2009

2 Programozási tételek (1.) Vannak olyan típusfeladatok, amelyeket igen hasonlóan kell megoldani. Például: ◦ átlagszámítás egy sorozat elemein ◦ bizonyos feltételnek megfelelő elemek megszámolása ◦ legkisebb / legnagyobb elem meghatározása ◦ adott elem megkeresése Ezen feladatok megoldására általános algoritmusokat adunk, amelyeket programozási tételeknek nevezünk.

3 Programozási tételek (2.) A továbbiakban legyen: ◦ v: tetszőleges elemtípusú vektor ◦ n: egész (a vektor tényleges, valódi elemszáma) ◦ adott tulajdonság: a feladat szövegéből következő logikai függvény (pl. egy adott szám páros, nagyobb mint 1000, egyenlő egy konkrét értékkel, stb.) A vektor elemtípusa lehet struktúra is, de a tételt mindig a rekord egy mezőjére kell felírni.

4 Összegzés tétele (algoritmus) Adott a v[1..n] vektor, amelynek elemein értelmezhető az összeadás művelete. Számítsuk ki a vektor elemeinek összegét (ossz változó)! Algoritmus: ossz := 0 ciklus i:=1-től n-ig ossz := ossz + v[i] ciklus vége. Mire kell figyelni a kódolásnál? ◦ A kezdőérték nem biztos, hogy 0. ◦ C# nyelvben a tömb indexelése 0-tól indul.

5 Összegzés tétele (kód) Kód: int ossz = 0; for (int i=0; i

6 Megszámlálás tétele (algoritmus) Adott a v[1..n] vektor, amelynek elemein értelmezhető az adott tulajdonságfüggvény. Számoljuk meg, hogy a vektorban hány darab, az adott tulajdonságnak megfelelő elem található (db változó)! Algoritmus: db := 0 ciklus i:=1-től n-ig ha v[i] adott tulajdonságú akkor db := db + 1 ciklus vége. Mire kell figyelni a kódolásnál? ◦ Mindig adjunk 0-t kezdőértéknek! ◦ C# nyelvben a tömb indexelése 0-tól indul.

7 Megszámlálás tétele (kód) Kód (például legyen a tulajdonságfüggvény, hogy az adott elem páros): int db = 0; for (int i=0; i

8 Minimum- és maximumkiválasztás tétele (algoritmus) Adott a v[1..n] vektor, amelynek elemein értelmezhető a kisebb / nagyobb reláció. Válasszuk ki a vektor legkisebb / legnagyobb elemét! A min változó jelentse a minimum helyét, azaz indexét! Algoritmus: min := 1 ciklus i:=2-től n-ig ha v[i]

9 Minimum- és maximumkiválasztás tétele (kód) Kód: int min = 0; for (int i=1; i

10 Lineáris keresés tétele (algoritmus) Adott a v[1..n] vektor, amelynek elemein értelmezhető az adott tulajdonságfüggvény. Keressük meg a vektor első adott tulajdonságú elemét! Az l logikai változó legyen igaz, ha sikerült találni ilyen elemet, és ekkor az i tartalmazza az első adott tulajdonságú elem indexét. Algoritmus: i := 1 ciklus amíg i<=n és NEM(v[i] adott tulajdonságú) i := i+1 ciklus vége. l := (i<=n)

11 Lineáris keresés tétele (algoritmus) Mire kell figyelni a kódolásnál? ◦ C# esetén 0 kezdőértékkel kell indulnunk, és i<=n helyett mindenhol i

12 Lineáris keresés tétele (kód) Kód (például legyen a tulajdonságfüggvény, hogy az adott elem páros): int i = 0; while (i


Letölteni ppt "TÁMOP 2.2.3-07/1-2F-2008-0011 Informatikai gyakorlatok 11. évfolyam Alapvető programozási tételek megvalósítása Czigléczky Gábor 2009."

Hasonló előadás


Google Hirdetések